Universal Clipboard only working one way

JonD25

macrumors 6502
Original poster
Feb 9, 2006
423
9
I can't seem to get universal clipboard working reliably. If I try and copy something from Notes on my iMac and paste into a different app on my iPhone, it pauses briefly like it's thinking, then nothing happens. If I try again, it only pastes what my iPhone last copied. But, if I copy something from my iPhone and then try and paste on my Mac, it works fine. What's going on?
 
  • Like
Reactions: freepomme

CTHarrryH

macrumors 68020
Jul 4, 2012
2,245
874
I have found that if I have done a copy on my Mac then I can't do a universal paste onto it. It always pastes what was copied on that Mac. If I have rebooted my mac and try the paste then it works (I did the reboot to test this specifically).
Certainly needs some work. for me, to be reliable. Like a paste and universal paste option
 

jjk454ss

macrumors 601
Jul 10, 2008
4,342
447
Same issue. I copy on my iPhone, and can paste it on iPad. Then I copy on my iPad, and what I had copied on my iPhone previously is what gets pasted on the iPhone, not the latest thing copied on the iPad.
 

VSMacOne

macrumors 601
Oct 18, 2008
4,705
1,425
I had the same issue up until today. I installed the latest beta of Sierra 10.12.1 and iOS 10.1 and VOILA it started working both ways. I didn't do anything different.
 
  • Like
Reactions: JuanGuapo

Thor774

macrumors regular
Sep 14, 2007
173
15
UNIVERSAL CLIPBOARD IS BUGGY AS HELL!

There are a lot of users with this problem, check here: https://www.reddit.com/r/MacOS/comments/51afxn/universal_clipboard_not_working/
I have tested everything written in that post on Reddit and the thing just refuses to work as advertised.
Back to my Mac: Check (stupid as hell that this has to be turned on? It is a just a security problem to deal with if you don't need it).
Bluetooth and WiFi: Check
iPhone showing under WiFi connections: Check
Handoff: Check
iPhone and Mac paired via bluetooth: Check
...
Seems like a buggy as hell function Apple rushed out from beta into the wild.
For me the stupid thing just work one way: From the iPhone to the Mac. And there is a stupid small delay every time you are going to paste something on the Mac anyway.
From the Mac to the iPhone it has just worked one or two times. When you tap on paste you just get this super annoying delay of almost 10 seconds and the action fails miserably. When you try again the iPhone just pastes the previous local clipboard content available but not the content from copied from the Mac.
Is is a pity seeing how lately Apple just rushes things out with terrible quality control into the users. The "just works" slogan is just a joke painted in our faces these days.
I am on an iPhone 7 Plus and a Retina MBP 2015 both with the latest OS updates.
 

Thor774

macrumors regular
Sep 14, 2007
173
15
Still the same here too. Works ok from iPhone to Mac, doesn't work from Mac to iPhone :/
 

Thor774

macrumors regular
Sep 14, 2007
173
15
This still sucks.
It was one of the best features introduced with Sierra and iOS 10 and it is frustrating that it is still working only one way, in my case from the iPhone --> Mac. And the stupid delay is also annoying.
Shame.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.