USB Drive won't mount on new MacBook, but mounts fine on 2010 MacBook

Discussion in 'macOS High Sierra (10.13)' started by Ilfracombe, Feb 13, 2018.

Tags:
  1. Ilfracombe macrumors newbie

    Joined:
    Jun 4, 2011
    #1
    Both my 2010 MacBook and my 2015 MacBook are running 10.13.3.

    My USB stick works fine on my 2010 MacBook.
    But on my 2015 MacBook it won't mount on the desktop, so I can't access the files it contains. However, it can be seen on Disk Utility, and when I run Disk First Aid, it says it is fine.

    (The USB worked with 10.13.2 on the MacBook 2015, although occasionally it needed to be inserted again. )

    The USB Stick is MAC OS Extended, journaled.

    Is there anything I can do?
     
  2. Ilfracombe thread starter macrumors newbie

    Joined:
    Jun 4, 2011
    #2
    I've just checked and in fact no USB drives will show up on the desktop, although they do on Disk Utility. I've checked the finder prefs, and the 'show External drives" is checked.
     
  3. Glmnet1 macrumors 6502a

    Joined:
    Oct 21, 2017
    #3
    You're saying it's not on the desktop, but is it on the left side of the finder window? Under Devices.
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    Does mounting them via Disk Utility do anything?
     
  5. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    Here's what I'd try:

    Take ONE USB flashdrive for experimental purposes.
    RE-initialize it on the 2015 MacBook using Disk Utility.
    Choose "Mac OS extended with journaling enabled".

    Does it re-initialize (erase) successfully?
    Does it them mount on the desktop?
    If you take it to the 2010 MacBook, will it mount up there, too?
     
  6. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #6
    def check this! & Finder>Preferences>General: check (or uncheck/recheck) External Disks...
     
  7. Ilfracombe thread starter macrumors newbie

    Joined:
    Jun 4, 2011
    #7
    No it isn't under devices.
    --- Post Merged, Feb 13, 2018 ---
    According to Disk Utility, it is already mounted. The option is to 'unmount'
    --- Post Merged, Feb 13, 2018 ---
    That is checked.
    --- Post Merged, Feb 13, 2018 ---
    Well well well,
    It seems to be back to normal again. I can't think of anything I did to make it happen.
    Thanks for all your help. If it happens again, I'll let you know.
     
  8. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #8
    Good. I think it's happened to me before. USB flash memory drives can be flaky and that's not surprising considering how cheap they are.
     

Share This Page