Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

MacRumors

macrumors bot
Original poster
Apr 12, 2001
56,981
19,827


Following the latest macOS Monterey 12.3 update, users are reporting several problems when using external monitors, ranging from Macs not detecting displays at all to inaccurate screen output, according to posts on the Apple Support and MacRumors forums.

24-inch-imac-and-macbook-monterey.jpeg

In the ten days since the update became available to the public, users have already reported issues with the update bricking Macs that have had logic board replacements and problems with using game controllers. Adding to the list of issues, users are now reporting that the update is causing problems with external monitors.

According to users on the Apple Support and MacRumors forums, some external displays connected over USB-C are no longer detected by Macs after updating to the latest macOS update. As one user on Apple Support reports:
After updating my Mac mini today to 12.3, my monitor now no longer displays an image via USB-C, just keeps saying on no signal on the monitor.

I have tried HDMI and same issue. The odd occasion it will display a picture but once I shutdown or restart the mac mini it does not display a picture. The mac is booting up. I have had to resort to connecting it to my old TV with HDMI connection.

This is so frustrating.
Other users have shared similar experiences. While many also report issues with USB-C displays, others also say that HDMI connections to the Mac are not being recognized. Some users have been able to crowdsource potential workarounds in the meantime. According to one user on the MacRumors Forums, the issue stems from macOS not recognizing a DisplayPort protocol version, which meant they had to change the version to an earlier one with poorer quality output.
I've solved this problem (on 2022-03-15). On my monitor (LG LCD 27 27UN880-B IPS) I've went into settings, and I've lowered the DisplayPortVersion from the default v1.4 to v1.2. As soon as I've lowered the monitor's DisplayPortVersion, my Mac with OS X 12.3 has started recognizing the second display correctly. It seems that the new OS X update has issues with a DisplayPortVersion 1.4 protocol (has faster data rate, faster refresh, and stream compression). Hope this helps.
Another short-term fix floated on both the Apple Support and MacRumors forums is to unplug the external display for a short time, plug it back into the Mac, and then plug the display back into a power outlet, after which it should work. Some users have also reported problems when using two external monitors with their Mac.

The issue of only one external display being recognized when two are connected to a Mac seems to have been present throughout the beta testing period for macOS 12.3. Even after release, however, the issue remains. As one user on the Apple Support forums relates:

2018 Mac Book Pro 15" and I have 2 external monitors (same viewsonic model), have been using fine for just under 2 years. After updating to 12.3, one is recognized and one is not and I have no clue why. I have swapped cables, connected other devices, including a iPad Pro (all fine) I have tried all 4 ports on the machine no difference. The Mac book flashes when the unrecognized monitor is plugged in, but never displays an image. the monitor seems to think it's connected (I don't get the no signal warning) nothing.... 8* the monitor is powered and the screen it bright (bleed from the backlight). The other monitor (same exact model) connects and works fine.
The online reports suggest that these issues are not arising when using Apple's new Studio Display, but instead with third-party monitors, such as those offered by BenQ and LG.

macOS 12.3 is Monterey's largest point-update since launch, bringing with it Universal Control along with several other new feature additions. MacRumors earlier this week reached out to Apple for comment on the issues users are experiencing so far with the latest macOS update. We'll update this post if we receive a response.

Article Link: Users Report External Monitor Issues After Updating to macOS Monterey 12.3
 

tmoerel

macrumors 6502a
Jan 24, 2008
764
1,135
No problems here on a 16" MBP M1 Max on 12.3 with a 4k and a 5k2k LG screen connected via two different OWC thunderbolt hubs connected with the original LG thunderbolt cables. Always detects and always the right resolutions.
 
  • Like
Reactions: dkamisato

Danfango

macrumors 6502a
Jan 4, 2022
755
3,039
London, UK
This doesn't surprise me. Dell and Intel screwed this up last year as well. My Iiyama display would not work with the WD19TB dock at all suddenly with the USB-C / DP cable. I had to use DP/DP suddenly which was a pain as it made it difficult to switch it between my mac and pc laptops.

Then there's the cheap Iiyama my daughter had connected to her gaming PC which decided it wast just not going to work after a display driver update with a cable that was working fine previously (HDMI) that worked fine on another computer!

Look at HDMI/HDCP nightmare as well. No streaming sticks worked on my 4 year old Samsung TV suddenly turning the thing to scrap value for me and resulting in me having to buy a damn Smart TV which I don't want.

The problem is really we have really crappy standards for display interfaces which are difficult for vendors to test out all combinations of likely problems. I'm not excusing Apple here for screwing it up as they should be aware of this but the real problem is that the standards and the implementations across the board are garbage.

One reason I bought the studio display was I don't have to argue with this pile of crap and spent hours in the cupboard playing find which cable works this week. I know this will be a well tested combo.

Also running Monterey for ref. ZERO problems so far.
 

singularity0993

macrumors regular
Oct 15, 2020
113
455
Now when will Apple fix their “intentionally” broken DSC support for DisplayPort? It’s was working in Catalina, but broken in Big Sur on Intel Macs (and Intel Macs only). Every DP connection now max out at 4k60hz or 4k120hz depending on your system, except for Apple’s own display (Pro Display XDR), which can still run at 6K.

I bought a 4k144hz display, only to find out my Mac cannot run at that resolution (ironically, 4k144hz can be achieved in Boot Camp). This issue has been reported many times but got totally no response. Does Apple even care about us Intel users any more?

For clarity, DSC is working on:
Any M1 Mac, Any Apple Display, or Any Mac below Catalina or in Boot Camp (provided the hardware is capable).

but is not working on:
Any Intel Mac running Big Sur or later that is connected to an non-apple display.

It’s just hard to believe Apple didn’t do this intentionally so that we have to buy M1 Macs or Apple Displays.
 

seaghost

macrumors newbie
Oct 19, 2020
15
11
This is really weird, I have Philips 276E8VJSB at home connected via Anker USB-C dongle and HDMI cable. Worked at 4K60hz from the very beginning, never had issues. Came today to work after a while and connected to LG 27'' UltraFine UHD IPS USB-C HDR with Ergo Stand via USB-C and a lot of issues with signal at first, then it only worked at 4K30hz couldn't get more, previously had issues on and off with USB-C cable what came with the screen, sometimes it charges MacBook Air M1, sometimes it does not. At the end I have decided to buy a new USB-C cable (https://www.amazon.de/gp/product/B096XBTWXL/) and it arrived today, after I have got connected it, it all worked perfectly, 4k@60Hz HDR, charging. Then I have disconnected new cable and connected old one that worked at 4K@30hz after last update 12.3 (21E230) and now it works at 4K@60hz all of a sudden. Definitely a lot of issues with the latest macOS update.
 

Mr. Dee

macrumors 68040
Dec 4, 2003
3,914
6,546
Jamaica
I keep thinking I need to upgrade to Monterey, and Apple keeps giving me reasons not to.
I personally won’t be upgrading to Monterrey until after macOS 13 is released. These OS updates are just too unstable even in commercial state. Besides, apart from universal control which is still in beta, there aren’t any must haves that make it real need to upgrade.
 

project_2501

macrumors 6502a
Jul 1, 2017
639
679
problems with my MBP 14" M1 Max with a Caldigit TS4 connected to an NEC professional display over DisplayPort.

never had problems before with my Intel MBP and the same display (which also worked perfectly with Chromebook's, Linux and Windows devices, even a raspberry pi).
 

falkon-engine

macrumors 6502a
Apr 30, 2010
563
1,638
M1 max, TS4 dock, on 12.3 and my dual monitors work fine via thunderbolt/dp1.4. 144 Hz 1440p. No issues here. I had an occasional issue where one of my monitors was occasionally slow to wake up but changing the TB cable between the dock and the Macintosh resolved that issue for me. Using an older TB3 cable seems to have resolved the issue. Weird.

12.3 also improved the stability of the TS4. 12.2.1 and 12.3 early betas I was pulling my hair out with crashes during resume from sleep. I was about to return the TS4, but with the 12.3 update, it’s been working fine. I’ve tested other TB4 docks with the m1 max and they were all fine as well the TS4 was the most finicky but now it behaves well.
 

MacRS4

macrumors 6502
Aug 18, 2010
308
429
London, UK
This has been doing my nut in, although stupidly didn't put it down to 12.3. I replaced my TB3 dock with a 4 and it's improved things, but it's still wonky.

I've a 5K Ultrafine next to a 4K LG. When it detects the 4k - which isn't always - it then up-scales the LG5K.

When the 4K isn't detected it's a hard reboot.

Hey ho.
 

uller6

macrumors 6502a
May 14, 2010
714
874
I've had external monitor issues for years with so many different Mac + monitor combinations I've lost count. Even Apple monitors don't work correctly sometimes - my old 24" Cinema Display showed a line of funky flashing pixels at the top when plugged into my M1 iMac. I swear not a single person at Apple actually uses an external monitor. So I didn't think twice when the Menu bar started appearing scrambled when my 1080p Dell external woke from sleep. I also think 12.3 has caused HDMI hot plugging to stop working with my 2014 mini - to get anything to display requires a restart.
 
  • Like
Reactions: dysamoria

polyphenol

macrumors 65816
Sep 9, 2020
1,154
1,159
Wales
Since Monterey 12.3, I have noticed some odd behaviour in Microsoft Word. (I have 365 and it is up-to-date.)

The position of the cursor on-screen is wrong. Sometimes it just seems to be at a position a few characters left or right, or lines up, or down, from where it should be. If I type, the characters might appear in the wrong place, or not at all. Just have to page up then down, and it resolves.

As it is so easy to (temporarily) fix, it isn't a major issue. I find the characters in the wrong place, or not present, and have to make a minor correction.

It appears to be a miscommunication between macOS/display driver and Word.
 

Station Grey

macrumors member
Jun 18, 2020
50
73
Yep, I have this, incredibly frustrating. Both my external monitors stopped working as soon as I upgraded and are just paperweights until Apple fix it.

For reference, this is a 2017 iMac 5K i7, with 2x USB-C monitors via TB3 - one direct, the second daisy-chained from the back of an external drive.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.