WatchOS 5.3 killing battery on Series 3

Discussion in 'Apple Watch' started by kirbyrun, Jul 29, 2019.

  1. kirbyrun macrumors member

    Joined:
    Jul 26, 2009
    #1
    Anyone else having this problem? I tried rebooting the watch, un-pairing and re-pairing, and I'm still losing something like 5% battery in less than an hour. My watch used to make it from 7am to 11pm with half its charge remaining. Now it's dead by 5pm since updating to 5.3.

    Just wanted to see if anyone else is experiencing this or has any solutions before I nuke it and set it up as new. (Ugh.)
     
  2. waw74 macrumors 68040

    Joined:
    May 27, 2008
    #2
    I've got a S3 with 5.3
    It's been fine for battery life,
    forgot to take it off last night, was at 40% this morning (24 hours off charger) which seems normal from before

    I might try unpair/repair again.
    My watch has done what yours is doing, and that seemed to fix it. (it was a few years back, S0, and would be dead by lunch)

    Maybe check & remove apps you don't use, one of those could have gotten "stuck" either in trying to install or setting things up for itself.
    or play around in the "background app refresh" settings.
     
  3. kohlson macrumors 68000

    Joined:
    Apr 23, 2010
    #3
    I agree with @waw74. I have AW3 and it's pretty good on battery life. Usually 60% left at the end of the day, and daily average of 110 exercise minutes. To be safe, be sure to back it up with iTunes (and a password to back up health data) before unpair/re-pair - but I don't think you'll have any issues.
     
  4. kirbyrun thread starter macrumors member

    Joined:
    Jul 26, 2009
    #4
    Update: Tried a second unpair/repair. Still no love — losing 5% or so every hour.

    Finally gritted my teeth and with great annoyance nuked it and set it up as a new watch. Seems to be OK now. Thanks for your advice!
     

Share This Page

3 July 29, 2019