Western Digital My Book shows but won't mount?

Discussion in 'Mac Basics and Help' started by Electribe, Jan 31, 2017.

  1. Electribe macrumors newbie

    Joined:
    Sep 21, 2012
    #1
    Hi all, I've got an infuriating problems with an older WD mybook studio II external drive.

    It's shows in disk utility but not in finder, and won't mount in DU. I found a thread suggesting that if fschk shows up in activity monitor, then force quit that process, but the process doesn't show when i plug in the drive.

    I've tried using both the FW and USB but still no joy. I've also tried the terminal mount command. And i've plugged it to two different macs, one with mavericks and one with el capitan, same problem.

    The drive spins, it powers up but just won't mount so I'm at a los as to what to do next.

    Any ideas of what else I can try?
     
  2. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    I read in another thread, some people have had luck with shutting down the Mac, connecting the drive, then starting the computer to get the external drive to mount and read properly. It can't hurt to try, though it is not a very convenient way to operate.
     
  3. Electribe thread starter macrumors newbie

    Joined:
    Sep 21, 2012
    #3
    Thanks! Anything is worth a try. This is a really weird problem and i'm open to anything; the drive can been seen but just won't mount. It even shows read/write status in disk utility info on the drive but the partition is greyed out an no amount of repairs/verifiy's will fix it....

    Thanks again and keep those suggestions coming if you think of anything else....
    --- Post Merged, Jan 31, 2017 ---
    Tried the shutdown option, but still no luck..... :(
     
  4. kschendel macrumors 6502a

    Joined:
    Dec 9, 2014
    #4
    I'm inclined to think that the drive is toast. You could try opening up the enclosure and reseating any cables that you can get at.

    Maybe open a terminal and try "diskutil list" with the drive plugged in, to see what it tells you. You ought to see something vaguely like:

    /dev/disk2 (external, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *1.0 TB disk2
    1: EFI EFI 209.7 MB disk2s1
    2: Apple_HFS vboxes 999.9 GB disk2s2
     

Share This Page