White MacBook - no chime on startup, dead?

Discussion in 'MacBook' started by Giuanniello, Dec 11, 2016.

  1. Giuanniello macrumors regular

    Giuanniello

    Joined:
    Oct 21, 2012
    Location:
    Capri - Italy
    #1
    Hello,

    found this old white MacBook which used to be my sister's, been in a drawer since ages and decided to open it to figure it out if possible to resurrect it, inside full of dust and some oxidation on the cooling system, on startup nothing happens, I see a quick flash in the screen but then no startup chime not anything else; removed battery and reset PRAM but again no chime, cooling fan spins, hard drive spins, cpu cooler gets warm, removed a ram module and the hard drive but still nothing happens, any idea what might I try before I take it to the special trash?

    Thank you
     
  2. Talkingtoaster macrumors regular

    Talkingtoaster

    Joined:
    Aug 19, 2014
    Location:
    UK
    #2
    Reset SMC?

    "
    1. Using the built-in keyboard, press Shift-Control-Option on the left side of the keyboard, then press the power button at the same time.
    2. Release all keys, then press the power button again to turn on your Mac"
     
  3. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #3
    Tried booting without the battery installed just ac power connected.
     
  4. Giuanniello thread starter macrumors regular

    Giuanniello

    Joined:
    Oct 21, 2012
    Location:
    Capri - Italy
  5. borgusio macrumors regular

    borgusio

    Joined:
    Jul 22, 2011
    #5
    Basically you need to try all components one by one
    Open it and remove:
    RAM
    DVD
    HHD
    Try to unplug, clean and plug again the screen cable as well.

    -> Do this just if you know what you do and you used already one of the iFixit guides in the past.

    If you still get no chime with ALL other components disconnected from the mainboard... it is the board itself. I would buy a spare part on eBay. I have one which is working myself (I leave in Germany though)
    --- Post Merged, Dec 13, 2016 ---
    I found this on eBay:
    http://www.ebay.de/itm/MacBook-A118...955639?hash=item25caf6b477:g:l5wAAOSwLF1X93jC
     
  6. Giuanniello thread starter macrumors regular

    Giuanniello

    Joined:
    Oct 21, 2012
    Location:
    Capri - Italy
    #6
    I will try and remove all the possible parts, I just need to figure out where the screen connector is (iFix comes always handy) and try and remove it too but I guess it's the mainboard since by attaching the laptop to an external monitor there is no video signal, such a pity, an almost unused machine, if I could find a good deal on an used working board I would buy one, by the way, Borgusio, am in the EU, well, at least until they throw new elections and we are forced to move on the Moon ;-)
     
  7. borgusio macrumors regular

    borgusio

    Joined:
    Jul 22, 2011
    #7
    Hahah, are you Italian, as well? Me too. Anyways that offer on eBay is 130 EUR, maybe worth a try to merge both machines. I still use mine from time to time, with an SSD it works perfectly fine for light tasks
     

Share This Page