WiFi issues on Mojave?

Discussion in 'macOS Mojave (10.14)' started by Qquarto, Sep 28, 2018.

Tags:
  1. Qquarto macrumors newbie

    Qquarto

    Joined:
    Sep 28, 2018
    Location:
    New york
    #1
    hi, is anyone else having trouble connecting to WiFi. My internet connection is Definitely working, because it’s working with my iPhone.

    But on my Mac, the Wi-Fi looks like it’s logged in but I can’t get a connection. Sometimes, when I turn it on and turn it off again, it helps. But not always. Can anyone help?
     
  2. haralds macrumors 6502a

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #2
    If you are using DHCP, try getting a new lease.
    If that does not work, create fresh set of settings by adding a "Location" in the network control panel.
     
  3. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #3
    Wifi looks like it’s logged in? What kind of security setup do you have?
     
  4. mrex macrumors 68040

    mrex

    Joined:
    Jul 16, 2014
    Location:
    europe
    #4
    forget the current connection (disconnect it) and reconnect again.
    after the update my wifi didnt work at all - didnt connect to the router.
     
  5. BorderingOn macrumors 6502

    Joined:
    Jun 12, 2016
    Location:
    BaseCamp Pro
    #5
    I'm having this issue with my 2015 13" MBP. After the computer has been on a while, it will just lose network connectivity even though it shows connected to WiFi. Reconnecting fixes it but other devices are fine and stable on the same AP.
     
  6. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #6

    I have a 2015 13” and the wifi has been rock solid. I use a NAS so any wifi issues are really my biggest isssues and I haven’t had any at all. Sleep mode is now useless, but wifi is great. I did a clean install.

    Using 5GHz to a Netgear r6300 v2.
     
  7. mozza1216 macrumors newbie

    Joined:
    Oct 9, 2018
    #7
    I have been having the same issue on my 2017 MBP 13" connected to Google WiFi, do you have any usb devices plugged in, I have been testing and my wifi speed drops to almost zero with my usb-c dock connected, as soon as I disconnect speed increases back to normal.
     
  8. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #8

    Doesn't apply to the 2015 MB Pro.

    Your specific issue is because you're using a 2.4GHz network and it's receiving interference from a USB3 device that is poorly sheilded. If you plan to keep your dock then change your network to 5GHz.
     
  9. mozza1216 macrumors newbie

    Joined:
    Oct 9, 2018
    #9
    I understand your response, but not sure why it would suddenly be a problem now, dock and laptop rarely move in my office and has been fine on High Sierra for the last 4 months. This only started happening after I upgraded to Mojave. I will monitor the WiFi on the MBP and see (currently docked... on 2.4ghz with a good connection) as it usually happens first thing in the morning after my latops has been left overnight.
     
  10. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #10
    Yeah that is a bit strange.
    Is it possible that it's not the dock itself, or Mojave, but it's when there is a specific item that is plugged into the dock?

    Is your network mixed 2.4GHz and 5GHz (ie same SSID)? Is it possible that sometimes you're using the 5GHz?

    To troubleshoot it, I would split the network to two networks, 2.4GHz and 5GHz, and then connect to the 2.4GHz network and start a file transfer. Then while the transfer is happening try using your dock and all of USB devices and see if there is a specific device that seems to trigger it.

    Or maybe it's Mojave. It's been rock solid for me, but my sleep is worthless, and I know other people can still use sleep mode. So who knows. :D
     
  11. BorderingOn macrumors 6502

    Joined:
    Jun 12, 2016
    Location:
    BaseCamp Pro
    #11
    Not in my case. Nothing connected each time it happened.
    --- Post Merged, Oct 9, 2018 ---
    Sleep mode is an issue for me too. All I can say is the WiFi issue is quite random. I used the laptop quite a bit yesterday with zero issue.

    Since you’re having sleep issues, do you shut down when you’re done? I never shut down unless I have to for an update. The WiFi issue seemed to happen after significant uptime.
     
  12. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #12
    I used to use sleep all the time. Now I don’t, it’s totally useless. I shut down now.
     
  13. Yayforgoats macrumors newbie

    Joined:
    Oct 19, 2018
    #13
    This saved me a **** load of time and frustration, remove USB c dock, bam, it connects immediately. What bothers me though is how intermittent it is
     
  14. mrex macrumors 68040

    mrex

    Joined:
    Jul 16, 2014
    Location:
    europe
    #14
    I wouldnt blame the device but rather the poor design in macbooks. The same usb3 device connected to my win laptop and 2,4ghz band doesnt affect at all to the connection. The same device connected to my mbp 2016 is causing problems. If you check ifixit you will see that it is a design choice (i would say flaw) in macbooks how they have placed the parts inside macbooks. It only makes me wonder doesnt apple try those prototypes before actually building and start selling them. Any engineer would have seen the problem when connected with 2,4ghz and using an usb3 device.
     
  15. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #15
    ...and properly shielded the device.

    :D
     
  16. yuc0n macrumors newbie

    yuc0n

    Joined:
    Nov 1, 2018
    #16
    This exact thing happened to me, I was almost accepting my fate to use a prehistoric cable, but then I found this **** that I never believed would work.. But it did:

    Go into /Library/Preferences/SystemConfiguration/

    Delete these files:

    com.apple.airport.preferences.plist
    com.apple.network.identification.plist
    NetworkInterfaces.plist
    preferences.plist

    (I didn't have the "com.apple.network.identification.plist" but you might, idk)

    Now reboot. Maybe it's not the same issue, but it sounds like what happened to me. Hope it helps.
    glhf
     
  17. Mary M macrumors newbie

    Joined:
    Nov 9, 2018
    #17
    This thread has been of so much help. The thing that finally fixed my issue was found here:
    https://support.apple.com/en-us/HT201163#16
    I moved my usb3 cord (connecting to my external display) to the front left port on my laptop. It worked fine after that. Took 5 hours to get to that point after trying all the other things, but yay!
     
  18. kateanth macrumors newbie

    kateanth

    Joined:
    Nov 15, 2018
    #18

    Do you mind sharing how you got the Library --- and so on? Is it in system preferences?
     
  19. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #19
    "Do you mind sharing how you got the Library --- and so on? Is it in system preferences?"

    Apple keeps the user's "library" folder (which is in the home folder) hidden.

    To make it visible, try this:
    1. click on the desktop so that the finder is the active app
    2. go to "Preferences" (under "Finder" menu)
    3. in "general", is there now a checkbox to show the user library? If so, check it.
    4. close finder preferences.
    You should now see the "library" folder in your user folder
     
  20. kateanth macrumors newbie

    kateanth

    Joined:
    Nov 15, 2018
    #20

    Thank you for this, but it doesn't seem to work. I am on a macbook pro 2017 touchbar if that means something else.
     
  21. Bartjes macrumors newbie

    Joined:
    Nov 28, 2018
    Location:
    Paris France
    #21
    I wasn't able to establish a wifi connexion on my mini 2018. I disconnected one of the two usb-3 hubs and replaced it with a usb-2 hub. Now all is fine. The second usb-3 hub, a Belkin 4 ports, doesn't seem to interfere.
     
  22. brdeveloper macrumors 68020

    brdeveloper

    Joined:
    Apr 21, 2010
    Location:
    Brasil
    #22
    Don't know if your adapter is an WIFI-AC or not, but I've noted a substantial improvement after I've upgraded the AirPort adapter from my Early-2013 MBP. WiFi seemed to be really laggy with the original wifi adapter.
     
  23. William Forrest, Jan 21, 2019
    Last edited: Feb 22, 2019

    William Forrest macrumors newbie

    William Forrest

    Joined:
    Dec 23, 2017
    #23
    I'm not an expert, but I believe the disappearing WiFi on my 2017 Macbook 15" pro is a software issue. I suspect Mojave, since I recently 'upgraded' to it. Many times I've lost WiFi contact to everything attached to my router. I have a DSL internet link and a HDHomerun SiliconDust TV box attached to it. The failure happens rather slowly, but eventually the only device shown when I click the WiFi icon (which is often black even though WiFi is dead) is my own home router. When WiFi is working, many routers from around my neighborhood show up, for instance one called Gorsline. There's even one without password protection that I occasionally try out just in case, 'wifi-2D....'. When WiFi fails, only my own router shows up, but I'm pretty sure that it's *not* actually connected. This condition is usually noted in 'Network Preferences'.

    Turning wireless off then on has never worked for me.

    One time during failure, I killed the 'Wireless....' app and immediately WiFi started working. But later, this didn't work.

    Because it usually happened near 6 PM, when I had an external video projector connected through my USB ports, I thought the USB connection was at fault. I vowed to *not* plug into the USB ports and see if it ever failed. Today, near noon, it failed again.

    This time, I 'Shut Down' my Mac. After it seemed to have gone totally dark, with no response to keys like 'caps lock', I hit the power button, and it booted back up. Voila, wireless is back.

    This problem happened shortly after I 'upgraded' to Mojave 10.14.2. One rule of thumb I have: look at the last thing that was changed. I believe 10.14.2 is at fault.

    In the future, until Apple issues a bug fix, I plan to reboot my computer if it loses WiFi connection. I can do that in about 10 minutes now.

    22 Feb. update. I called Apple, and eventually reached a person who knew something. He had me do an SMC reset, and my WiFi problem went away.
     
  24. ohitsjason, Jan 23, 2019
    Last edited: Jan 23, 2019

    ohitsjason macrumors newbie

    Joined:
    Jan 23, 2019
    #24
    Oh wow, this worked for me! The only one I didn’t have was “com.apple.airport.preferences.plist” but deleted all the others, restarted & internet started working again. Thanks!
     
  25. macaudiodemon, Jan 25, 2019
    Last edited: Jan 26, 2019

    macaudiodemon macrumors newbie

    macaudiodemon

    Joined:
    Jan 25, 2019
    Location:
    Australia
    #25
    :mad: This only worked for one day. My internet is not working again today even though Wifi connects fine.




    I just had this happen today on my mid 2017 MacBook Pro 13 inch touchbar.

    I tried many solutions listed here (rebooting router, DNS update on my macbook pro, unplugging all USB-C devices etc, and of course rebooting each time). Unfortunately they didn't work for me. I was just about to try the deletion of files from the library folder as suggested by a few who had success but then I noticed that there was an update to OSX 10.14.3. I thought this was worth a shot before deleting system files.

    Somehow I was still able to download this Apple update even though all other internet connection was not working!

    Once I ran the update and rebooted the MacBook Pro, Wifi was all fixed and allowing internet connection through again.

    So I can only assume there was some bug with OSX 10.14 (which I was running until the update) that somehow I had triggered today even though I had not changed anything.

    :) My solution was updating to :apple: OSX 10.14.3.
     

Share This Page