Win7 x64 booting natively via EFI (no BIOS emulation)

Discussion in 'Windows, Linux & Others on the Mac' started by VirtualRain, May 4, 2009.

  1. DaGr8Gatzby macrumors member

    Joined:
    Dec 24, 2011
    #1051
    I managed to get nvidia GT750m to load. I had to install the latest windows 8.1 drivers directly from nvidia. I did not have to set any registers in EFI.

    I now have an EFI dual boot system using the EFI boot loader in OS X. I will report on windows 10 usage sometime next week as I just updated it with all patches. Will report back.
     
  2. zos-arafat, Mar 14, 2015
    Last edited: Mar 14, 2015

    zos-arafat macrumors newbie

    Joined:
    Mar 14, 2015
    Location:
    EU
    #1052
    Further woes

    Hello all,

    this post is directed at AH (Andreas Heider) and Bruno Bierbaumer.

    First of all, chapeau for the excellent work done to date.

    I have tried your GPU switcher on the belowmentioned machine.

    with an integrated Intel HD 5200 (IRIS Pro) and a discrete Nvidia GK107M (GeForce GT 750M Mac Edition).

    Model Name: MacBook Pro Retina 15 (Mid 2014)
    Model Identifier: MacBookPro11,3
    Processor Name: Intel Core i7
    Processor Speed: 2.5 GHz


    Using the gpu-switch -i for the integrated Graphics Card, reboot and I am still on the NV card.. :(

    A shutdown / power off does not seem to make any difference - still on the discrete card.


    LSPCI

    00:00.0 Host bridge: Intel Corporation Crystal Well DRAM Controller (rev 08)
    00:01.0 PCI bridge: Intel Corporation Crystal Well PCI Express x16 Controller (rev 08)
    00:01.1 PCI bridge: Intel Corporation Crystal Well PCI Express x8 Controller (rev 08)
    00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
    00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
    00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
    00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
    00:1c.3 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 (rev d5)
    00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d5)
    00:1f.0 ISA bridge: Intel Corporation HM87 Express LPC Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
    01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 750M Mac Edition] (rev a1)
    01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
    03:00.0 Network controller: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter (rev 03)
    04:00.0 Multimedia controller: Broadcom Corporation Device 1570
    05:00.0 SATA controller: Samsung Electronics Co Ltd Apple PCIe SSD (rev 01)
    06:00.0 PCI bridge: Intel Corporation Device 156d
    07:00.0 PCI bridge: Intel Corporation Device 156d
    07:03.0 PCI bridge: Intel Corporation Device 156d
    07:04.0 PCI bridge: Intel Corporation Device 156d
    07:05.0 PCI bridge: Intel Corporation Device 156d
    07:06.0 PCI bridge: Intel Corporation Device 156d
    08:00.0 System peripheral: Intel Corporation Device 156c

    I see that my /sys/firmware/efi/efivars/ is populated though.

    Any thoughts?



    Regards,

    Mainframe Arafat


    PS Running Debian 8 (Jessie) with a 3.19.1 kernel.
     
  3. ah- macrumors member

    Joined:
    May 7, 2010
    #1053
    Hi, have a look at the requirements in the readme here: https://github.com/0xbb/gpu-switch

    You'll need either the kernel patch or the grub patch, once that's working you'll see the intel gpu in lspci.

    I would have expected that you get a black screen if you don't have one of the patches applied, so there might be something else as well, but that should get you a bit further.
     
  4. mbazz macrumors newbie

    Joined:
    Apr 30, 2015
    #1054
    I figured out how to convert a Bootcamp Win7 installation on my 2009 Macbook Pro to EFI, everything works except the following caveats: screen brightness control doesn't work (starts at full brightness or likely the brightness of screen when OSX shutdown), webcam maybe doesn't work, bluetooth untested. Bootcamp Control panel won't open without a hack. Check my wiki post: http://wiki.bazz1.com/w/index.php/EFI_Win7_Macbook_Pro_5,4_2009
     
  5. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #1055
    Thinking about using Windows 10 upgrade as an opportunity to make the switch to EFI.
    So the plan is - remove all hard drives except the Windows/Bootcamp drive, do EFI Boot from a USB installer, clean install Windows. Would this work?
     
  6. ShiftZ, Jul 23, 2015
    Last edited: Jul 23, 2015

    ShiftZ macrumors newbie

    Joined:
    Jul 23, 2015
    #1056
    Hi all,

    Im stuck at the very begining. I have a MBP late 2013. When i try to 'EFI Boot' to windows 7 x64 installer, the system just freezes. I tried it with different windows install images with different usb sticks in different usb ports, but the result is always the same.
    Is that a known issue?

    The boot stick was made using rufus.

    EDIT: Tried windows 8.1, and it worked. Although I was not able to install it on a usb drive.
    What is wrong with windows 7 efi?
     
  7. PartisanEntity macrumors member

    Joined:
    Apr 10, 2008
    #1057
    I am having the same issue trying to install Windows 7 on an iMac 11,3 (late 2010 model). In my case I cannot get the iMac to boot from the original Windows 7 x64 install DVD, and when I try a custom made install USB it either hangs after I select "EFI Boot" or it cannot see any bootable partition on the USB (depending on which tutorial i followed).

    Any feedback from others as to how on earth to get Windows 7 installed on an iMac (without using Boot Camp as I have Ubuntu installed on the iMac and multiple partitions (Boot Camp cannot deal with this setup) would be greatly appreciated.
     
  8. ShiftZ macrumors newbie

    Joined:
    Jul 23, 2015
    #1058
    Magicaly windows 8 installation works.
     
  9. PartisanEntity macrumors member

    Joined:
    Apr 10, 2008
    #1059
    Did you have to do anything special to get your iMac to boot the Windows 8 installation DVD/USB?
     
  10. ShiftZ macrumors newbie

    Joined:
    Jul 23, 2015
    #1060
    I have Mac Book Pro late 13. Nothing special, just original win 8.1 iso burned to usb flash drive.
     
  11. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #1061
    Got it halfway working but having a big problem. Whenever I try to boot to EFI Windows 10 via the Startup Disk panel, or BootChamp, it gives me the "no bootable device" error.

    However when I boot into Windows using the hold Option key at startup and select the EFI Boot option, it works fine and loads quickly.

    Machine is a Mac Pro 5,1 and I use a dedicated internal SSD for Windows.
     
  12. flyinmac macrumors 68030

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #1062
    This is a long thread, but some of the EFI issues can be worked around much simpler. You don't need boot loaders and hacking. You just need to get windows on the drive without Apple's roadblocks stopping you. Once you do that, you'll be surprised to find that the EFI is not even a remote issue that needs a addressed.

    I ran into EFI getting on my way and stopping me. Boot camp not letting me do what I wanted. All artificial barriers. Boot camp is unnecessary, EFI doesn't even need to be involved.

    Check out how I did it on my system
    http://forums.macrumors.com/threads...allation-no-bootloaders-or-efi-hacks.1905564/
     
  13. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #1063
  14. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #1064
    One final piece of the puzzle before it's working 100%...

    I believe I need to run the 'bless' command on the EFI boot file to add it to the Startup Disk panel options.

    Would this command do the trick? (Note I still want OS X to be the default)

    sudo bless --file /Volumes/NO NAME/EFI/Boot/bootx64.efi
     
  15. SoyCapitanSoyCapitan macrumors 68040

    SoyCapitanSoyCapitan

    Joined:
    Jul 4, 2015
    #1065
    Will installing Windows like this allow me to boot it from Sonnet Tempo?
     
  16. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #1066
    Not sure if this method would. If the Mac 'sees' the card as an external drive, my understanding is you can get it to work but it requires some minor hackery.
     
  17. seanbperiod, Aug 30, 2015
    Last edited: Aug 30, 2015

    seanbperiod macrumors member

    Joined:
    Dec 23, 2009
    #1067
    I'm happy to find this thread but I'm still unable to load Nvidia drivers for my 2010 Mac Mini under Windows 8.1.

    The EFI install goes well, but as soon as I install the Nvidia driver and reboot, I get the black screen. Did D3vi1 ever come out with that efi app that would trick Windows into booting with the Nvidia drivers loaded?
     
  18. flyinmac macrumors 68030

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #1068
    Are you getting your drivers from the nVidia site? I always use the manufacturers drivers and avoid the ones Apple supplies. Usually works better.
     
  19. seanbperiod macrumors member

    Joined:
    Dec 23, 2009
    #1069

    Thanks for the response flyinmac- i haven't tried the latest drivers from nvidia yet. from what i gather though, a major problem is isolated to the mac mini 2010 because it uses the 320m chip and there's no vga fallback. i'll try the latest 341.81 drivers and cross my fingers, but not feeling hopeful.
     
  20. flyinmac macrumors 68030

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #1070
    Well, hopefully it'll work. NVidia also has a beta drivers section that sometimes has hardware support not found in the released versions.

    What you're after is a chip / graphics card type / model. Don't bother trying to find mac specific. Just get the driver for the gpu that you have.
     
  21. seanbperiod macrumors member

    Joined:
    Dec 23, 2009
    #1071

    Just tried it. Same results. =( Going to try switching to non efi install.
     
  22. flyinmac macrumors 68030

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #1072
    Check my August 5 post in this thread for a link to how I installed windows 10 on my unsupported Mac Pro. That might be a solution if you're looking to bypass EFI. My EFI was not compatible. Rather than using patches and boot loaders, I just worked around it altogether.

    My method does work on hard drives that have a mac partition and windows partition. It also works on dedicated drives. Just be sure you choose the right partition for windows if it's on a shared drive with os x.
     
  23. Apple06 macrumors member

    Joined:
    Feb 24, 2012
    #1073
    I have a Mac Mini late 2012 and wishes to have Windows 7 Pro 64bit installed on an external USB 3 drive so I can upgrade it to Windows 10 without using Bootcamp. I've read about Windows To Go and tried that, but without any success at boot. I'm able to create the To Go image and my Mini just doesn't boot after selecting the external Windows drive via Options-key boot menu -- the screen goes black and just hangs there. I tried this very same image on a old Dell laptop and it booted fine.

    Is it possible? Has anyone got it working with a Mac Mini 2012? Hopefully someone can re-summarize the steps for me.

    Thanks in advance.
     
  24. davidcie, Feb 2, 2016
    Last edited: Feb 3, 2016

    davidcie macrumors newbie

    davidcie

    Joined:
    Dec 25, 2008
    Location:
    Poland
    #1074
    Guys, first of all let me shout a huge thank you to all of you (@d3vi1, @DaGr8Gatzby, @ogjelland, @mark1234, @Jognt and countless others) contributing in this thread. Without bucketloads of your persistence and a fair bit of knowledge we would be a lot more clueless as a community! Plus I would not be able to get nearly as far as I got in my little project.

    What I am trying to accomplish is get Windows 7 installed on a MacBookAir7,2 (Early 2015). The quest is made a little harder since this is their first laptop with no CSM / BIOS mode (it's either EFI or nothing) and its NVMe SSD.

    Where I got so far is:
    1. Slipstreamed Intel HD 6000, Intel USB 3.0, Apple SSD and USB-to-Ethernet-dongle drivers.
    2. Slipstreamed the Windows 7 NVM Express hotfix.
    3. Injected the final install.wim into a Windows 8.1 setup on a thumbdrive.
    4. Installed Windows 7 with @Jognt's AutoUnattend.xml (adding RDP-enabling rules and making sure the right image index is picked via a MetaData section as this iso is an all-in-one).
    5. On the EFI partition: replaced EFI\Boot\bootx64.efi with EFI shell.
    6. On the EFI partition: replaced bootmgfw.efi and all its files from Windows 7 with Windows 8.1 couterparts apart from the BCD store (W7 bootmgfw.efi does not work on this laptop).
    7. My Intel HD 6000 card has bus/dev/func of 00:02:00 and its bus master bit is already set.
    8. Since it has direct connection to the chipset and does not go through a PCI bus, it should not require any VGAE register setting. However, as @mark1234 discovered, this is still needed. I chose the first available PCI bridge @ 00:1C:00 and set its VGA Enable register every time I boot.
    9. BCD store was initialized by the installer and has correct entries (verified using a Win8.1 setup recovery console).
    The results? This is the weirdest part: once I run bootmgfw.efi from EFI shell the screen goes blank for a second, then a single random character (W, 5, F so far) appears on the screen, positioned in the top left corner of the screen where the EFI console was a second ago. After a few seconds Windows boot manager shows an error screen (0xc0000428, "Windows cannot verify the digital signature of this file", but does not say which file). When I press Enter I get back to the choose your OS Windows boot manager screen. If I choose the same OS again, this time it shows a different error (0xc0000225, "File \Windows\System32\winload.efi is either corrupted or missing") and powers the computer off after a few seconds.

    As far as I understand what @d3vi1 was saying back in 2011 (this post specifically) it might be down to how Windows 7 is expecting a legacy option ROM at a particular location and/or has to do with int10h. And without the environment especially crafted according to its weird expectations, Win7 possibly displays what happens to be at some particular memory location and crashes soon after its actions interfere with real stuff.

    Since few of you mentioned shadowing the VGA ROM this in your later posts, is this still needed? Possible without having access to a CSM-booted linux to check stuff? Will be looking for the option ROM in UEFITools tomorrow but would love to hear your input in the meantime.

    I hope that we can figure this one out somehow... There's lots of threads out there with "want to install W7 on my Air" and "not meant to be done, sorry" as the only reply offered. Once we jump the last hoops I will contribute back and write a step-by-step for any Air owner not prepared to upgrade to W8+.

    EDIT: added lspci -v and lspci -tv output.
     

    Attached Files:

  25. Pockets69 macrumors newbie

    Joined:
    Jan 7, 2016
    #1075
    Hello Davidcie

    Like yourself i am running the same problem as you know, but on early macbook, a macbook from 2010, i have done mostly everything in this thread that applies to my situation but to no avail.

    Strangely enough this changes done on ubuntu works to nvidia graphics driver working, so it is beyond me why it isn't working on any windows from 7 to 10.

    Now highlighting what I did before and have been doing these past months:

    - I downloaded the nvidia drivers
    - I slipstreamed the nvidia drivers into the install.wim with dism and checked if they were present to make sure (they were)
    - I used an unattended file from this thread (can't remember from whom) which wipes the hdd and creates 3 partitions EFI MSR and windows partition, it also proceeds to create a user and log you in automatically to the desktop.
    - i put the install.wim in the sources the autounattended.xml into the root of the usb stick
    - I also created a windows PE pen drive.
    - I installed shell.efi from DaGr8Gatzby to my EFI partition.
    - I found my PCI bridge and my display addapter, the first being 00 17 00 and the other 02 00 00
    - I modified the PCI registers on the shell with mm 0017003E 8 -PCI and mm 02000004 7 -PCI

    the procedure:

    - boot into efi shell
    - modify the pci registers with mm (as written above)
    - boot the windows PE environment
    - boot windows 7 through windows PE using setup.exe
    - watch autounattended.xml do its job and install windows without any user interaction.
    - first reboot, after this you lose image on the screen
    - boot into efi shell again
    - set the same pci registers
    - continue the installation by booting /EFI/Microsoft/boot/bootmgfw.efi
    - no image on the screen, so I just let it do its thing and reboot.
    - last reboot ready to get into the desktop.
    - again set the pci registers as always
    - boot from /EFI/Microsoft/boot/bootmgfw.efi
    - black screen on boot, but as i am getting to the desktop, backlight goes off as if to enable the gpu, but it never comes on.
    - I managed to restart the pc blindly so i know i reached the desktop.

    I have tried all sorts of variations of this procedure, i get no image everytime, I don't know what else to do, the smae happens with 8 and 10, but there is image througout the instll, the problem only comes when you try to install the nvidia driver.

    On 7 though, the problem is much deeper, so what I know?
    - the install reached the desktop
    - the nvidia gpu drivers were installed successfully during the unattended install
    - the PCI registers are correclty set

    I don't know what else i need to do to make this crap work, any idea anyone?
     

Share This Page