10.14.5 Mail Opens by Itself

SpiritSoul1008

macrumors newbie
Original poster
May 23, 2019
27
8
Hello. since updating to the newest macOS Mojave update, Mail has been opening by itself periodically and it getting very annoying and I don't know what is prompting it. If I am in full screen mode, mail will open and take up the right side of the screen also. I have tried reinstalling the operating system over the current installation to see if the system could rebuild itself and fix the issue but this was not successful. Thank you for your help.
[doublepost=1558669797][/doublepost]Also, I installed the supplemental update on my 2018 MacBook Pro, and this did not fix the issue. Also, Mail is not in my startup items.
 

Kuba77

macrumors newbie
Dec 16, 2010
22
6
No, it's not that. Mail app is not open - it's just running in the background. Periodically, when I'm in full screen (working in another app), Mail just opens up by itself and takes up the right side of the screen - just like SpiritSoul1008 said.

But I give it a try and deselect this option - who knows, maybe it helps...
 
Last edited:
  • Like
Reactions: martyjmclean

chabig

macrumors 604
Sep 6, 2002
6,743
3,959
What does it display on the right side of the screen? A new message window? A received message? The accounts list?
 

Smoothie

macrumors 6502a
Jun 23, 2007
614
334
California
I have the same issue. Apple fixed the failure to connect to Gmail, but replaced it with this. At least it's downloading messages, but this is an annoyance.
 

SpiritSoul1008

macrumors newbie
Original poster
May 23, 2019
27
8

SpiritSoul1008

macrumors newbie
Original poster
May 23, 2019
27
8
Check your Energy Saver settings in Preferences. Turn off Power Nap to see if that eliminates the issue. I have seen it happen in a few instances on my MBP 2018 with OS 10.14.5
Thank you, I'll try it and see, and let you know.
 

jandrso

macrumors member
May 21, 2019
45
8
Fl, US
Well now that's truly annoying.

I am trying to replicate on my 10.14.5 right now. When you say it is in the background are you saying the inbox window is closed and app running as an open procces or window minimized with app running?

Also, are you getting the usual mail notification on the left of the Dock when you are checking or getting email on the iPhone? (Assuming you have one).
 

Nodens

macrumors newbie
Jul 17, 2017
21
4
If I remember correctly, I always had this issue with Mojave. It just became more frequent with 10.14.5.
 
  • Like
Reactions: kevo0822

chabig

macrumors 604
Sep 6, 2002
6,743
3,959
I am trying to replicate on my 10.14.5 right now
I think this is the key. If we can figure out how to replicate it, we might learn what to undo. Personally, when I am full screen on my MacBook Pro, Mail behaves exactly as it should and newly arriving mail messages open in split screen only if I click on the banner notification. (Which gets me thinking--I have Mail notifications set to banner. Where are yours?)
 

SpiritSoul1008

macrumors newbie
Original poster
May 23, 2019
27
8
Well now that's truly annoying.

I am trying to replicate on my 10.14.5 right now. When you say it is in the background are you saying the inbox window is closed and app running as an open procces or window minimized with app running?

Also, are you getting the usual mail notification on the left of the Dock when you are checking or getting email on the iPhone? (Assuming you have one).
Yes, continuity is working and mail is displayed on the left of the dock when viewing on an iPhone. It is just open as a background process but not open on the screen.
[doublepost=1558841708][/doublepost]
I think this is the key. If we can figure out how to replicate it, we might learn what to undo. Personally, when I am full screen on my MacBook Pro, Mail behaves exactly as it should and newly arriving mail messages open in split screen only if I click on the banner notification. (Which gets me thinking--I have Mail notifications set to banner. Where are yours?)
Banners.
 

Kuba77

macrumors newbie
Dec 16, 2010
22
6
Well now that's truly annoying.

I am trying to replicate on my 10.14.5 right now. When you say it is in the background are you saying the inbox window is closed and app running as an open procces or window minimized with app running?

Also, are you getting the usual mail notification on the left of the Dock when you are checking or getting email on the iPhone? (Assuming you have one).
1. Mail app is in the background - I mean the inbox window is closed and app running as an open procces.
2. Yes, I'm getting mail notification on the left of the Dock. There's nothing wrong apart from this little, but annoying bug.
 
  • Like
Reactions: SpiritSoul1008

chabig

macrumors 604
Sep 6, 2002
6,743
3,959
Both Mission Control and Spaces are controlled by the Dock process. Try dragging your Dock preferences to the Desktop and restarting your Mac. The preferences are in a file called com.apple.dock.plist. That file is in ~/Library/Preferences/ where ~/ is Unix shorthand for your home folder.

If it works you will have to arrange your Dock icons again and maybe rest some Dock, Spaces, and Mission Control Settings. If not, put the old preferences back and restart again.
 
  • Like
Reactions: SpiritSoul1008

SpiritSoul1008

macrumors newbie
Original poster
May 23, 2019
27
8
Both Mission Control and Spaces are controlled by the Dock process. Try dragging your Dock preferences to the Desktop and restarting your Mac. The preferences are in a file called com.apple.dock.plist. That file is in ~/Library/Preferences/ where ~/ is Unix shorthand for your home folder.

If it works you will have to arrange your Dock icons again and maybe rest some Dock, Spaces, and Mission Control Settings. If not, put the old preferences back and restart again.
Will give it a try and let you know.
 

SpiritSoul1008

macrumors newbie
Original poster
May 23, 2019
27
8
Both Mission Control and Spaces are controlled by the Dock process. Try dragging your Dock preferences to the Desktop and restarting your Mac. The preferences are in a file called com.apple.dock.plist. That file is in ~/Library/Preferences/ where ~/ is Unix shorthand for your home folder.

If it works you will have to arrange your Dock icons again and maybe rest some Dock, Spaces, and Mission Control Settings. If not, put the old preferences back and restart again.
Mail is still popping up.
 

KingArthurVI

macrumors regular
Dec 17, 2011
237
21
Minneapolis, MN
I'm seeing the same issue as OP. The Mail app pops up regardless if it's "hidden" (i.e. I hit the red button to close it out of the window) or if it's visible in its non-fullscreen form on the desktop. It pops into full screen and takes up the right side split view when this happens, very frustrating. I've seen this happen on older updates before but they were incredibly rare; after updating to 10.14.5 this happens about every 10-15 minutes.
 
  • Like
Reactions: SpiritSoul1008
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.