2017 iMac Bluetooth issues - turns itself off and on

Discussion in 'iMac' started by eddiel, Mar 5, 2018.

Tags:
  1. eddiel macrumors newbie

    Joined:
    Jan 16, 2007
    Location:
    Toronto
    #1
    Hi All

    A month ago I purchased a 27" iMac to replace my old mid-2007 iMac.

    I've been having bluetooth issues right from the outset.

    When I first set it up, it took awhile for it to recognise the keyboard and mouse via bluetooth. I chalked that down to first installation pains.

    After getting everything up and running and updating all the required s/w I started having bluetooth connectivity issues. At first I thought it might be some sort of interferences but I never had any issues with my mid-2007 iMac and the Magic Mouse 1.

    Then just by pure chance I was starting the bluetooth icon in the menu bar. It was on, both keyboard and mouse were connected and the three dots showing connectivity were there as well. Then they disappeared, the icon went grey (i.e. it turned off) and then came back on again.

    But when it came back on, it wouldn't connect to my keyboard or mouse. I did the usual turning each off and on but nothing happened. Eventually, they connected.

    Here's a summary of what I've experienced so far

    - the bluetooth module definitely turns itself off. It's not just a dropped connection.
    - there's no pattern other than it happens after the computer has been on for sometime
    - it usually happens while I'm working but it also happens when the iMac goes to sleep and I try and wake it
    - when the mouse connects before the keyboard, when I try and connect the keyboard, I go into the bluetooth menu, hit connect for the keyboard and nothing happens. I click on connect several times but it won't connect. The keyboard option font turns to bold for a split second then goes back to normal. Eventually it connects
    - not sure if this matters but my Magic Mouse 1 from the my mid-2007 iMac isn't discoverable on my new iMac (running the latest high sierra)
    - at first the problem happened sometimes, but after a couple of weeks it turned into a almost daily occurence

    What I've done to try and solve the problem:
    1) turned each off and on several times. Doesn't seem to make a difference
    2) debugged by resetting the bluetooth module; no change
    3) contacted Apple support; they suggested three things, SMC reset, NVRAM reset and then to create a test account to see if it also happens on the test account. They said that was required to check if the problem is with the user or the computer. I have done the SMS and NVRAM reset and it appeared to be working ok for about 2 days, then back to normal. I have not tried using a test account yet as it sounds like it'll be a waste of time, especially since the problem occurred when I first set up the computer and had two different accounts on the go; I blew the temp account out once I had everything set up.

    I have not tried a factory reset (as available under the debug menu) nor have I tried deleting the bluetooth plist files. Reason being is I haven't had a chance yet. But something tells me that after everything I tried already it'll just be a ticking the box exercise before actually having to send my iMac in for repair.

    So what I'm wondering is:

    1) Does anyone have any suggestions as to what I can try next, without contacting support? I'm hoping someone who's had the same issue has come across a solution
    2) Does this sound like a software problem or a hardware problem?
    3) I have Apple Care so am I better off just sending it back for a "repair" than wasting more time on this?

    Getting an external bluetooth dongle is not an option. I'm not going to plug in a dongle after spending $4K on a computer with a bluetooth module.

    Truthfully, I regret not returning the iMac the moment I noticed the bluetooth issues when I first got it. But it's too late now.

    I'll of course try deleting the .plist files when I get the chance, but I'm hoping others have had this problem and can offer up some sort of solution.

    I have found other threads but none seam to have a solution or even suggestions. I might get the same result but it was worth a shot! :)

    Eddie
     
  2. wardie macrumors regular

    Joined:
    Aug 18, 2008
    #2
    Did you get anywhere with this? I’ve now got a similar problem whereby soon after logging in all the Bluetooth devices disconnect and then reconnect. It’s fine after that but seems to often happen close to 100% of time. Any ideas it is an OS version bug? IMac 5k i7 580 GPU
     
  3. hfg, Apr 18, 2018
    Last edited: Apr 18, 2018

    hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #3
    FWIW: I also experience short disconnects occasionally with the mouse and keyboard, usually lasting 5-10 seconds. I believe this started after one of the recent OS updates.

    Also a iMac 5k i7 580GPU
     
  4. eddiel thread starter macrumors newbie

    Joined:
    Jan 16, 2007
    Location:
    Toronto
    #4
    Couldn't work out what was going on and nothing I tried seemed to work. The problem eventually just went away.
     
  5. wardie macrumors regular

    Joined:
    Aug 18, 2008
    #5
    +1 same problem also with a 2017 iMac 5k i7 580GPU - most of the time a few seconds after a boot up and log in, bluetooth keyboard and mouse are disconnected, then after say 5-10s reconnected. Then they work fine. Spooky.
     
  6. wardie macrumors regular

    Joined:
    Aug 18, 2008
    #6
    I tried the method to reset the Bluetooth module in the iMac which did seem to work for a few boots, but then problem returned, so there is obviously something wrong. No obvious USB3 devices that could be causing interference - anyway the problem is not one of transmission as when they are connected they work fine.
    Anyone got any ideas?
     
  7. eddiel thread starter macrumors newbie

    Joined:
    Jan 16, 2007
    Location:
    Toronto
    #7
    My original issues haven't gone away entirely. For awhile it was fine all the time, but something somewhere must have changed and they started again. Not as often, maybe once a week. But for the past month about once every two weeks or so the bluetooth module just crashes and is unavailable. I have to reboot to get it to work again.
     
  8. Bzztoh macrumors newbie

    Joined:
    Oct 14, 2018
    Location:
    Netherlands
    #8
    Same problem here. Switching on and off solves the issue for a few days. Annoying when Apple provides keyless keyboard and mouse.
     
  9. alien3dx macrumors 6502a

    alien3dx

    Joined:
    Feb 12, 2017
    #9
    my imac 2017 base line dont have this issue. i got 1 mouse logitech bluetooth,magic mouse,magic keyboard. Have try airdrop blue tooth thing without any issue. Maybe hardware specific model ?
     
  10. eddiel thread starter macrumors newbie

    Joined:
    Jan 16, 2007
    Location:
    Toronto
    #10
    I figured I should update this thread.

    I have not completely resolved my issues however, I did manage to isolate one of the main culprits; my vpn software.

    I noticed that although the mouse and kb would disconnect when the VPN was not running, they always disconnected when it was running. 100% of the time when I ran my VPN software they disconnected. As a work around, I removed Bluetooth as a network preference (System Prefs - Network). Now they do not disconnect when the VPN is running apart from the odd time and in those situations they disconnect for about 15 seconds and reconnect themselves.

    Now, from time to time I do have connection issues and when they happen only a reboot will "correct" the issue. My next test will be to remove the VPN software completely off my computer and see if the connection issue continue. The last time it happened, a few days ago, my Imac wouldn't even recognise the mighty mouse at first, then it did, but refused to connect, refused to turn off bluetooth...eventually I rebooted. It was still funky e.g. at login it would not recognise the mouse or the keyboard. I plugged in the keyboard and used a wired spare mouse I had to login. Once logged in, both were recognised and it's worked fine since.

    I also noticed that when they disconnected the mouse goes first, then the keyboard. The keyboard can be reconnected but the mouse will not reconnect no matter what I try. I always need to reboot to get the mouse to connect. In addition, I also noticed that when this happens the mouse behaves badly before it does e.g. swiping becomes less responsive. As a precaution I'm getting Apple to check them both out. It'll probably come to nothing but I'd like to eliminate any possible reason if I can.

    When I bought this imac earlier this year I was already running the VPN software on my mid-2007 iMac with no issues. So I'm not sure why it's an issue on this one.

    Not sure what I will test next. After Apple clear my mouse and kb I thought I might just wipe my HD and reinstall from scratch but I think I'll first do a test by removing the VPN software completely to see if that makes a difference.

    When I bought the computer I had it sent to my work so my IT department could load up my work software on it. They had no issue with connectivity at all. When I brought it home, I powered it up and the first thing I noticed was it took awhile to find the bluetooth keyboard. I just plugged it in figuring it wasn't a big deal. Then I started to set it up and loaded my old s/w on it, including the VPN software.

    So between work and home, either something happened to damage the bluetooth module when I transported it home, or I loaded some software onto it that's causing the issues.

    I eliminated interference by other devices as a possible explanation so it's either a s/w or Imac specific h/w issue.
     
  11. wardie macrumors regular

    Joined:
    Aug 18, 2008
    #11
    Interesting, not thought of VPN. I don’t use an app for that typically just settings in the apple system config manually switch on. It doesn’t seem to be correlated to VPN on/off for me. Still happening most times just after boot & login.
     
  12. eddiel thread starter macrumors newbie

    Joined:
    Jan 16, 2007
    Location:
    Toronto
    #12
    To update...I took my keyboard and mouse into work to see if they might be faulty. Of course they connected immediately to my macbook pro. I'm 99.99% sure this is software rather than hardware related.

    I'm going to wipe my drive and reinstall. I'll leave out the VPN at first and see if the issues still persist. If they don't I'll reload the VPN and see if that causes the issues again.
     
  13. mikehalloran macrumors 6502a

    Joined:
    Oct 14, 2018
    Location:
    The Sillie Con Valley
    #13
    Are you using a commercial VPN, one of the freebies or is this something imposed on you by your employer?
     
  14. eddiel thread starter macrumors newbie

    Joined:
    Jan 16, 2007
    Location:
    Toronto
    #14
    It's a commercially available, paid subscription VPN. Yesterday I decided to email their tech support and noticed that my version was out of date by about 10 iterations. I updated and have been testing it today and I've not had any issues. But, this happens from time to time and then it all goes crazy again so I'll need to reserve judgement for the next couple of weeks.
     
  15. wardie macrumors regular

    Joined:
    Aug 18, 2008
    #15
    I noticed recently some correlation with it happening and me starting up VMWare. I guess that plays around with networking too. I wonder if there is some community here around changing network services?
     
  16. eddiel thread starter macrumors newbie

    Joined:
    Jan 16, 2007
    Location:
    Toronto
    #16
    Well after some good news I'm not back to bad news. I removed the VPN software, made sure all the library files were gone as well. Everything seemed fine for a few days. Then had a short 10 second disconnect issue. Thought nothing of it. Then it happened again, but only 5-10 seconds of disconnect before reconnecting itself. It's now been two weeks and today the mouse and keyboard disconnected and would not reconnect. I connected the keyboard with a USB cable and also hooked up my USB cable mouse. Bluetooth module would not reconnect either the KB or the mouse.

    I tried turning the module off, which it would not do after the first click, but eventually did. Now the "Turn Bluetooth On" button is greyed out and I'll have to reboot the system.

    So far, Apple Support has tried to help me the best they can. When I went in to speak to them about it, they said that if uninstalling the VPN software doesn't solve the problem, it might be worth trying a fresh install as they would try doing that themselves if I brought it in for service. So I might as well try it.

    I think this is some sort of profile issue. I logged off and logged back in (not restarted) as my test user and the bluetooth module was working. Both the KB and mouse connected.

    I then logged off and back in as my main user and the bluetooth module was working.
     
  17. mreg376 macrumors 65816

    mreg376

    Joined:
    Mar 23, 2008
    Location:
    Brooklyn, NY
    #17
    I've seen a variation of this problem, 2017 iMac. Occasionally my keyboard would just stop working. It still says it's connected, but it just doesn't work. No matter what the battery level. I have to disconnect and reconnect, or plug it in to power, to bring it back. Happened to my trackpad once too. I can go for weeks without a problem, then it happens. Exchanged the keyboard, still happened. Hasn't happened for a while now, but I expect it will. BUT it has never happened to the mouse, so I don't think it can be a hardware issue. Very strange.

    I'm using the magic keyboard (w/numeric keypad) and magic mouse that came with the 2017 machine. But the Apple trackpad is an older battery-powered edition. Can that be doing it?
     
  18. mikehalloran macrumors 6502a

    Joined:
    Oct 14, 2018
    Location:
    The Sillie Con Valley
    #18
    Try this first:

    Unpair all BT devices. You may find more than three. Now re-pair one at a time.

    In older OS, this was quite common.

    I don't expect that to work but it should be something that Apple support will ask you to try.

    If it persists, the next suspect is an improperly assembled Bluetooth antenna.
     
  19. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #19
    I missed this thread the first time around. I've got Macs and PCs in 5 office locations plus my house. Short history: I owned an older iMac (2009 I think) before going to Dell laptops and rMBPs in 2013 for a few of my engineering techs and I, and started having BT timeout issues pretty much right away at a couple of locations but not at one field office - it drove us batcrap crazy for a bit until I figured it out. The single location had two Asus routers running Tomato - I had enabled Bluetooth Coexistence mode on those Asus routers but that option wasn't available in the non-Tomato OS routers. On the Macs the fix was to fire up Terminal and run a command then reboot, zero issues since - it's one of the first things done on our new Macs, including the few iMPs and my own 2012 Mini Server that get toted from location to location.

    What's changed? The older Macs included a BT chipset that included several features that aren't present in newer Macs, starting with BT 4 - including EDR. I use several input peripherals that pretty much require EDR, so I use a Class 1 StarTech dongle and there's a bunch of them used by my techs. I've noticed that some networking SW we use that interferes with wireless packet transfers and causes an increase in the timeout frequency of BT peripherals - SIG stopped requiring the "publishing" of BT chipset capabilities starting with BT 4, however, I looked up the chipset made by Broadcom that's installed in my Mini Server and my (now sold) late-2013 rMBP and there are several desirable features that I would expect - including EDR - that are not present. The BT chipsets in newer Macs are low-power units - they're IMHO prone to timeouts in situations where there is poor communication between the computer and wireless peripherals.

    Tomato.org documents BT Coexistence Mode here. This goes back around a decade...

    At the office I have several people come into my office each hour. All of them have smartphones, most have laptops in their bags. Our networking is a real spatial mess, but it works fine 99% of the time since I've planned for it. At my home office, I use my peripherals in wired mode, I have my router's 2.4GHz frequency turned to "Low Power", have my iMP connected via Ethernet, and tend to connect to 5GHz when I need it while owning several devices that connect only to 2.4GHz as that's what they're capable of.

    When a router's options do not include the option to enable Coexistence Mode, it can be enabled on a Mac or PC. I've enabled BT Coexistence Mode on my iMP and Mini Server (the latter is in a cabinet and connects via wifi). The command, using Admin credentials:
    sudo defaults write /Library/Preferences/com.apple.airport.bt.plist bluetoothCoexMgmt Hybrid

    Zero issues with around 25 Macs and I have no idea how many peripherals. I use Regedit on PCs with a similar goal, also zero issues. My techs are really whiny - I'd know if there is a problem... o_O
     
  20. TechnicallyTee macrumors 68000

    TechnicallyTee

    Joined:
    May 14, 2013
    Location:
    Atlanta
    #20
    This issue seems like it’s an ongoing issues with these iMacs. Battling the same issue on mine where the Bluetooth will drop and I have to wait a minute or so and then the mouse and keyboard will reconnect.

    I was on chat with support yesterday for about an hour and we did all the potential fixes and nothing seemed to work. One plus is right now I don’t get the Bluetooth not available issues but not just intermittent drops or Bluetooth and having to work a minute or two for them to reconnect.

    I feel like if I take it in they won’t have a fix and will say it’s interferring with someone so I made a appointment for this weekend and between now and then I’m going to try all the fixes again and then checking is something is interfering with it.

    Super frustrating.
     
  21. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #21
    My opinion only:
    Bluetooth = a nifty technology on the drawing board, that doesn't work out quite so well in the real world.

    I use USB connections instead.
    Clunkier? Yes... but... they work.
     
  22. wardie macrumors regular

    Joined:
    Aug 18, 2008
    #22
    I’m still having same problem, have tried all the advice I could find on re-pairing, restarting Bluetooth etc. Curiously though mine only ever seems to do the drop/connect trick once per boot cycle, often a minute or two into using the system after first login.
     
  23. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #23
    I forgot to "unwatch" here, so here I am - have ya'll explored the "disable Handoff" workaround? I rarely use the feature and have it turned off in 3 of the 4 user accounts on my two Macs, and I usually have BT disabled on my iPhone/iPad until I need it (it's only a Siri command away...).

    There's a bunch of issues/solutions posed on Michael Kummer's web page dedicated to BT issues regarding trackpads and mice - there's quite a bit to read through, or jump down to the "Disable Handoff" bit, which was pushed to him by some of his readers. I'm still sticking with my StarTech dongle...
     
  24. misan123 macrumors newbie

    Joined:
    Dec 20, 2018
    #24
    Like others above, I am experiencing the same problems with BT disconnects on a 2017 IMac 5K i7 (three dots disappearing over the BT logo). It is really telling that Michael Kummer started reporting this same problem more than 3 years ago: Apple does not care or does not know.

    None of the fixes removed the problem entirely from my system, but some might have helped to reduce its frequency. In my case, it seemed to happen mostly minutes after waking up the system, but other times I could not wake up the system using the keyboard nor the mouse, so I guess it also happens while the system is sleeping but lasting usually a minute or so it is not very likely to notice it while system is sleeping.
     
  25. TheMadBrewer macrumors regular

    TheMadBrewer

    Joined:
    Feb 11, 2008
    Location:
    Marina del Rey, CA
    #25
    I've been having similar issues with my 2017 5K iMac as well. For months, the mouse would disconnect and then most of the time, reconnect after about 30 seconds. Irritating but livable as it happened at most once a day. Occasionally it would take longer and I'd end up connecting a wired mouse and turn bluetooth off, then back on and then it would work. My magic keyboard would also disconnect, but I now leave that plugged in all the time.

    Sometime last fall I realized the problem had pretty much gone away -- I assumed that one of the updates I installed had fixed it.

    Then last week I upgraded to 10.13.6 and the problem is back -- and worse. Happens every couple hours or so and almost never comes back on its own. I open Bluetooth preferences and when I click "Bluetooth off" nothing happens. After a minute or so I can finally turn bluetooth off, then back on and my mouse connects.

    Occasionally now it disconnects and I get "Bluetooth not available" in the menu bar. If it doesn't come back I open go to Advanced Bluetooth preferences and toggle the "Let Bluetooth wake this computer" setting and that seems to bring it back.

    It seems clear to me that something changed in 10.13.6 -- for the worse.

    I guess I'm down to trying a Bluetooth dongle but that brings up other issues.

    And btw, I have the same issues with multiple Magic Mice -- early on I actually bought a new one in case it was the mouse's fault. Doesn't matter which MM I use or even an old Kennsington Pocket mouse. I to the point where I leave my iPhone open with the remoteMouse app working so I quickly go thru my sequence to get things working again.
     

Share This Page