2018 MBP Slow WiFi on Wake

Discussion in 'MacBook Pro' started by mcaswell, Jul 27, 2018.

  1. mcaswell macrumors regular

    Joined:
    Dec 22, 2013
    #1
    I've noticed that almost always when I wake up the computer from sleep after not having used it for a while, my WiFi connection is very slow (even after waiting a few minutes for it to stabilize), as evidenced both by the link rate shown in the WiFi menu, and by an iPerf test (see screen shots)... low double-digit mb/s link rate and actual tested speed.

    Turning WiFi off/on immediately results in a link rate in the expected 800 mb/s range, and actual speed of 400-500 mb/s (I'm in the same room as the base station).
     

    Attached Files:

  2. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #2
    Just a followup, the problem seems to have resolved itself... hasn't happened in several days.
     
  3. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #3
    Hmmm... perhaps not, as it's been happening again.
     
  4. danistyping macrumors regular

    Joined:
    Dec 8, 2009
    Location:
    Boston, MA
    #4
    Same here! Anyone know the cause/solution?
     
  5. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #5
    I got nothing. But can you post the full details from the wifi assessment. The screen shot only shows a portion.

    And what router are you using?
     
  6. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #6
    Here's a screen shot from when it's working fine (will have to wait until it misbehaves again to get the "slow" screen shot). My router is a Linksys Velop (3 node system).
    --- Post Merged, Aug 1, 2018 ---
    I should also reiterate, when I say "very slow" that's relative to what it should be and what it normally is, but still produces a usable internet connection for browsing, email, etc. (in other words, I probably wouldn't notice it except for when I do LAN stuff, or download a big software update).
     

    Attached Files:

  7. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #7
    Thanks! Yeah that screen for both.

    Please don't mask out the BSSID. It only has local relevance to you. I know it sounds absurd, but I'd really like to see that the BSSID in both cases is the same. I know, you would have noticed, I'm sure. But hey, sometimes it's the crazy things that get missed.
     
  8. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #8
    Next time it misbehaves (which, again, is typically when it's been asleep for a few hours) I will do screen shots before and after cycling the WiFi connection. I did previously confirm that it's connected to the same Velop node each time, and on the 5ghz band, though I can't say with absolute certainty that it's the same radio (upper vs. lower 5ghz channels)... this particular Velop node has a hardwired backhaul, so because it doesn't need to use one of the 5ghz radios for backhaul, it makes both available to clients.
     
  9. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #9
    Two screenshots are attached, one when the slowdown was taking place, the next immediately after cycling WiFi off/on.
     

    Attached Files:

  10. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #10
    Thanks. I got nothing. It’s connecting to the same base station I believe, so it’s not like it’s bizarrely picking some remote antenna. If your Linksys firmware is up to date, I’d report it to Linksys and Apple.
     
  11. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #11
    It's really odd... I haven't been able to home in on a particular circumstance that causes it to happen. I had thought it only happened after long periods of sleep, but this morning I woke up the computer and found the connection was normal. The difference this morning compared to most was that the computer was unplugged... I'm assuming when plugged in, it maintains the WiFi connection even when asleep (for Power Nap), but does not when unplugged, so perhaps that offers some clues.
     
  12. mcaswell, Aug 3, 2018
    Last edited: Aug 3, 2018

    mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #12
    With the above observation, last night before going to bed I turned off Power Nap and Wake for Wi-Fi in the Energy Saver settings (since and Power Nap was off by default on battery, and Wake for Wi-Fi is not available at all), and this morning the problem did NOT occur. While such a small set of data (once instance of the problem not occurring when on battery power, and one instance of it not occurring with those two suspected settings turned off) is certainly not enough to pronounce a culprit, it's still promising.
    --- Post Merged, Aug 3, 2018 ---
    More observations. Speed was fine when I first woke it up (as evidenced by the link rate shown in the WiFi menu, and by speed tests conducted over the course of several minutes), but even though I've been sitting here working on the machine for the past 30 minutes, at some unknown point the speed degraded back down to ~13-40mb/s.

    Ran a few speed tests to confirm, but then after a few minutes the speed went back to normal. However, I should note that when I've had this slowdown previously, I gave it plenty of time to recover on its own, but it did not.

    I wonder if perhaps the WiFi chip in the MBP reverts to a minimal link speed after a period of non- or light use as an energy-saving tactic, with the intention being to bring it back to normal speed when higher network activity requires it, but sometimes it doesn't quite make the transition and remains stuck in the reduced speed mode? My iMac Pro is on ethernet, so I don't pay much attention to WiFi on that machine, but I do recall when I first got it I noticed that the link speed would drop to about 54mb/s or lower when there wasn't much network activity, but would "wake up" as needed (there was a thread about it here, as others noticed the same thing).
     
  13. Howard2k, Aug 3, 2018
    Last edited: Aug 3, 2018

    Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #13
    I don't think the MBPro chip would throttle down. Mine is a 2015 but I've never seen that behaviour or heard of it in other deployments.

    But...

    The 2018 MBPro uses a Apple/Universal Scientific Industrial (USI) 339S00428 Wi-Fi/Bluetooth module, according to ifixit.
    The 2017 iMac uses a Broadcom BCM943602CDP.
    The 2018 iMac Pro uses the same USI as the MBPro.

    So you could be onto something there.


    EDIT: It would be interesting to see if this happens in non-mesh wifi deployments too. Or some other hardware manufacturer who is not using the same chipset as being used in your wifi AP.
     
  14. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #14
    Some more developments today, providing some additional insight while also creating more questions.

    First, I observed throughout the day that the issue is not limited only to when the machine wakes up. As I noted earlier, it was fine this morning at first, then degraded after a while. I also found that if I was patient, it would sometimes recover on its own (after maybe 20-30 minutes), but even then it still wasn't entirely stable (problem would come and go). I did also notice that sometimes the measured speed would be a bit higher than the Tx Rate shown in the WiFi menu (example, Tx Rate 13mb/s, tested speed 120mb/s). But still well short of the 400-500mb/s expected.

    Taking your comments about the iMac Pro a step further, I disconnected the ethernet from that machine and after running a few iPerf tests to confirm the WiFi connection was good, I set up a looped iPerf test to run once a minute for 10 seconds. Came back in about 30 minutes later, and found that it too had suffered from a similar degradation of the WiFi connection (Tx Rate was in the low double digit range, and actual speed tests corresponded), which was instantly recovered to full speed when I disconnected/reconnected.

    Sensing a breakthrough (as this would indicate that either there was an issue with the WiFi chip that is in both of these computers, or an issue with the Velop), I sought to answer that question by recruiting my daughter's MacBook Air. I set all three machines up to do a 10 second iPerf test once a minute (round-robin style, not simultaneously), with the goal being to find out if the MBA also exhibited this behavior (which would point to the router, or an interference* issue), or if its connection remained normal a reasonable amount of time after the MBP and iMac Pro degraded.

    However, after letting the tests run for an hour, all three machines retained a rock-solid WiFi connection. Currently, I'm just letting them sit for a while, to see if a period of non-use prompts the problem to recur.

    * Regarding interference, if I were reading a post like this from someone else, that would be my first guess, especially after today's behavior, with the problem coming and going. But again, the fact that full speed is instantly restored by cycling the connection doesn't seem to support that as being the culprit, and also during the periods when the MBP's connection was degraded, I ran a test from the iPad, which was fine.

    So, anyway, I'm going to keep hunting for clues. At this point, I don't think I have enough information to go to either Linksys or Apple, as I'm sure each of them (without some corroborating evidence) would simply point the finger at the other.

    Unfortunately, I don't have another AC router on hand (just a little Airport Express).
     
  15. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #15
    I’m hesitant to suggest it given the ethical implications, but if there’s an unlocked network nearby that belongs to a neighbour that would be interesting to see. The first six digits of the BSSID (14:91:82) can loosely be used to identify the vendor. I say loosely, because this shows Belkin, not Cisco or Linksys.

    Maybe a Starbucks, McDs, etc.

    Agreed, doesn’t sound at all like interference.
     
  16. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #16
    Yeah, the Velop identifies as a Belkin product in the WiFi scanning app I use. I'll try again in the morning to replicate the issue.
     
  17. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #17
    So, I ran a looping iPerf test overnight on all 3 machines overnight, though I set them to run once every 20 minutes. No issues were found. Similarly WiFi on the MBA and iMac Pro has been rock solid all morning, though earlier the MBP did once again drop down to 13mb/s. Cycling WiFi off and on restored it.

    However, before I did that, I did stumble across a small clue. I came across a mention elsewhere of a command line utility to help diagnose WiFi problems. The most basic usage of it spits out a simple assortment of info about the connection, very similar to what's shown in the screen shots above by option-clicking the WiFi menubar icon. The most notable difference is that the menubar drop-down shows PHY Mode (802.11ac), while the command line utility doesn't show this, but does show a "maxRate" number (along with "lastTxRate", which appears to coincide with the Tx Rate shown in the menubar).

    Anyway, what I found interesting was that before the connection degraded, it showed the following:

    lastTxRate: 650
    maxRate: 144

    I didn't pick up on the obvious discrepancy (maxRate being lower than the actual rate) until afterward. Soon after this, the connection speed plummeted, and the command line utility said this:

    lastTxRate: 14
    maxRate: 144

    Cycling the WiFi connection, expected connection speed was restored, and the maxRate figure changed to what it should have been:

    lastTxRate: 780
    maxRate: 867

    The Velop is a 2x2, so 867 indeed is the maximum rate. So where did this 144 come from? Some quick research revealed that this rate coincides with 802.11n 2x2 20mhz. It would seem that something is occasionally causing my MBP to think its connected to an 802.11n network, but what's most puzzling as that when this occurs, it is NOT reflected in the WiFi drop-down menu, which continues to indicate that it's 802.11ac.

    Not sure how helpful this will be, but it at least gives me some direction, and gives me something to look for next time it happens. And I will continue to attempt to identify whether the MBA and iMac Pro have this same issue (so far, the MBA has not exhibited it at all, and the iMac Pro did have one episode yesterday).
     
  18. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #18
    MCS15 for 802.11n and MCS7 for 802.11ac are both 20Mhz and 144Mb/s.

    On ac, MCS0 and MCS1 can be 14Mb/s. On n, MCS8 and MCS1 can be 14Mb/s. Technically I believe they are different labels for the same thing, BPSK 20Mhz, 2 streams, for instance is MCS0 for ac and MCS8 for n. So just labels I think. Not sure whether it matters or not.

    The Velop does support both 802.11n and 802.11ac. So it could be either...

    867 is ac only of course, and therefore 5GHz only.

    I’d guess that it’s 14Mb/s on ac, not n. Not sure if that help in any way. 2.4Ghz is obviously far more likely to suffer interfere problems and a poor signal to noise ratio could force the downgrade to 14Mb/s but I’d expect them all to scale down in that case. Unless the MBPro dropped to 2.4Ghz and so was affected (and also used 802,11n) but the MBA and iMac stayed on 5GHz and so were not affected. This doesn’t seem plausible to me, but if you have an option on the Velop to disable the 802.11n and/or 2.4Ghz frequency you could be sure that the 14Mb/s is still over 5GHz. Is might then be ac or n, but at least it rules out a 2.4Ghz issue.
     
  19. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #19
    You clearly know MUCH more about this stuff than I do... I know just enough to be dangerous. I can disable 2.4ghz on the Velop as a troubleshooting step (and, if I jump through some hoops, can disable 802.11n), but I'll save that as a last resort since it would cause some disruptions around the house with non-ac devices.

    Shortly after my last post, the iMac Pro's connection degraded again (for the first time since I observed it happening yesterday afternoon), but it recovered on its own after 20 minutes or so. MBA still has not exhibited this behavior.

    But I made another observation during the iMac Pro's episode just now. When it happened, I noticed that it coincided with my kids turning on the TV downstairs (pretty much directly below my office) and beginning to watch a movie. In particular, the Vizio soundbar broadcasts an 802.11n network (it's not actually used for anything significant, reportedly just for the pairing process of their smartphone app, but you can't disable it). I considered that perhaps an n-only network being broadcast nearby (not on the same channel, but on the same band, the low 5ghz channels) was causing the downgrade to a slower connection, but I somewhat ruled that out as the culprit, because when I noticed the slowdown, I went down and shut off the soundbar for a few minutes, which did not result in the connection recovering to normal speed (and it did recover on its own a little while later, after I had already turned the soundbar back on).

    Additionally, the problem has occurred during times when the soundbar is definitely not on (in the morning, before anyone else has woken up). But when looking through my neighbor's networks, I see at least 2 or 3 that are 802.11n 5ghz... weak but there.

    So, I wonder if somehow the n-only network of the soundbar and my neighbors is somehow causing the WiFi chip in the MBP and iMac Pro to freak out. Even if the condition that prompts it is only transient (maybe the neighbors having a brief spike in their WiFi usage, or the Vizio soundbar briefly transmitting for some reason when first turned on), sometimes it recovers on its own, but other times it remains in this degraded state and needs a kick in the rear (cycling WiFi power or disconnecting/reconnecting)?
     
  20. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #20
    I'm no expert. :)

    If you option click on your wifi icon and bring up the advanced menu (like you did above) you can choose the Create Diagnostic Report.

    What would be really cool would be to use the MBA to create that report while either the iMac or the MBPro are showing the issue.

    Then once that's created (might take a few minutes) you'll have a folder created on your desktop. That will have a file in it called Wireless_Diagnosics...tar.gz. Inside there is a file called Wifi_scan.txt. That will show what's running in your vicinity. This is a CSV file so it would be trivial to import into Excel or Numbers I suspect.

    The channels do overlap to some degree when using 2.4GHz. On 802.11b, for example, we had channels 1 through 11 in North America, but only 1, 6 and 11 were the non-overlapping channels. So channel 5 overlaps with channel 6 for example. And to a lesser degree, channel 5 would also overlap with channel 1. 802.11n has similar overlapping.

    In the 5GHz space there's more room and less overlap, but the report generated above will allow you to see what else is running. It won't show non-wifi interference explicitly, but you'll see the signal strength data. Unfortunately not the noise, but it might have something relevant. Here's an example:

    'Network-5G' <57726179 2d3547>, bssid=3c:00:8a:00:1f:00, channel=[44 (80 MHz, Active)], cc=CA, type=11ac, rssi=-74, rsn=[mcast=aes_ccm, ucast={ aes_ccm }, auths={ psk }, caps=0x0, wpa=(null), wep=no, ibss=no, ph=no, swap=no, hs20=no,

    The close RSSI gets to 0, the stronger the signal. So a -40 network is much louder than a -70 network.
    In your example in the first post, even where you've got a very slow connection, your signal to noise is very good. -91 noise and -44 signal. -90 noise and -44 signal would be worse. As would -70 noise and -44 signal. The closer those numbers get to each other the worse performance you would expect.

    Here: https://www.wlanpros.com/mcs-index-charts/
    You can see that for 2 streams and 20MHz spacing and 14.4Mb/s (MCS1) the SNR is 2 and the RSSI is -82. So I believe if your RSSI is -79 and your noise is -81 you'd end up around here. Or if your RSSI is -44 and your noise is -46. But your noise is nowhere close to that it would seem. So this certainly seems like it's "unnatural".

    I would try to find the loudest networks on 2.4GHz and 5GHz and ensure that you're have adequate channel spacing. Ideally turn off 2.4Ghz if you can. But as you said, may cause other issues. Certainly I would verify the other 5GHz networks and the channels. I have three relatively loud 5GHz networks close by . 1 is mine, 2 belong to neighbours. They are both sitting on channel 44 so stepping all over each other. I'm on channel 153 so miles away from them. The 2.4Ghz space here is a mess, there are 15 2.4GHz networks around (and again, only 3 non-overlapping channels for 802.11b, only 2 for 802.11n 40GHz). Having said that, I keep some of my devices in the 2.4GHz space too and they still work fine, even when congested. I've never seen anything like what you're seeing.

    Other things that mess up the 2.4GHz space - USB3, microwave ovens, fluorescent lights, bluetooth, and cordless phones. And I imagine LOADS of industrial devices.

    In the 5GHz space there is a weather radar in North America. That uses channels up around 120. And cordless phones too. Are you close to an airport?

    As opposed to disabling 2.4Ghz, another idea might be to try to switch the APs. This is a mesh right? So this one AP (identified by the BSSID) could be switched with a partner AP? Either switch the APs, or move to a different location where you connect to another AP on the same network and see if the symptoms still exist? Does that make sense?

    Did you change your channels? Or is the Linksys box picking channels? If the Linksys box is picking channels, I would consider taking that burden away from it and forcing it to a specific channel, once that you know is clear based on the Create Diagnostics option. In the first set of images you're using channel 149. In the second set it's 149. In the third set it's channel 48.



    Sorry for the long post. I think you're doing a great job by yourself. Next things I would do:
    * Create Diagnostic and look a the 5GHz space. See how crowded it is and what channels are in use.
    * Try the other AP/node.
    * Force the channel to a low channel and a high channel and see if there is any variation.
     
  21. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #21
    No, I really appreciate all the help (your earlier post is what prompted me to scrutinize the iMac Pro more closely, since I hardly ever use that machine on WiFi). Basically, I'm fumbling around in the dark here, and you are providing a flashlight. :)

    The iMac Pro is actually in the middle of a speed drop right now (MBP is fine at the moment, and again, MBA has not flinched in the 20 hours or so that it's been running). Attached is a screen shot from the iMac Pro (as before, actual measured speed is similar).

    Screen Shot 2018-08-04 at 2.06.42 PM.png

    I went ahead and created diagnostic reports on this machine (during the slowdown) and also on the correctly functioning MBA. And as with the slowdowns on the MBP, disconnecting and reconnecting to the network instantly restores full speed.

    Screen Shot 2018-08-04 at 2.36.30 PM.png

    And I did actually already try swapping nodes a day or two ago (the MAC of this one ends in :26, the other one ends in :C2). I let the Velop system's "channel finder" determine channels for the 5ghz band (since each unit has 2 radios, and there are 3 units, I figured it would be best to let it take care of that), though I did manually set the 2.4ghz channels to 1, 6, and 11. That said, I'm fairly certain all of this is taking place on 5ghz, I've seen no indication of being on 2.4ghz.

    Regarding high vs. low channels, I have noticed, at least yesterday and today, that all this is taking place on the low channels (and the screen shots from a few days ago, when I had the :C2 node up here, were also on the low channels). I don't think there's a simple/elegant way to force a connection to the upper channels, I think I just have to log in and disable the lower channel radio. The way the Velop system works is that it doesn't have one radio dedicated solely to backhaul, it changes it up depending on what it thinks is best. This particular node has hardwired backhaul, so both 5ghz radios are available for client use on this node... it decides which one to connect the client to, reportedly based on how much traffic is on each. But I think I can disable the low channels on this node with no ill effect, since, again, it doesn't need the other radio for backhaul.

    I'll look through those diagnostic reports for clues, but just glancing again at my WiFi scanning app, it looks like around me I've got 3 neighboring networks on the low channels (36, 36, and 40), as well as 3 on the high channels (132, 149, 153). They're all pretty weak, RSSI around -90.
     
  22. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #22
    Such weak signals shouldn’t have much impact. That’s REALLY weak.

    Doesn’t sound like faulty hardware since it’s been seen on two wifi APs and two USI based wifi devices. But the Broadcom based MBA is working great. Also sounds like you’re in a pretty isolated area (for 5GHz).

    So my money is on some sort of compatibility clash between the Belkin chipset and the USI chipset. Or some other aspect of each device.

    If this was a general iMac Pro / MBPro issue I think there would be more noise on the forum.

    So I unfortunately I think the next step is to find another AC AP and see if the fault can be reproduced.
    Then take the information to Apple and Linksys and see.

    But whatever you do, please keep us posted.
     
  23. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #23
    On the high channels now, and it just happened again on the MBP (including the strange maxRate: 144).

    Screen Shot 2018-08-04 at 8.03.19 PM.png

    However, the difference this time was that it recovered quickly on its own after I ran an iPerf test. When I saw the low link speed on the MBP, I went and checked the iMac Pro, and it had the same thing. But it too went back to normal speed shortly after sending some traffic through it.

    Not sure what to make of that. Perhaps that's how it is supposed to work (drops down to a slower speed as a power-saving measure, then speeds back up when the level of network activity requires it), but it was just somehow stuck in that power-save mode before? I'll continue to observe.
     
  24. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #24
    Way back in the 802.11b days, pre Cisco acquiring Linksys, I remember that I always had to disable the power save in my Linksys routers to make them work better. Or it might have been my Linksys NICs actually. Or perhaps even both. Calling Linksys they had no idea whatsoever what the settings on their router configuration page were really for :D Not a knock on Linksys, they’re all as bad as each other.

    For 802.11ac there is a power save feature as part of the specification called TXOP PSM. I don’t think this should result in a reduced TX rate; simplistically all devices in the same wifi network hear all traffic, so TXOP PSM allows your MBPro to listen as your MBA says “ok everyone, I’m sending a stream of packets to the Internet for the next 150ms”, so your MBPro can hear that and decide “In that case I’m going to shut my radio off for the next 150ms then” and have a very short sleep. It should be completely seamless and unnoticebale to the user.

    And certainly a device sending traffic should not be shutting off the radio. But you never know!

    I’m pretty certain it’s not how it’s supposed to work. :)
     
  25. mcaswell thread starter macrumors regular

    Joined:
    Dec 22, 2013
    #25
    This morning I had another speed drop episode on the MBP, but this time it did not quickly recover on its own as it did last night. But eventually (after a half hour or so) it did.

    Today I picked up a WiFi extender, which I set up as a wired access point in my office (I was thinking of doing that anyway, to take advantage of the MBP's 3x3 WiFi, as the Velop is only 2x2). I specifically sought one out that, in addition to having 3x3 or 4x4, was NOT based on Qualcomm, and ended up with a Linksys RE9000 (4x4, Mediatek-based). Blazing-fast connection at the moment:

    Screen Shot 2018-08-05 at 6.07.22 PM.png

    Let's see if the speed lasts!
     

Share This Page

55 July 27, 2018