Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Gregnyrfan

macrumors regular
Original poster
Jun 17, 2011
109
32
Has anyone received this message? Started occurring after updating to 10.13.6. I'm also running iOS 12 beta 3 on my iPhone 6s plus.

The installation of the new software fails because the software is not available yet.

New Software iPhone 8,2.jpeg


Downloading.jpeg


Installing Not Available.jpeg
 

Banglazed

macrumors 601
Apr 17, 2017
4,931
9,095
Cupertino, CA
iTunes 12.8 isn’t compatible with iOS 12. Either you have to download and run Xcode to install the required components to work properly or downgrade iTunes or wait for iTunes update.
 

Gregnyrfan

macrumors regular
Original poster
Jun 17, 2011
109
32
iTunes 12.8 isn’t compatible with iOS 12. Either you have to download and run Xcode to install the required components to work properly or downgrade iTunes or wait for iTunes update.

Thanks. I removed the beta xcode due to some issues i've been having and went back to xcode 9 for now.

You need an updated mobiledevice.framework. I copied my from Mojave.

https://forums.macrumors.com/thread...pport-for-itunes.2126709/page-4#post-26227584

Thanks, Would you be able to send me the file? I don't have Mojave running. This would prevent me from installing xcode 10 beta.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.