All browsers crash when uploading files

Discussion in 'macOS Sierra (10.12)' started by Dantnad, Jul 11, 2016.

?

Are you having the same problem on macOS Sierra?

  1. Yes

    2 vote(s)
    33.3%
  2. No

    4 vote(s)
    66.7%
  1. Dantnad macrumors newbie

    Dantnad

    Joined:
    Jul 11, 2016
    #1
    I've got this problem after installing macOS Sierra that is really frustrating!!!! I initially thought it was a Google Chrome Problem, then I found out it happened to every single Web browsing app; Safari, Chrome, Mozilla...
    What happens is that when I try to upload a file to any page via "upload file" button results into crash and then I get an "internal error" i've contacted Apple about this problem and they told me to provide feedback about it on the included app, but I really need to upload files on some Web pages using this method as some Web pages don't support the Drag & Drop way of uploading.

    My macbook specifications are
    MacBook Pro Retina early 2015
    13 inch
    8 GB RAM
    128 GB SSD

    I'll copy/paste Safari errors here. Hope you can help me.
    Safari Crash Info

    Nombre de excepción: NSInternalInconsistencyException

    Descripción: -[NSNib _initWithNibNamed:bundle:eek:ptions:] could not load the nibName: iCloudQuotaBanner in bundle NSBundle </System/Library/PrivateFrameworks/FinderKit.framework> (loaded).

    Información del usuario: (null)


    0 CoreFoundation 0x00007fff7e36c06b __exceptionPreprocess + 171

    1 libobjc.A.dylib 0x00007fff91d7db7d objc_exception_throw + 48

    2 CoreFoundation 0x00007fff7e3e56cd +[NSException raise:format:] + 205

    3 AppKit 0x00007fff7c0ed518 -[NSNib _initWithNibNamed:bundle:eek:ptions:] + 669

    4 AppKit 0x00007fff7c0ed22b -[NSViewController _nibWithName:bundle:] + 182

    5 AppKit 0x00007fff7c0ece2a -[NSViewController loadView] + 132

    6 FinderKit 0x00007fff8a2ad2b9 -[FI_TViewController loadView] + 98

    7 AppKit 0x00007fff7c05d7da -[NSViewController _loadViewIfRequired] + 75

    8 AppKit 0x00007fff7c05d745 -[NSViewController view] + 30

    9 FinderKit 0x00007fff8a30b8bf -[FI_TBannerViewController updateBannerState] + 401

    10 FinderKit 0x00007fff8a30b377 -[FI_TBannerViewController initWithBannerType:] + 71

    11 FinderKit 0x00007fff8a30b102 +[FI_TBannerFactory bannerViewControllerForType:] + 105

    12 FinderKit 0x00007fff8a363033 -[FI_TBrowserViewContainerController configureBannerView:selectedNodes:isInColumnView:isBackupBrowser:] + 243

    13 FinderKit 0x00007fff8a44d87d -[FI_TBrowserContainerController configureBanner] + 243

    14 FinderKit 0x00007fff8a455e37 -[FI_TBrowserContainerController configureAccessoryViews:] + 95

    15 FinderKit 0x00007fff8a445fc3 -[FIAppCentricContainerController configureAccessoryViews:] + 77

    16 FinderKit 0x00007fff8a44d6b7 -[FI_TBrowserContainerController commonFinishInitialization:] + 122

    17 FinderKit 0x00007fff8a457643 -[FIContainerController createBrowserViewWithViewStyle:containerState:] + 572

    18 FinderKit 0x00007fff8a4546d2 -[FI_TBrowserContainerController buildBrowserView:containerState:] + 353

    19 FinderKit 0x00007fff8a450ff9 -[FI_TBrowserContainerController configureContainerWithState:] + 236

    20 FinderKit 0x00007fff8a450569 -[FI_TBrowserContainerController initWithWindowState:targetPath:containerLayoutManager:containerDelegate:] + 462

    21 FinderKit 0x00007fff8a3a6354 -[FIFinderViewGutsController _internalSetTargetPath:withViewStyle:] + 1069

    22 FinderKit 0x00007fff8a3a12e6 -[FIFinderViewGutsController forceContainerToExist] + 215

    23 FinderKit 0x00007fff8a3a248f -[FIFinderViewGutsController prepareToShow] + 134

    24 FinderKit 0x00007fff8a459386 -[FIFinderViewAppCentricGutsController prepareToShow] + 47

    25 FinderKit 0x00007fff8a3abed9 -[FIFinderView viewWillMoveToWindow:] + 379

    26 AppKit 0x00007fff7bff91ab -[NSView _setWindow:] + 254

    27 CoreFoundation 0x00007fff7e2e8e82 __53-[__NSArrayM enumerateObjectsWithOptions:usingBlock:]_block_invoke + 114

    28 CoreFoundation 0x00007fff7e2e8d16 -[__NSArrayM enumerateObjectsWithOptions:usingBlock:] + 198

    29 AppKit 0x00007fff7c81161c __21-[NSView _setWindow:]_block_invoke.639 + 151

    30 AppKit 0x00007fff7bff9c0a -[NSView _setWindow:] + 2909

    31 AppKit 0x00007fff7bff657d -[NSView addSubview:] + 461

    32 AppKit 0x00007fff7c0f37ba -[NSBox setContentView:] + 109

    33 AppKit 0x00007fff7c6bfe26 -[NSSavePanel(NSSavePanelLayout) _layoutViewsVerticallyAndResizeWindowToLastExpandedSize:accessoryViewHeight:documentWindow:navViewMinSize:visibleFrameAvailable:] + 5491

    34 AppKit 0x00007fff7c6b5585 -[NSSavePanel beginSheetModalForWindow:completionHandler:] + 543

    35 Safari 0x00007fff8df0cf90 _ZN6Safari19BrowserPageUIClient12runOpenPanelERKNS_2WK4PageERKNS1_5FrameERKNS1_19OpenPanelParametersERKNS1_23OpenPanelResultListenerE + 650

    36 Safari 0x00007fff8e1407a8 _ZN6Safari2WKL12runOpenPanelEPK12OpaqueWKPagePK13OpaqueWKFramePK27OpaqueWKOpenPanelParametersPK31OpaqueWKOpenPanelResultListenerPKv + 126

    37 WebKit 0x00007fff8610d65a _ZZ21WKPageSetPageUIClientEN8UIClient12runOpenPanelEPN6WebKit12WebPageProxyEPNS0_13WebFrameProxyERKN7WebCore18SecurityOriginDataEPN3API19OpenPanelParametersEPNS0_31WebOpenPanelResultListenerProxyE + 100

    38 WebKit 0x00007fff8606b627 _ZN6WebKit12WebPageProxy12runOpenPanelEyRKN7WebCore18SecurityOriginDataERKNS1_19FileChooserSettingsE + 213

    39 WebKit 0x00007fff8607db4f _ZN3IPC13handleMessageIN8Messages12WebPageProxy12RunOpenPanelEN6WebKit12WebPageProxyEMS5_FvyRKN7WebCore18SecurityOriginDataERKNS6_19FileChooserSettingsEEEEvRNS_14MessageDecoderEPT0_T1_ + 101

    40 WebKit 0x00007fff85f3e25d _ZN3IPC18MessageReceiverMap15dispatchMessageERNS_10ConnectionERNS_14MessageDecoderE + 129

    41 WebKit 0x00007fff860bb3dc _ZN6WebKit15WebProcessProxy17didReceiveMessageERN3IPC10ConnectionERNS1_14MessageDecoderE + 24

    42 WebKit 0x00007fff85f0ad05 _ZN3IPC10Connection15dispatchMessageENSt3__110unique_ptrINS_14MessageDecoderENS1_14default_deleteIS3_EEEE + 119

    43 WebKit 0x00007fff85f0d650 _ZN3IPC10Connection18dispatchOneMessageEv + 126

    44 JavaScriptCore 0x00007fff810dbf69 _ZN3WTF7RunLoop11performWorkEv + 169

    45 JavaScriptCore 0x00007fff810dc182 _ZN3WTF7RunLoop11performWorkEPv + 34

    46 CoreFoundation 0x00007fff7e303161 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17

    47 CoreFoundation 0x00007fff7e2e331d __CFRunLoopDoSources0 + 557

    48 CoreFoundation 0x00007fff7e2e2816 __CFRunLoopRun + 934

    49 CoreFoundation 0x00007fff7e2e220d CFRunLoopRunSpecific + 285

    50 HIToolbox 0x00007fff7d8a3bcc RunCurrentEventLoopInMode + 240

    51 HIToolbox 0x00007fff7d8a3a01 ReceiveNextEventCommon + 432

    52 HIToolbox 0x00007fff7d8a3836 _BlockUntilNextEventMatchingListInModeWithFilter + 71

    53 AppKit 0x00007fff7c017a91 _DPSNextEvent + 1093

    54 AppKit 0x00007fff7c721704 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1658

    55 Safari 0x00007fff8de86b44 -[BrowserApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 252

    56 AppKit 0x00007fff7c00c409 -[NSApplication run] + 926

    57 AppKit 0x00007fff7bfd7aea NSApplicationMain + 1237

    58 libdyld.dylib 0x00007fff92657255 start + 1
    --- Post Merged, Jul 11, 2016 ---
    I would post chrome error but it is way too long for MacRumors to process, and i would try to upload it but... you know, i can't.
    I can send it via email though if you require it
     
  2. twanj macrumors member

    twanj

    Joined:
    Sep 10, 2015
    #2
    Can you give us a site & instructions to try to reproduce it on?

    For instance, the Attach File button in GMail works for me on Chrome.
     
  3. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #3
    Uploading to the Dropbox site via Safari works for me on the exact same machine.

    Have you tested in a new user account?
     
  4. twanj macrumors member

    twanj

    Joined:
    Sep 10, 2015
    #4
    The "Upload a File" button on this forum works for me as well using Chrome.
     
  5. DavidEther macrumors newbie

    Joined:
    Aug 26, 2010
    #5
    I'm having the same issue as you. I don't know if it has to do with the fact I previously had Path Finder 7 installed, but uninstalling still hasn't fixed it. Hopefully can find a fix!
     
  6. Dantnad thread starter macrumors newbie

    Dantnad

    Joined:
    Jul 11, 2016
    #6
    I've tried uploading things on Facebook, when clicking the attach file button a window appears with a message that says "an unexpected error Ocurred, will try with a new user, if it doesn't work i'm going to format my SSD and reinstall Sierra from scratch, i believe it is because i initially had Yosemite and then upgraded to "El Capitan" and some time laater installed Sierra. Thing is that if i format the SSD it is going to download the factory OS which is Yosemite... i need to find a way to install Sierra from scratch.

    But first let me try creating a new user. Why don't the macs have a "Factory reset" button. Lol
    --- Post Merged, Jul 11, 2016 ---
    Surprisingly enough creating a new user account solved it (in that user account, in mine i still can't upload files) any idea of how to solve this on my user? or do i have to create a new one and use that one instead?
     
  7. blasto2236, Jul 11, 2016
    Last edited: Jul 12, 2016

    blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #7
    Honestly, the best thing you can do right now in beta software is report the bug. Testing in a new user is a great way to isolate issues, but as far as WHAT in your user account is causing it, that's a bit beyond my level of expertise. The fact that it's in multiple browsers would indicate that its a system file causing you trouble, but then again, user-specific issues are by definition not system wide. Reinstalling macOS is not likely to help here.

    Apple's article on the subject is frustratingly vague:

    https://support.apple.com/en-us/HT204443

    But now that you have it narrowed down to a user-specific issue, it should at least point you in the right direction. You won't be able to get help from Apple support, but keep digging with Google searches. The fact that you're encountering it in beta software does not necessarily mean it's related to the beta. Someone has likely encountered this issue before in a prior version of OS X. Keep digging and I will do the same. I'll report back if I find anything for you. At this point, it's a fun puzzle to solve :)

    Edit: based on the list of things in that linked article, I'd start by clearing history and website data in all of your browsers if you haven't already.
     
  8. tamasmacbudapest macrumors newbie

    Joined:
    Jul 14, 2016
    #8
    --- Post Merged, Jul 14, 2016 ---
    Hello, I have the same problem and I think I found out the origin of the problem.

    Sympoms:
    1. Safari and Opera web browser collapse when I try to attach a file in a web form (or in the GMAIL website while I am writing an e-mail (click on attach icon). I got the same message both browsers (unexpected error). By the way drag&drop works me as well.

    2. On desktop applications (Microsoft Word, Microsoft Outlook, Mail app) the ATTACH, the SAVE AS and the OPEN functions are not working, the BROWSER pop up window is not appearing, so I cannot choose where to save, from where to attach or from where to open a file.

    But in 2 application it worked: Microsoft Excel and Word. But I realized that the browser pop up window (attach, save as, open) has 2 different views. One is a simple view, where you can find dedicated librarys like documents, downloads, desktop, and so on. This window appeared. I tried something in Word, when I clicked on SAVE AS, the simple browse windows appeared and on the top there is a down arrow (if you click on this arrow you will got an EXTENDED VIEW of the browse window). So I clicked on that and WORD collapsed :(. From that time also in Microsoft Word the SAVE AS, OPEN and ATTACH is not working.

    So who said that they have no problem with attaching, try to click on that SMALL ARROW on browsing window and I think it will collapse for them.

    I don't have solution till yet :(.

    Tamás
     
  9. Dantnad thread starter macrumors newbie

    Dantnad

    Joined:
    Jul 11, 2016
    #9
    Hello Tamás, I did find the solution. Se es like if you want to do that you have to creare a new user and upload files from there, Or simple delete the actual one and start using the new one.
    No I can upload files and I have no problem relaté with that but I found that mayor it was a problem relaté with steam as with the one where I have installed CS:GO I can't upload files and in the user where I can upload files I can't play CS:GO
    However the solution is to create a new user.
    -Dantnad
    --- Post Merged, Aug 1, 2016 ---
    *Seems
     
  10. dsjr2006 macrumors regular

    Joined:
    Jun 29, 2007
    Location:
    Metro Detroit
    #10
    People are mentioning getting it to work by creating a new user. Is this a permissions issue?
     
  11. Dantnad thread starter macrumors newbie

    Dantnad

    Joined:
    Jul 11, 2016
    #11
    Nope, seems to be an issue of overwritting something during the install of sierra, for it to work correctly you have to install from scratch. Or creating a new user. Until now it seems to be the only problem, I believe it is a problem with the previous file system as I believe apple changed to a new file system in this OS.
     
  12. dsjr2006 macrumors regular

    Joined:
    Jun 29, 2007
    Location:
    Metro Detroit
    #12
    They are working on a new filesystem which is available as a Beta in Sierra; however, it is not enabled by default and requires you to manually create a new partition so I'm sure that isn't it.

    Your statement does not rule out a permissions issue.
     

Share This Page