Anyone been getting issues with Google Chrome on Sierra?

Discussion in 'macOS Sierra (10.12)' started by Hustler1337, Oct 8, 2016.

  1. Hustler1337 macrumors 68000

    Hustler1337

    Joined:
    Dec 23, 2010
    Location:
    London, UK
    #1
    Hi Guys,

    Ever since updating my Mac to MacOS Sierra, I've been having issues with Google Chrome. Some pages would just display a blank white page whilst others would show a black screen or blocks of black on the page.

    I can't seem to figure out what's wrong and am thinking it could be related to MacOS Sierra, though I'm not entirely sure. Is anyone else having similar problems with Google Chrome or is it just me? Quitting Chrome and then re-opening it seems to temporarily fix the issue until it happens later again.

    If anyone has any possible solutions to the problem, please feel free to suggest. Chrome has been driving me nuts lately and I don't wish to go back to Safari.

    Would appreciate any help.

    Thank you :)
     

    Attached Files:

  2. slvrscoobie macrumors 6502a

    slvrscoobie

    Joined:
    Mar 24, 2013
    Location:
    NJ
    #2
    Yes!!! Had a bunch of trouble with it. Usually closing and reopening seems to fix it.
     
  3. gamemaster.com macrumors newbie

    gamemaster.com

    Joined:
    Dec 11, 2016
    #3
    Yes...I am also having the same "black screen" and "black block" issues, the problem seems to be unique to Google Chrome as Firefox and Safari don't seem to have the same issues. I have also accomplished a clean install of Sierra and downloaded a fresh version of Google Chrome, but the issue is still not fixed. Perhaps it is a graphics card issue as I am also using a 15" 2011 Macbook pro though mine is late a late 2011 model?
     
  4. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #4
    I've had no issues. Try testing in a new User or the Guest User. iMac (Retina 5K, 27-inch, Late 2014)

    CREATE A NEW USER
    Go to System Preferences --> Create a New User in Users & Groups.
    Switch to the New User by logging out under the Apple in the Menu Bar.
    Log into the new User.
    You can skip logging in with an Apple ID. Hit continue then skip.

    Only Apple apps will be in the Dock.

    Do you still see the issue?

    If no, then the problem is in your User's folder.
     
  5. lclev macrumors regular

    lclev

    Joined:
    Jul 29, 2013
    Location:
    Ohio
    #5
    No problems here. I have it installed on a 2011 MB Pro, 2013 MB Air and a 2010 Mac Pro. I only use Google Chrome.
     
  6. matthewhgross1 macrumors newbie

    matthewhgross1

    Joined:
    Sep 27, 2017
    #6
    --- Post Merged, Sep 27, 2017 ---
    Yes, I'm having the exact same problem. Just started after I installed Sierra 10.12.6.
     

Share This Page