App data not restoring

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Robert_H90, Oct 11, 2016.

  1. Robert_H90 macrumors newbie

    Joined:
    Oct 11, 2016
    #1
    Hi,

    I've recently purchased an iPhone 7 and have transferred all my purchases from my iPhone 6 and then backed it up via iTunes. I then plugged in the iPhone 7 and clicked restore from backup. It has restored my contacts, messages, photos and all of my apps however not all of the apps have had their data restored. Only a few have them have not worked and I can't understand why some would have their documents/data but some wouldn't. I have tried the restore from backup several times but get the same result. I can live without a few of them having the data and having to start over but not The Simpsons Tapped Out which when I first open it on my new phone does have all the data but when I close it and then re-open it it's all gone. I really need this to work as I have played on it for a few years, wouldn't be able to get some of the content back due to events being over and have spent some money on it.

    I've never had a problem with restoring from backup so I can't figure out why it isn't working properly now. Any help with this would be greatly appreciated.
     
  2. The Tos macrumors 6502a

    Joined:
    Jan 5, 2011
    Location:
    Buffalo, New York
    #2
    Make sure you are properly signed into Gamecenter and the appstore on the phone. Then force close the apps and relaunch, should prompt you to pick up where you left off.
     

Share This Page