App Store weird behavior

Discussion in 'Mac Apps and Mac App Store' started by cabbageman, Mar 15, 2016.

  1. cabbageman macrumors newbie

    cabbageman

    Joined:
    Oct 18, 2015
    Location:
    Denmark
    #1
    For about 2-3 weeks I have had a rather bizarre issue with the App Store, which seems to be working even more slowly than usual. When the App Store is launched, it would only load and display certain elements, while others will appear only as placeholders (sometimes the titles of the apps will show, sometimes not) or will not appear at all (see the blank spaces in the screenshots).

    [​IMG]

    After leaving it for a minute or so, the rest of the contents finally loads, but if you go to a certain app and then want to go back to the previous page or the home page, you will have to wait again for everything to load. Alternatively, if you click on a placeholder or on the title of something that has not yet loaded, you will not be taken to that app's page, but will be directed to the page of some of the other items on the screen that have already loaded (it's like the App Store can't even recognize where I click).

    [​IMG]

    It isn't a problem with my Internet connection as everything else using the Internet works fine. This is a clean install of Yosemite (10.10.5) that I did after formatting my whole disk, I have not used any "Cleaner" apps and have absolutely no idea what could be causing this. I have tried rebooting OS X and even tried deleting the *.plist file of the App Store, but it didn't help...

    Has anyone had a similar experience or any suggestions about what could be done to fix it?
     
  2. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #2
    In my experience Mac App Store has been problematic regardless of OS version.

    Im not sure why but I suspect it might be Apple server problem because MAS is simply a frond end to the store.

    Unfortunately I haven't been able to find a way to fix it. Its one of the reasons I only use MAS for updates and I don't purchase anything there.
     

Share This Page