Apple Releases Firmware Update 7.7.9 and 7.6.9 for AirPort Base Stations [Updated]

Discussion in 'Mac Blog Discussion' started by MacRumors, Dec 12, 2017.

  1. TTTedP macrumors member

    Joined:
    Nov 27, 2017
    #126
    Default DNS is Google's on those. It seemed there was some pre-caching going on but could've been all in my head. I switched DNS for sure.
     
  2. shiekh macrumors member

    Joined:
    Sep 26, 2006
    #127
    I suspect the battery may need changing; not easy as things are glued shut

    https://www.ifixit.com/Guide/Apple+AirPort+Extreme+Model+A1354+Battery+Replacement/8899
    --- Post Merged, Dec 14, 2017 ---
    MSRP > $1,000
     
  3. richard harris podolsky macrumors newbie

    richard harris podolsky

    Joined:
    Sep 13, 2016
    #128
    My download speed went from 60 to 117mbps and my upload speed from 5 to 11mbps after applying these updates. Anyone else seen speed increases like this?
     
  4. Le Big Mac macrumors 68030

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #129
    Updated four devices with no problems last night - not sure of the generations, but the following:

    Original Time Capsule (flat version)
    Old-style airport express (direct plug)
    Newer airport express (flat version)
    Airport extreme (newest model - tallboy)
     
  5. Mr_Fastbucks macrumors newbie

    Mr_Fastbucks

    Joined:
    Dec 14, 2017
    #130
    Until Apple releases a suitable replacement, people will still keep picking up AirPort Express' on Ebay for $20 just to stream audio through their homes. I don't even turn on the Wi-Fi on the first generation devices. Even though the AirPort Utility has stopped supporting them in recent versions, the audio streaming still works.

    It would be a shame if Apple killed off these devices. Probably the best value in Wi-Fi over the last decade.
     
  6. Euroamerican macrumors member

    Euroamerican

    Joined:
    May 27, 2010
    Location:
    Boise
    #131
    I love mine. I have two Airports deployed at home and two more Expresses deployed at relatives' houses. Reliable and unobtrusive, they almost never generate help calls. My wife also has one deployed at her Mom's house, a later tower-shaped Extreme.

    I got my two updated yesterday with the 7.6.9 security updates, both the Airport Extreme gen 5 and the Express gen 2.

    When I saw one of you mention the availability here on MR, I went into my Airport Utility and saw the red exclamation points next to the routers in the GUI. I then updated one via that utility and used the iOS airport utility on my phone to update the other.

    I am extremely happy and gratified that Apple provided these updates, as I believe we should be getting premium support when we pay for premium devices.

    I will try updating the next two remotely located Airport Express devices via the Windows airport utility via Teamviewer sessions on their Windows PCs.

    Happy Friday!
     
  7. d00d, Dec 16, 2017
    Last edited by a moderator: Dec 16, 2017

    d00d macrumors regular

    Joined:
    Jul 22, 2002
    Location:
    Massachusetts
    #132
    Using their DNS doesn't route all your traffic through their servers. The person you replied to is making an absurd claim. Even if they meant DNS, it's incorrect.
     
  8. cmaier macrumors G4

    Joined:
    Jul 25, 2007
    Location:
    California
    #133
    iPhone camera bump
     
  9. WannaGoMac macrumors 68020

    Joined:
    Feb 11, 2007
    #134
    I understand they were not actually susceptible to the hack...
    --- Post Merged, Dec 17, 2017 ---
    It probably is related to a reboot and getting on a different wifi channel during the autoscan at startup
     
  10. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #135
    How long had it been since the router was last rebooted?

    If it had been up for a year or more since the last update, sometimes things can get slow. I always recommend an occasional reboot of network devices, just to ensure general stability and performance.
     
  11. dpyang macrumors newbie

    Joined:
    Jul 16, 2008
    #136
    Apple wifi fix 7.6.9 (for Airport Extreme). Did Apple break something in the process? Now my devices (two iphones, and one ipad mini) are showing Latency Test Fail when I run Ookla's speedtest.net.
     
  12. jpsmith76 macrumors newbie

    jpsmith76

    Joined:
    Jun 4, 2014
    #137
    4th Gen Time Capsule here. Updated last week to the 7.6.9 firmware and noticed that none of my ports are forwarding correctly anymore.

    Anyone seen similar issues?

    I’ve tried just removing and recreating one, but no change. Don’t really want to do a hard reset and redo 20+ DHCP reservations and 10+ port forwards if I don’t hav to go that route.

    The firmware update is the only change I can think of that may be causing it. Crappy Charter Spectrum has actually been up for a whole week and a half, but I wouldn’t put it past them causing me greif.
     
  13. sloancpa macrumors newbie

    Joined:
    Jan 5, 2018
    #138
    --- Post Merged, Jan 5, 2018 ---
    Ever since this update, I had to re-establish connections to the wireless signal for many of my devices. Additionally, I get occasional messages that the password has changed, when it hasn't and it won't establish a connection even after re-entering the password and finally, the signal just disappears and re-appears for no apparent reason. Anyone else having issues?
     
  14. TTTedP macrumors member

    Joined:
    Nov 27, 2017
    #139
    thanks. I think it was a trust issue with Google and I was *looking* for a problem. I switched it back to Google DNS just to see if anything weird would happen. Baseless. I've been using Google Wifi for a month now and honestly, its been great. Much improved performance. Already sold the Airports.
     
  15. Nosix macrumors newbie

    Joined:
    Sep 14, 2014
    #140
    Yes, I’ve had the same issue on my latest generation Airport Time capsule. I have rolled back the firmware to 7.7.8
     

Share This Page