General Blocking OTA iOS updates via router no longer working on iOS12

Discussion in 'iOS 12' started by vancityguy, Oct 30, 2018.

  1. vancityguy macrumors newbie

    Joined:
    Oct 30, 2018
    #1
    Is it just me, or has anyone else noticed that blocking 'mesu.apple.com' & 'appldnld.apple.com' in your router no longer prevents iOS update nags from Apple?



    I have updated all the household iOS devices to iOS12.0 and get the update nag for iOS12.0.1 & now iOS12.1 despite following all the known tricks to block OTA updates.



    The only device in my home (my work phone) where router-level OTA blocking is effective is still on iOS11x.



    If anyone has a proper work around (such as updated domains/URLs to block in the router), please help this homie out!

    I'm using a Synology router btw.

    TIA
     
  2. Martyimac macrumors 68000

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #2
    Why don't you just turn automatic updates off? Easy Peasy.
     
  3. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #3
    Have you tried using the tvOS beta profile?
    --- Post Merged, Oct 30, 2018 ---
    That doesn't prevent automatic download of updates unfortunately.
     
  4. Martyimac macrumors 68000

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #4
    That may be, but the OP's post said he wanted to stop the updates and nags from occurring. My auto update option is unchecked and I don't get either one.
     
  5. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #5
    "Nag" happens when the update is downloaded but isn't installed. It's basically there to get you to install it, which means that it wouldn't even come up with auto updates as the update would get installed automatically without the need to "nag".
     
  6. Martyimac macrumors 68000

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #6
    I agree, but what I am saying is that I don't get ANY notifications unless I visit software update. If I don't go there, there is no download, therefore, no nags. Does that make sense?
     
  7. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #7
    I understand what you are saying and the experience you have. That isn't the case for some others (who have automatic updates disabled as well).
     
  8. vancityguy thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #8

    That's exactly my problem.

    Auto Updates feature was disabled since the moment I installed iOS12.0.
    I even kept deleting the iOS update file from the iPhone Storage menu after I began getting the nag, but it would just keep downloading it over and over and prompting me to update every morning. Super annoying.

    What I'm trying to get at is, prior to iOS12, I was able to blacklist the URLs listed in the original post on my router and even if I accidentally visited the updates link on my iPhone, it would just throw me a pop up saying "unable to check for updates. Please try later.", or something to that effect. I want to re-enable this block in iOS12.

    Anyone know how?
     
  9. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #9
    Sounds like potentially different servers might be used?

    Also, have you tried the tvOS beta profile menthol?
     
  10. vancityguy thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #10

    Thankfully, this did it for me...phew! I thought this was it for my iPhone 7. lol..

    I actually didn't know about the tvOS beta profile hack until you guys mentioned it. I was relying on blacklisting known apple domains at the router level, and it worked flawlessly until this September's iOS12 upgrade.

    Thanks @C DM. Looks like this method has been known to work for a while, and I'd been living under a rock. *facepalm*

    Works like a charm!

    IMG_6107.jpg
     

Share This Page

9 October 30, 2018