Cannot add eSIM on XS Max - help please

Discussion in 'iOS 12' started by naeemmer, Dec 30, 2018.

  1. naeemmer macrumors newbie

    Joined:
    Dec 30, 2018
    #1
    I have been with Apple Support for countless hours now and have met with the Genius Bar folks 3 times already.

    I originally bought a HK version XS Max (physical dual SIMs). That one stopped working and I got it replaced at the Apple service centre in the UAE. As it was the UAE, they gave me one with an eSIM. However, I do not have the "Add Cellular Plan" option to add the eSIM. After many many hours with all kinds of Apple representatives, it seems the issue is that my profile is setup for a physical dual SIM while the phone I currently have is eSIM enabled. Therefore, I cannot use a dual SIM either way. I am way beyond frustrated at this point as Apple does not have a solution and will not give me a refund because I bought from another retailer.

    Does anyone have a fix to this? Or know anyplace I can escalate to?
     
  2. George Knighton macrumors 65816

    George Knighton

    Joined:
    Oct 13, 2010
    #2
    You mentioned Apple and a profile, so I assume we are talking iCloud.

    Pardon me for suggesting the obvious, please, but did you delete the old iPhone from your profile, and then try to set up your current XS Max as a new device?

    Please excuse me for asking the obvious, but you never know.

    Did Apple Support mention why they could not help with this?

    Who is your provider, and in what country?
     
  3. Gamer-Dad macrumors regular

    Gamer-Dad

    Joined:
    Aug 11, 2018
    Location:
    Pasadena MD USA
    #3
    Why would your Apple profile have anything to do with why you cannot active eSim? Doesn't make sense...
     
  4. George Knighton macrumors 65816

    George Knighton

    Joined:
    Oct 13, 2010
    #4
    You're right.

    The only thing I could think is that he's tried to restore a backup from an A2104 that isn't working properly with his new A1921.

    If that's the case, I hope he is in a position to report it as a bug because that should happen.

    But if that *is* the case, then the next logical (desperate) step is to delete the A2104 from his list of devices for his Apple ID, and then start the A1921 as a new device.
     
  5. naeemmer thread starter macrumors newbie

    Joined:
    Dec 30, 2018
    #5
    --- Post Merged, Dec 31, 2018 ---
    I’ve tried resetting to a new phone multiple times now but it just doesn’t work. Apple has told me to get it in to the store for a hardware check. I will try that in a week to see if it works.
     
  6. Banglazed, Dec 31, 2018
    Last edited: Dec 31, 2018

    Banglazed macrumors demi-god

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #6
    General>About> Tap on the Model number and what does the 5-digit model number? AXXXX?

    Then at the bottom, how many IMEI numbers do you see? If you have dual SIM capable device, for example, US model A1921 will have a physical IMEI number (1st slot)and an eSIM IMEI number (2nd slot). If you only see one IMEI number, you may need to update to iOS 12.1. Is your device up to date and on iOS 12.1.2?

    To activate an eSIM, you must have an active internet connection for the device to verify and add the plan.
     
  7. naeemmer thread starter macrumors newbie

    Joined:
    Dec 30, 2018
    #7
    I have an IMEI number and then a Back SIM IMEI which is for a second physical SIM. This is the problem. The phone I currently have is not capable of a second physical SIM.
     
  8. ZaidButt macrumors newbie

    Joined:
    Jun 5, 2019
    #8

    What happened after you visited apple store?
    I am also facing similar issue. I bought a phone from turkey, I restored it from my iPhone X backup and I can't find "add cellular data" option in mobile data and in about I am getting IMEI for primary and other IMEI for back sim (Same as yours) and I got single sim tray with phone, which means my phone has one nano sim and one esim option but I don't understand how can I add esim when there is no option available.

    I also searched alot about this issue on internet but I couldn't find any information regarding this issue.
     
  9. Bogstandard, Jun 5, 2019
    Last edited: Jun 5, 2019

    Bogstandard macrumors newbie

    Joined:
    Aug 24, 2018
    Location:
    Mid West
    #9
    Switched my primary number to e-sim last week via AT&T (USA).
    After the nano sim gave up its id to the e-sim, things did not work.
    When a second nano sim or phone number was added to the phone, the e-sim worked fine.
    I have a second number in a different device and I wanted to keep it that way, so I used my 2nd number in the e-sim device for an hour and then removed the nano sim and put it back it its home device.
    The primary e-sim phone continues to work fine as the primary number.
    The second number with empty sim card bay simply advises the second number and " no sim installed'.

    Edit...unlocked Xs USA market Ymmv
     
  10. naeemmer thread starter macrumors newbie

    Joined:
    Dec 30, 2018
    #10
    --- Post Merged, Jun 5, 2019 ---
    Apple gave me another new phone. When the phone was activated, I could see the esim option but as soon as I restored my backup, the esim stopped working again. I could not find a solution and have been living with it now.
     
  11. ZaidButt macrumors newbie

    Joined:
    Jun 5, 2019
    #11
    Well your case is different, I think if you factory reset your phone and set up as new iPhone, you will get esim option back.
    Then dont restore your backup from itunes, restore backup from icloud. I am sure you will be able to use both sims (Esim and nano sim).
    The reason why I think this will work is icloud doesn't restore settings, it just restore the data. In your case the problem is you are getting old settings which is making esim unavailable for you, because it was not available in your old phone.

    My case is different, I am not getting add data plan option since I purchased the phone, I tried factory reset but it didn't work. The problem is with my phone.
     

Share This Page

10 December 30, 2018