iPhone Cannot restore iCloud backup

Discussion in 'iOS 9' started by GrumpyTrucker, Mar 25, 2016.

  1. GrumpyTrucker macrumors 6502a

    Joined:
    Jun 1, 2014
    #1
    Hi all.

    Earlier today my iPhone just had a bit of a fit so I did hard restart on it. That was it, it got locked on the Apple logo and would NOT come back to life. I tried to update via iTunes, still the same. So I ended up restoring it. Now I'm trying to restore from my last iCloud backup and the thing just won't have it. The backup is from about 20 hours ago but it either just hangs at "Time remaining: estimating" or I get the error "cannot restore iCloud backup"

    What could cause this error? Corrupted backup (in which case I'm sure the software is clever enough to know this and tell me that's the problem), iCloud server issue (all showing green on the online checker), or something else?

    Any and all ideas please because this is driving me nuts.
     
  2. kerrikins macrumors 65816

    Joined:
    Sep 22, 2012
    #2
    Is there another, slightly older backup showing? I had this issue yesterday and after the second attempt I just restored from the older one and that worked.

    As to why, though, I don't know. :/
     
  3. GrumpyTrucker thread starter macrumors 6502a

    Joined:
    Jun 1, 2014
    #3
    Yeah there are some older backups showing. I went to the next oldest (didn't want to go too far back) but that was doing the same. Eventually, after about 15 tries and over an hour it did finally restore from the original backup. But this is supposed to be a simple process that anyone can do. It drove me round the twist and I'm not exactly a total novice here. No way my Mum for example could have sorted this issue.
     

Share This Page