Can't get MacBook Pro to wake for access

Discussion in 'macOS' started by Schmactor, Jan 13, 2017.

  1. Schmactor macrumors member

    Joined:
    Aug 5, 2014
    #1
    I have an early 2008 MacBook Pro running El Capitan. I am trying to use Back To My Mac to connect to it remotely. It works 100% perfectly if it is already awake. However if it is asleep I cannot seem to connect. I have "Wake for network access" checked in the energy settings. I have my correct Apple ID set up on not only the computer but also on my Airport Extreme. When I open a finder window on the computer I am using it shows my MacBook Pro under the list of shared computers. But clicking on it only returns a "Connection Failed" message. If I have someone at home wake the computer I can then connect immediately so there are no problems with Back To My Mac there is only a problem waking the computer. Any ideas?
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    This Apple KB should explain how to do it: https://support.apple.com/en-ca/HT201960

    Basically, in addition to setting Wake for Internet Access on your Mac, you have to set up Bonjour Sleep Proxy on your Airport Extreme:

    Setting the Bonjour Sleep Proxy on your AirPort Base Station, Time Capsule or Apple TV

    Install the latest software updates for AirPort Base Station with 802.11n (or later including 802.11ac), Time Capsule, or Apple TV (second generation or later) to enable it to act as the Bonjour Sleep Proxy. Once installed, your AirPort Base Station, Time Capsule or Apple TV (when no AirPort base station or Time Capsule is present on the network) will make itself available as a Bonjour Sleep Proxy to other devices on your network with no other configuration necessary. ​
     
  3. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #3
    You may have to update the firmware on your Apple Extreme. Is the light on the front green or yellow? If it is yellow, open the Airport Utility and update the firmware.
     
  4. Schmactor thread starter macrumors member

    Joined:
    Aug 5, 2014
    #4
    It seems that an early 2008 MacBook pro is simply not able to wake wirelessly. Going into sleep mode completely disconnects from wireless so there is no way whatsoever for the airport to contact it. The only solution seems to be to prevent it from sleeping.
     

Share This Page