Can't play my Apple Music library offline on iPod...

Discussion in 'iPod touch' started by SuperFreak, Jan 12, 2016.

  1. SuperFreak macrumors member

    Joined:
    Jul 16, 2012
    #1
    I have a 12GB iPod touch, with a paid Apple Music account, i have download at least 800 tracks on my iPod, loads of albums, i have iCloud Music Library ticked, and i have also properly downloaded the tracks so that i can play them offline (i'm sure it used to say "make available offline"), however i no longer see that option, only the Cloud/Download icon.

    I can see my library on my iPod, but when im not in the house, it says "This song can't be played. To remove all Apple Music songs, disable iCloud Music Library form Music in the Settings app"...

    What has happened? I used to be able to play my songs but, now I cant?

    I've since unticked iCloud Music Library so i imagine all those songs ill have to download onto my iPod again if I can fix this.

    Any help?

    Thanks
     
  2. Prozak0820 macrumors regular

    Prozak0820

    Joined:
    May 14, 2015
    Location:
    Stuttgart, Germany
    #2
    Used to happen to me. Just reconnect to wifi and play one of the downloaded songs. Then turn off wifi. Should work. I'm guessing it has to verify the songs.
     
  3. Lucas Godfrey macrumors 6502

    Lucas Godfrey

    Joined:
    Jul 12, 2010
    Location:
    Somewhere between Here and There
    #3
    Which is totally useless if the user isn't near a wifi point..
     
  4. Prozak0820 macrumors regular

    Prozak0820

    Joined:
    May 14, 2015
    Location:
    Stuttgart, Germany
    #4
    True. But I don't really have that problem. I'm hoping Superfreak doesn't either and that they have access to wifi.
     
  5. Allandwong macrumors newbie

    Joined:
    Mar 12, 2016
    #5
    --- Post Merged, Mar 12, 2016 ---
    I followed steps on making my music available offline from everywhere. No good, I get a pop up with a message "This song can't be played" then below that states To remove all Apple Music Songs, disable iCloud Music Library from Music in the settings app. I definitely don't want to do that. I have gone on Apple.com, I have called support and I even brought it to the Apple Store with no solution. I was told Apple Support would call me back. still waiting.
     
  6. rigormortis, Mar 14, 2016
    Last edited: Mar 14, 2016

    rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #6
    i have apple music. i went and got ' killed by death ' by Motörhead and added it to my music and downloaded it then put my iPhone in airplane mode and rebooted into airplane mode. and this song is still playing. yeah, this is a mystery

    maybe you need to sign out and sign into itunes again


    i like itunes match personally

    i think apple music requires you to click on add to my music and also click on download song so you have to click twice. but guess you already know that
     
  7. Superspeed1234 macrumors newbie

    Joined:
    Nov 23, 2016
    #7
    I had the same issue. I tied quitting the app and opening it again. That didn't work. Let me tell you what fixed it for me. THIS IS HOW TO FIX IT. Shut down the phone/iPad or whatever it is. Then put it in airplane mode. Once you do that go into Apple Music, and listen to an offline song. After that you can turn airplane mode and it should work. I hope it works for you
     

Share This Page