Does anyone know what YC-SoundRecord is?

Discussion in 'macOS Sierra (10.12)' started by Oblivious.Robot, Mar 31, 2017.

  1. Oblivious.Robot, Mar 31, 2017
    Last edited: Mar 31, 2017

    Oblivious.Robot macrumors 6502a

    Oblivious.Robot

    Joined:
    Sep 15, 2014
    #1
    Updated my 2012 Macbook Pro recently to 10.12.4 and today while watching a Youtube video, I noticed an unusual thing while increasing the sound.

    Malwarebyte didn't find anything and I have no idea what that is either, the only two things I recently installed are Chrome and Avast.

    It's 2:30am and am freaking out just a little bit!

    Screen Shot 2017-04-01 at 2.00.52 AM.jpg Screen Shot 2017-04-01 at 2.01.02 AM.jpg Screen Shot 2017-04-01 at 2.29.18 AM.jpg
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    audio spider. download 'easyfind' (free), find the driver, uninstall/delete it. reboot.

    an app i think that records audio playing from the mac. did you install something to do that?
     
  3. Oblivious.Robot thread starter macrumors 6502a

    Oblivious.Robot

    Joined:
    Sep 15, 2014
    #3
    Thank you so much, I tried the app but couldn't find anything on audio spider and yc-sound record search came back only with safari history!

    The weird thing is, I haven't installed anything and am usually very careful!
    But then again, I installed Chrome (needed builtin java) and Avast and I do have Vuze(torrent app) think something got installed on it's own?! It's not showing up on neither Avast nor Malwarebyte
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    check in the main library, in the audio folder. proceed with care, but look in the plugins folder there, the HAL folder.

    when you searched with easyfind, make sure you're searching the entire drive, not just your home folder... try 'soundrecord' or 'audiospider' without spaces.

    but if you don't think it has anything to do with anything you've installed, try running this: https://www.malwarebytes.com/mac/
     
  5. Oblivious.Robot, Mar 31, 2017
    Last edited: Mar 31, 2017

    Oblivious.Robot thread starter macrumors 6502a

    Oblivious.Robot

    Joined:
    Sep 15, 2014
    #5
    I think I have narrowed it down to this - http://macgenius.co/app/Screen-Capture/449543542
    I remember having that stupid app years ago when I was new to Mac.
    But i have no idea how to find it or get rid off it

    1/5
    Version 2.3
    Review by Sethdog
    Not with Mountain Lion - Worked pretty good with Lion but since getting Mountain Lion I can only record 1024 by 768. Also sometimes it just doesnt record at all. To the person who says " easy to used on Mountain Lion ,Good" ( thats their broken english, not mine ) How did you get it to work? I did a screen capture the same day before and after installing Mountain Lion and with the same settings it will barely work. It will not even record unless I change the screen resolution to 1024x768. Also I installed the stupid sound driver and now I can't figure out how to get rid of it. Please help me if you know how to get rid of YC-Soundrecord. I cant delete it. Update its been a couple weeks and still no response from developer about how to remove YC-SoundRecord Update Feb 26 2013 Installed again and still does not work, Still cant remove YC Soundrecord, no help from developer Update developer did respond finally respond, I was able to remove YC sound record. Quicktime is built into OSX and works better for free

    Found helpful by 4 out of 4 people


    Edit -
    View attachment 694414
    As its in core services and some are showing up as com.apple I have no idea what to remove without breaking Mac
    --- Post Merged, Mar 31, 2017 ---
    I'm a bit more calm now as it doesn't appear to be something more sinister, and just some leftover driver which suddenly got activated or something from ages ago.

    Apart from a fresh install now, I don't really know how to get rid off it

    View attachment 694415 View attachment 694416 View attachment 694417
    --- Post Merged, Mar 31, 2017 ---
    Nothing in library/audio/plugin/hal
     
  6. Oblivious.Robot thread starter macrumors 6502a

    Oblivious.Robot

    Joined:
    Sep 15, 2014
    #6
    Mods end thread. Found and fixed the problem.

    @fisherking Thanks for the help buddy, I really appreciate it! :)

    For in case anyone suffers from it in the future, it's just a audio driver with a rather scary name making one panic into thinking of malware.

    Found it in library/system/extension
    Deleted and then restarted
    Fixed :D
     

Share This Page