Driver error when installing Windows 10 through Bootcamp on MBP

Discussion in 'Windows, Linux & Others on the Mac' started by Lieutenant_Carter, Jan 3, 2017.

  1. Lieutenant_Carter macrumors newbie

    Lieutenant_Carter

    Joined:
    Jan 3, 2017
    #1
    Hey! First of all, these forums have been an awesome help for me while trying to get Windows 10 up and running on my MacBook. Unfortunately, I've run into yet another error, this time one that I haven't found a solution for via various forums yet.

    I'm trying to set up Windows 10 on my MacBook Pro (13-inch, mid-2012, running macOS Sierra 10.12.2), using Boot Camp Assistant. I've successfully formatted a USB Drive (SanDisk Ultra Fit 3.0 Flash Drive, 128 GB), and copied the Windows 10 ISO Image and support software to the USB, using Boot Camp. I got through the next step too, partitioning the internal hard drive (allocating 395 GB for the Mac OS and 105 GB for Windows). Then Boot Camp restarted my Mac automatically to install Windows.

    I got to the part of the Windows install where it reads "Install now" (right after the language selection screen), and clicked on that, then got the "Setup is starting" message. A few seconds later I got a message reading "A required CD/DVD drive device is missing. if you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now. Note: If the Windows installation media is in the CD/DVD drive, you can safely remove it for this step." I closed the pop-up and tried to rescan for the USB drive, and took the USB out of the port entirely then reinserted it, but I keep getting the message "No device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK." I tried one other suggested fix: copying the "Bootcamp" and "$WinPEDriver$" folders from the USB drive to the BootCamp/Windows partition, and then trying to run the install again, but no dice. Help?
     
  2. Johbremat macrumors regular

    Joined:
    Feb 8, 2011
    #2
    I think I had a similar problem with my Early 2011 MBPs. I came to believe that because of the SuperDrive you were obliged to use a DVD for installation (as a result of running through three different USB sticks and never getting a result).

    And using dd via Terminal wasn't enough to get a suitable bootable ISO working.

    I ended up using the USB/DVD Tool on an existing W10 machine to burn the DVD, and then went through the motions.

    Worked a treat.
     
  3. Lieutenant_Carter thread starter macrumors newbie

    Lieutenant_Carter

    Joined:
    Jan 3, 2017
  4. cybersmarty macrumors newbie

    Joined:
    Saturday
    #4
    Lieutenant_Carter, did you find an alternative solution other than burning a DVD? I have exactly the same problem, and went the same path as you did. Curious whether you found a solution later on. Please let me know.
     

Share This Page