El Capitan WiFi Problem

Discussion in 'Mac Basics and Help' started by lastr, Jul 16, 2016.

  1. lastr macrumors newbie


    Jul 16, 2016
    Screen Shot 2016-07-15 at 14.26.06.png
    Hey guys, I'm having a very annoying problem right now. As you can see in the pic I attached, the wifi is shown connected, but no available wifi list. Of course, the service is not available, but well, not exactly. If no internet connection, the browsers will tell so. But in this problem, the browsers still try to connect, but stay about 10% of the progress bar. I cannot turn the wifi on/off. It stuck like that. It's not actually happening directly after the laptop is started, but it's happening after a while (sometime when the laptop's started it's happening, too). For now I'm solving this problem by restarting the laptop, but I can't do this forever. Have been trying the el capitan wifi problem's solutions, but no luck. Deleting and adding the service too. I hope there's an answer for this. Thanks.
  2. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    1. Reset NVRAM / PRAMM.

    2. Turn off wireless. Go into the application /Applications/Utilities/Keychain Access and find the entry for your non-working setting and delete it. Then turn your Airport card back on and rejoin your wireless network.

    3. Open System preferences->Network pane, Advanced button and click on the 'Renew DHCP Lease' and see if you get all the network settings, including the 'DNS' mini-tab. If you get no DNS settings use either OpenDNS or Google Public DNS and put those IPS in the DNS mini-tab.

    4. Staying in the System Preferences->Network pane, at the top of that pane is the 'Location' pull-down. Use that to select 'EditLocations …' and in the pop-out click on the + symbol to add a new custom named Location (calling it what you like) and then saving that in the pop-out, Network main page. Don't worry because it will act the same as 'Automatic', you just giving it a custom name. Then Use the System Preferences->Network pane, Airport card to rejoin your wireless network.

    5. Turn off the wireless card. Then open Finder window and go to the folder /Library/Preferences/SystemConfiguration/ and move the files com.apple.airport.preferences.plist & NetworkInterfaces.plist to your desktop. Then IMMEDIATELY REBOOT!!!

    This reboot will rebuild fresh Preferences in that folder. Upon the reboot go back into System Preferences->Network page and male sure all you networking devices are put back in. If any are missing network port you can use the + button, in the Network System Preferences pane, and add the port back into your Macs Network setup. Then from that pane select you Airport card and from there use that Network pane to rejoin your wireless network. Lastly if everything is working, throw out those files you moved to the desktop out.

    6. In your wireless router go back to System Preferences->Network pane and click on the 'Advanced' button, Hardware ini-tab and set your MTU settings back down from 1500 to 1453. Some older wireless routers seem not to be able to do Jumbo frames (the 1500 MTU settings). It is hit or miss in the hint.

    7. Reset your wireless router. If you never been in your wireless router, get the default router password visit the web site Router passwords.com to get the default username/password. This way you can reset your wireless router.

Share This Page