Final Cut Pro X always asks for a library

Discussion in 'Mac Apps and Mac App Store' started by thinhpham, Jan 23, 2017.

  1. thinhpham macrumors newbie

    Joined:
    Jul 27, 2014
    #1
    Every time I open FCP X, it always asks me to locate a library. I know this would happen if I launch FCP X with the Option key held down, but I don't. I have tried to trash FCP X preferences, even reinstall the program but nothing helped.

    Screen Shot 2017-01-23 at 2.41.01 PM.png

    Does anyone have the same problem or know how to fix?

    Thanks,
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    If you just click 'New Library' and create a new library, does the issue persist when you next close & reopen?

    If so, you can try a complete uninstall by dragging FCPX from the Applications folder into AppCleaner, remove all files, restart computer, and download/install again: https://freemacsoft.net/downloads/AppCleaner_3.4.zip
     
  3. thinhpham thread starter macrumors newbie

    Joined:
    Jul 27, 2014
    #3
    I tried creating new library, did not help. I also tried uninstalling it, did not help. Indeed, this issue has been following me from my old laptop to the new one, and I still have no ideas what caused it.
     

Share This Page