Help fix with my 2011 MBP not working after reinstalling MacOS X.

Discussion in 'MacBook Pro' started by MacbookPro2011_GPUfailed, Mar 12, 2019.

  1. MacbookPro2011_GPUfailed macrumors newbie

    Joined:
    Mar 10, 2019
    #1
    2011 MBP AMD GPU died.
    Found this page and tried the steps but couldn’t fix it. Followed the codings on there but don’t know what I’m doing really. But I figured out along the many tries that if I go to single-user mode and enter the code below it would put my MBP into Integrated Graphics instead of the AMD Radeon after I reboot it.

    nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

    So after many different tries I some how got it to the internet recovery mode and reinstalled the MacOS X. I let it do it’s thing overnight and went to bed. Woke up and the MBP turned off, I turned it back on and it goes into the black screen/white letters mode and then gray screen of death. Waited 1 hour, still nothing, I manually powered it off and turned it back on. Now back to using the failed GPU, so I reboot, single user, entered the coding, reboot, and now using integrated graphics. I rebooted while hitting the shift to get into safe mode and when it’s like 95% loading bar it freaking rebooted by itself! I have been trying to fix this for 3 days to no avail. Please help....
     
  2. emccready macrumors newbie

    emccready

    Joined:
    May 12, 2019
    Location:
    India at the moment
    #2
    ----------

    Try not rebooting in Safe mode...maybe that reverts things back to the old settings? Not sure. I have problems with my cursor disappearing which freezes things. Two times however the cursor worked for several hours. I shut down using the command in the tool bar black apple Shut Down...and the next day it was back to same bad mode. So I re did the commands:

    1 - Boot Single User (press Command + S) at boot (If you have MacOS installed on your hard drive).

    Enter these commands (change gpu-power-prefs to Intel GPU and boot verbose):

    Code:
    nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

    nvram boot-args="-v"

    reboot

    and things worked fine again..... except for the cursor which is not a related issue. If I can get the cursor working again, I will only shut down MANUALLY pressing the power button because only then does it boot up properly. I did that last night and this morning this are booting up okay....

    just my cursor disappears and freezes things after about 3 minutes. Just rebooted and opened the Calendar to update it and just moving my finger on the track pad...not even clicking... the cursor just disappears and of course everything freezes. But that is my problem.

    Maybe reloading the OS was a mistake too but I don't know about these things.
    Good luck.
    Maybe someone else know the issue... go back to the site where you got the above fix and repost as well.
     

Share This Page

1 March 12, 2019