High CPU temperature when idle (with screensaver)

Discussion in 'Mac Basics and Help' started by roksraka, Aug 24, 2016.

  1. roksraka macrumors member

    Joined:
    Dec 9, 2012
    Location:
    Slovenia
    #1
    Hello!
    For a while now, whenever I turned on the screensaver and left my desk for half an hour, I'd come back to see my CPU temperature rise to 80ºC and my fans spinning at a substantial speed. When I wake it up again and unlock the computer, it quickly cools down and is nice and quiet again. I did look at the activity monitor immediately after waking up the computer, and there were no problematic processes going on. This problem occurs even if I have almost no background applications open - only Safari, Mail, Messages...

    I'm using a late 2013 15" rMBP (2.0Ghz i7, 16GB...) with an external monitor and running the latest El Capitan 10.11.6. I even cleaned the fans about a month ago...

    Is anybody experiencing similar problems?
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Have you tried resetting PRAM & SMC?
     
  3. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #3
    I've seen the same thing with other users who were using an external monitor. Try removing your external monitor as a test, activate the screensaver, and wait. If the fans don't rev up and the machine stays cool, you'll know the cause is because you're using an external monitor and it's loading down the GPU. And by all means try resetting the PRAM and SMC as has been recommended.
     
  4. roksraka thread starter macrumors member

    Joined:
    Dec 9, 2012
    Location:
    Slovenia
    #4
    I'll give that a try...but it might be the GPU, or lack-there-of. It only has the Iris Pro. :(
     
  5. supermariofan25 macrumors regular

    supermariofan25

    Joined:
    Feb 7, 2011
    #5
    That will do it, I have the 13" model of the same year, from what I know screen savers are Open GL based and causes the Iris GPU/CPU to get hot and ramp the fans up, but only when I have upped the resolution from 1280*800 HiDPI to 1650*1050 HiDPI. Thats not very well optimized for something that runs when your computer is supposed to be using low power i.e idle. Unless you really want the screen saver, best you can do is disable the screen saver and just have the screen turn off instead, or try using a different one.
     
  6. roksraka thread starter macrumors member

    Joined:
    Dec 9, 2012
    Location:
    Slovenia
    #6
    Thanks for your insight :) I might just turn it off then...
     
  7. Garrod macrumors regular

    Garrod

    Joined:
    Nov 13, 2008
    Location:
    UK
    #7
    Screen savers = obsolete and waste of energy. Just set it so the screen switches off when idle. It is probably cheaper to buy a budget toaster and throw it through the air.
     
  8. hobowankenobi macrumors regular

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #8
    Amen!

    Save power, eliminate heat, save everything.......just disable screen saver, and sleep the monitor. Done.
     

Share This Page