Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Skevaboy

macrumors member
Original poster
Dec 14, 2011
54
6
Toronto
HomePods can now be set as default audio output through Apple TV I thought , however I have updated to tvOS 14.2 & HomePodOS 14.2 and dont see this option as per a TVOS 14.2 beta user.

anyone see it?

0czbpf73yws51-2.jpg
 

MontTrain

macrumors member
Sep 10, 2012
39
26
I have the same problem. I did turn off the beta updates a while ago and there was a version update when I checked this morning on the release track but it didn’t make any difference. Maybe need to reset it or something
 
Last edited:

mallbritton

macrumors 6502a
Nov 26, 2006
940
254
You've got the feature, right there, to select your HomePods as the default audio out. Are you saying you don't see your HomePods as an option when you select it? Are your Apple TV and HomePods on the same subnet?
 

Skevaboy

macrumors member
Original poster
Dec 14, 2011
54
6
Toronto
You've got the feature, right there, to select your HomePods as the default audio out. Are you saying you don't see your HomePods as an option when you select it? Are your Apple TV and HomePods on the same subnet?
the screenshot is not from my Apple TV its a photo I pulled from a article I read.
 

MontTrain

macrumors member
Sep 10, 2012
39
26
You've got the feature, right there, to select your HomePods as the default audio out. Are you saying you don't see your HomePods as an option when you select it? Are your Apple TV and HomePods on the same subnet?
That’s correct - you select that option and the only thing listed is the tv speakers and not my stereo HomePods.

You can manually select them from the airplay menu as always but not set as default.
 

mallbritton

macrumors 6502a
Nov 26, 2006
940
254
The 14.2 updates were only released today. Are you sure you've updated the ATV and the HomePods to the latest release?
 

MontTrain

macrumors member
Sep 10, 2012
39
26
Yip all have the latest and greatest software
I’ve been going through the main thread about this and the fix for me was that my Apple TV and HomePods weren’t in the same Room location. Go to the Home app on your iPhone and check. To change it long press the devices and click the cog setting. Once I moved them together it prompted me to set them up as home theatre default.
 
Last edited:
  • Like
Reactions: undies1993

undies1993

macrumors 6502a
Mar 10, 2011
842
6
Ann Arbor, Michigan
I’ve been going through the main thread about this and the fix for me was that my Apple TV and HomePods weren’t in the same Room location. Go to the Home app on your iPhone and check. To change it long press the devices and click the cog setting. Once I moved them together it prompted me to set them up as home theatre default.
Thank you! That did it for me!
 

TonyC28

macrumors 68020
Aug 15, 2009
2,411
6,247
USA
Are you guys seeing any issues with wifi when audio is set to default to HomePods? In another thread some people were seeing a big drop in their wifi when HomePod was selected as the default audio source.
 

dom_a2345

macrumors newbie
Sep 14, 2015
24
3
London
Has anyone managed to fix this i wonder if it is because I have apple TV HD rather than 4K’s, no matter what i do what rooms i put the the homepod and Apple TV in I am not able to get the default audio option to show
 

mallbritton

macrumors 6502a
Nov 26, 2006
940
254
Has anyone managed to fix this i wonder if it is because I have apple TV HD rather than 4K’s, no matter what i do what rooms i put the the homepod and Apple TV in I am not able to get the default audio option to show

The feature is not supported on the Apple TV HD model. Only the Apple TV 4k.
 

mallbritton

macrumors 6502a
Nov 26, 2006
940
254
You can choose the HomePods via the Control Center. Press/Hold the Home button, scroll down to the AirPlay icon, select it and choose your speakers.
 

dom_a2345

macrumors newbie
Sep 14, 2015
24
3
London
You can choose the HomePods via the Control Center. Press/Hold the Home button, scroll down to the AirPlay icon, select it and choose your speakers.
I know I can do that, but the fact remains I didn’t used to have do that before upgrading to 14.2, the functionality has gone backwards.
 

dom_a2345

macrumors newbie
Sep 14, 2015
24
3
London
What do you mean? There was no way to set HomePods as default audio in tvOS prior to 14.2.
There was because i used it, it just wasn’t called default audio. It was Settings > Audio > ‘Audio Output’. This option allows you to select the homepod as the output option and most of the time the setting remained. Now in 14.2 this setting has been removed and for the 4K’s they have added the default audio option but there is now nothing on the HD model.
 

mallbritton

macrumors 6502a
Nov 26, 2006
940
254
Ah, yes. But that was not a persistent setting. If you used the HomePod for something else, like playing music via AirPlay from your iPhone, you had to reset it.
 

B/D

macrumors 65816
Mar 30, 2016
1,224
893
There was because i used it, it just wasn’t called default audio. It was Settings > Audio > ‘Audio Output’. This option allows you to select the homepod as the output option and most of the time the setting remained. Now in 14.2 this setting has been removed and for the 4K’s they have added the default audio option but there is now nothing on the HD model.

It isn´t the same thing.


This method didn´t routed ALL ATV audio (like menu sounds and clicks), to the homepods, only from certain apps. The new "default output" setting does, including video games and IPTV apps.
 

dom_a2345

macrumors newbie
Sep 14, 2015
24
3
London
It isn´t the same thing.


This method didn´t routed ALL ATV audio (like menu sounds and clicks), to the homepods, only from certain apps. The new "default output" setting does, including video games and IPTV apps.
Whether you agree with the finer details is really neither here nor there. With the 14.2 upgrade there has still been a down grade of functionality to the 4th gen HD only models, as they have removed the 'Audio Output' option and there is nothing to replace it.
The 'audio output' method although not perfect was better than the option we have now of connecting to airplay everytime we want to use the apple tv, which my 4yr old cannot manage on her own, (which incidentally also does not include system clicks and I never had any issues with the old method with IPTV, I use channels and iPlayTV)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.