How to correct an autocorrect?

Discussion in 'Mac Basics and Help' started by IslandOwl, Jan 8, 2016.

  1. IslandOwl macrumors newbie

    Joined:
    May 10, 2011
    #1
    For some reason in some unknown place Autofill has memorized VASHON so every single time I try to type Vashon my Mac, iPhone, and iPad all "correct" it to VASHON.

    Can someone tell me the Master Location for this "learned behavior" so I can go in and delete it?

    The autofill is happening everywhere - in Contacts, in email, etc.

    Ps. Vashon is an island in Puget Sound just south / southwest of Seattle.

    TIA
     
  2. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #3
    Text substitutions can be fixed in System Preferences -> Keyboard -> Text. If it's doing a spelling substitution (why??? but maybe that's the problem) that would imply that VASHON is somehow considered in the dictionary but Vashon is not. In that case you can add Vashon by selecting it and then doing "Learn Spelling" from the context menu. I noticed that Vashon is not in my dictionary -- I expect that if I had accidentally done a Learn Spelling on VASHON I'd get what you are seeing. In that case I'd remove VASHON from the text file ~/Libary/Spelling/LocalDictionary.
     
  3. 960design macrumors 68000

    Joined:
    Apr 17, 2012
    Location:
    Destin, FL
    #4
    I have predictive text and spell autocorrection turned off on my iPad. Definitions are still turned on, as I use them occasionally.
     

Share This Page