How to delete\undo auto-imported bookmarks from Chrome into Safari?

Discussion in 'Mac Basics and Help' started by LordAdam5, Nov 21, 2016.

  1. LordAdam5 macrumors newbie

    Joined:
    Nov 21, 2016
    #1
    So I signed in to Chrome on my Mac and set it as my default browser (since Safari on Sierra takes literally ten seconds to even begin loading a page, and Firefox doesn't support Google Sheets). Now Safari and my iPhone have had everything I've ever bookmarked in Chrome dumped into their bookmarks. I was never asked permission and I absolutely did not want to do this.

    Safari did have a bar at the bottom that said "This includes your imported bookmarks from Chrome. [Keep] [Don't keep]." So I very very carefully pressed "Don't keep". But nothing changed. I still have hundreds of old bookmarks from five years ago that I do NOT want.

    I am pissed that Apple and Google both think it's okay to merge my bookmarks without asking me. My Safari bookmarks are now in such a mess of old useless Chrome ones they're useless. And why do they have a "Don't keep" button that does literally nothing?

    Please please PLEASE tell me there's some way to go back to just having my Safari bookmarks and delete all these Chrome ones from iCloud. I never asked for them and I specifically clicked "Don't keep". I can't do it manually, it's merged hundreds and hundreds from each browser. And it's merged my very personal and unprofessional Chrome bookmarks with my Safari ones which are almost exclusively for work.

    Also, more to the point, how can I sign in to Chrome and make it my default browser in the future without it messing up my iCloud bookmarks? I want them all separate.

    I'm on Sierra 10.12.1 on a 2015 MacBook Pro.

    Thanks in advance.
    --- Post Merged, Nov 21, 2016 ---
    Alright I think I was able to sort of recover by manually picking out the important ones (thank god I used folders) and deleting everything else. I probably lost a few but oh well.

    Now what I need is a way to set Chrome as my default browser in the future without this happening again. I don't ever want any syncing. No history, no bookmarks, nothing. I want Chrome and Safari separate. Anyone know?
     
  2. Zazoh macrumors 6502a

    Zazoh

    Joined:
    Jan 4, 2009
    Location:
    Mico, Texas
    #2
    Click Apple | System Preferences | General

    Just below the center of the page is the setting for default browser.

    As far as importing bookmarks that is normally a manual action, not sure how that happened.
     
  3. LordAdam5 thread starter macrumors newbie

    Joined:
    Nov 21, 2016
    #3

    Yeah it's pretty easy to set a default browser. Not really sure how my question came across as "how do I set the default browser".

    Yeah, importing bookmarks SHOULD be manual, but it isn't, it's automatic, and as far as I can see there's no way to even prevent it manually. There's a "Don't keep" button, but it keeps them whether you press it or not.
     
  4. davDC5 macrumors newbie

    Joined:
    Dec 24, 2010
    #4
    Just happened to me. I specifically clicked on "Don't Keep" and it still auto imported. Any fix?
     

Share This Page