How To: Enable AirPrint on Windows (32/64Bit) with iOS 5+ Support

Discussion in 'iOS 5 and earlier' started by JasonHD, Dec 19, 2011.

  1. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #76
    iOs 5.1: Wow !

    dlist,

    thanks for sharing this ! I tried it on my iPad and iPhone and effectively it asks for an account and password :eek:. I was so accustomed seeing the lock, it didn't cross my mind trying.
     
  2. Benson11 macrumors regular

    Benson11

    Joined:
    Mar 18, 2012
    #77
    Thanks for your helpful post..It works great with your instructions..
     
  3. kblack macrumors newbie

    Joined:
    Sep 6, 2011
    #78
    I have a PDF printer shared on my PC (lots of people do), and discovered the folder where the PDF's go once you use the airprint-enabled PDF printer. This is also where your .ppd files are located.
    C:\Windows\Temp\cupslite
    For me, being able to print to PDF and have the files stored on my PC is a huge deal.

    Thanks to OP for getting airprint back to us office-bound PC users.
     
  4. giepoe macrumors newbie

    Joined:
    Mar 29, 2012
  5. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #80
    iPhone and iPad act differently

    Hi,

    for some reasons, when I print from the iPhone, I am asked to provide an account and password (a valid Windows account) before I can print. But when printing from the iPad, no question asked. It prints right away.

    Why is there is there a difference between the two devices, is it a parameter somewhere on the iPad or iPhone ?

    Thanks
     
  6. mlindblad macrumors newbie

    Joined:
    Mar 30, 2012
    #81
    AirPrint for Windows

    Jason,
    I followed your instructions and got no errors on the installation or the reg program or the installation program. I am running Windows Vista 64bit and ran the matching reg program.
    Shared my printer. Restarted my laptop and I still can't get my printer to appear on my Iphone 4s running OS 5.1. AirPrint.exe is running in the proccesses (Task Manager) and Bonjour is running under the services tab.

    Any help would be appreciated.

    Thanks,
    Mike
     
  7. mlindblad macrumors newbie

    Joined:
    Mar 30, 2012
    #82
    RE: AirPrint

    Jason,
    I spoke too soon. after I restarted my laptop my printers finally appeared on
    my Iphone. I just had to deal with the locked situation and followed your
    instructions and now I can print!

    Thanks for your post with the instructions.

    Mike
     
  8. tony710 macrumors member

    Joined:
    Jul 4, 2007
    Location:
    Columbus, OH
    #83
    I've set up the printer and Windows like the post suggested. I can see the printer in iOS with no lock and can choose print. Only thing is now I can't print at all. I can't even print from Windows anymore. I keep getting the message that the printer is offline (I've checked and can print fine from my MacBook). Anyone have any ideas?
     
  9. HowardMM macrumors newbie

    Joined:
    Apr 5, 2012
    #84
    Thankyou

    As a long time Windows (7) user having recently extended our household technology with Ipods /Iphones /Ipad (all on IOS 5.1) I am most grateful for this advice. It worked 'out of the box' as they say and we are able to use our existing wireless Epson Stylus Office TX610FW from all our devices. Many thanks.
     
  10. howardf macrumors newbie

    Joined:
    Apr 7, 2012
    #85
    Still no joy

    I've been trying to get AirPrint for Windows 7 (64b) running with your very complete instructions but still have not been successful. The Airport for Windows service is running as is Bonjour, but I don't show any printer available on my iPhone 3GS with iOS 5.01. I've also installed the 64b patch. What have I missed?
     
  11. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #86
    Still no joy

    Howardf,

    I run Windows 7 64bit and it works. The printer needs to be shared on the computer where AirPrint runs. I have experienced in the past that when the printer was Off, it wouldn't show. But that's not happening anymore. As far as I understand, some printers may not work with AirPrint.

    Hum, iOS 5.01 :confused: can you install iOS 5.1 ? I had issues until I installed that version.

    Hope you will find out.
     
  12. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #87
    Resolve the latter first. If you can't print from Windows then you won't be able to print from IOS using this solution.
     
  13. howardf macrumors newbie

    Joined:
    Apr 7, 2012
    #88
    Thanks planteg,
    Printer is shared and on. It's an HP Photosmart C4780. It doesn't have built-in Airport support, but I thought that's what Airport for Windows was for.

    As for iOS 5.01, my iPhone is jail-broken and unlocked so that I can use it in Mexico, where I live and the US when I visit from time to time. Last time I checked v5.1 wasn't ready for my kind of situation.
     
  14. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #89
    howardf,

    my printer is an Epson CX-6600 dating back 2005, also not supported by AirPrint. I found out AirPrint for Windows is kind of finicky. I hope some one will provide you a hint.
     
  15. howardf macrumors newbie

    Joined:
    Apr 7, 2012
    #90
    planteg,
    I actually got AirPrint to run for a short while today, but it is again not working. I had it running after I reset my router, but I'm not going to do that every time I want to run AirPrint. There's got to be a better way. Thanks for hanging in there with me.
    Howard
     
  16. Pavr27 macrumors newbie

    Joined:
    Apr 11, 2012
    #91
    This is a great fix to AirPrinting! Thanks!

    However I'm not quite there yet!

    I use a Canon MP970 printer attached to my network via Ethernet, and accessed using Canon network tool.

    I can see my printer on an iOS5 device when it is attached to my Windows 7 PC via USB, but not when it is only networked.

    I am wandering whether this will be possible (as I can't really have the printer attached to the PC via USB.)

    I have checked that the network printer is shared, and although the sharing box is ticked, its greyed out (I suspect this is just because I can't change the sharing status, but that it is still shared)

    Any ideas?

    Thanks!
     
  17. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #92
    Pavr27,

    whether your printer is connected via Ethernet or USB does not matter to AirPrint for Windows. The question is who 'owns' the printer, in other words where will the print queue be managed ? If you have a print server in a router for example, then the printer owner is the router. If the printer is attached to a computer, then that computer owns the printer.

    The rule for AirPrint for Windows is that the printer has to be shared on the computer running AirPrint. If the printer is connected to that computer, fine. If the printer is connected to your router, but there is no print server in there, then each computer owns the printer because each computer spools the print jobs. The all you have to do is share that printer on the computer where AirPrint runs.
     
  18. Pavr27 macrumors newbie

    Joined:
    Apr 11, 2012
    #93
    Thanks for the quick reply. I think I am going to have to continue fiddling blindly then, because according to windows, the printer is shared, and this is the PC that AirPrint service is running on.

    (and just to clarify, the printer is managed by the laptop rather than by the router)

    Maybe I can try reinstalling it on the network
     
  19. Pavr27 macrumors newbie

    Joined:
    Apr 11, 2012
    #94
    Update on the above.

    I can now successfully use Airprint on my networked printer...only on another laptop.
    So my problem above is PC specific.

    This leads me to suspect that the laptop I'm actually trying to get it to work on (my server) is causing me issues because of user permissions. As previously stated, the printer properties tab shows that the printer is shared, but all options (including the shared 'tick' are greyed out) and my ios devices just can't see the printer.

    This isn't the first time Windows 7 permissions are causing me a headache...so I'll have to continue fiddling!
     
  20. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #95
    Pavr27,

    when you share a printer in Widows, permissions are set so that everybody can use the printer, but they can't change the default settings, only the settings for their own print job. I think this is why you have grayed out fields. Ordinary users may print but not change (manage) the printer.
     
  21. Pavr27 macrumors newbie

    Joined:
    Apr 11, 2012
    #96
    Yeah, and I checked the permission on the printer...and 'Everyone' has 'print' permission - so not sure what the problem is. Anyway, I'll start from scratch when I get a chance :)
     
  22. class77 macrumors 6502a

    class77

    Joined:
    Nov 16, 2010
    #97
    Just buy Printopia for $9.95 and save yourself of problems. It goes on your Mac and as long as your iPhone/iPad is on the same network as the Mac, it works flawlessly
     
  23. Pavr27 macrumors newbie

    Joined:
    Apr 11, 2012
    #98
    I don't have a mac! Hence I'm reading a thread specifically for windows ;)

    And it appears to be $20, not $10
     
  24. Pavr27 macrumors newbie

    Joined:
    Apr 11, 2012
    #99
    Hoorah! All working now following re-installation of networked printer! Thanks for this bit of software :)
     
  25. Raxs macrumors newbie

    Joined:
    Apr 16, 2012
    #100
    Hmmm. Having a little trouble here still.

    The printer's a networked one, and airprint's running on my Windows 7 media pc. I've testing printing from it directly and that works just fine.

    I've installed the latest Airprint version along with the registry patch and the guest account and I can see the printer just fine on my iPhone, but when I try to print from notes or whatever, it goes to the 'connecting to the printer' screen for a few minutes, when back to the notes app. But nothing comes out of the printer or enters the print queue on the PC as far as I can see.

    I've tried reinstalling the printer on the PC but no dice. Any ideas?

    R.
     

Share This Page