Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

deehappy

macrumors newbie
Original poster
Jan 24, 2020
3
0
Hi everyone

I have a 27'' iMac - late 2013 currently running:
- Intel Core i5 4570 3.2 GHz
- 16 GB DDR3
- 1 TB HDD (I can't remember if it's 5400 or 7200 rpm)

Due to slowness I've recently attempted to boot from an external SSD (Samsung T5) using USB 3.0 rather than running off the slow hard drive. I've followed some instructions to duplicate my data to the SSD. And it booted fine to the new drive and things seem to be running quicker.

Here's the problem: I ran Black Magic to test speeds before and after. Before the change I was getting read and write speeds of approximately 140 MB/s. After the change I'm getting around 38-40 MB/s. I checked and confirmed that the USB is running off the USB 3.0 bus and in the System Report, it says the drive max speed should be 480 MB/s.

I've tried running the TRIM command that other posts have suggested but that didn't appear to have a significant impact.

Any suggestions??

Thanks!
 

chrfr

macrumors G4
Jul 11, 2009
11,027
4,588
If you're seeing the maximum speed is 480, that's megabits not megabytes, so your drive is connected as a USB 2.0 device rather than USB 3.0, so the slow speed is about right for USB 2.0.
A device connected as USB 3.0 would show that it's connected at 5Gb/sec (that's gigabits) and then the speed would be substantially faster. Do you have the SSD connected directly to your computer?
Trim cannot be used on USB connected SSDs on Macs, so it would have no effect at all in this case.
 
Comment

deehappy

macrumors newbie
Original poster
Jan 24, 2020
3
0
Oh good point about the USB 2.0 and megabits value.

I was able to figure it out. I unplugged all usb devices - someone on another thread said that if the bus reads a 2.0 device first it affects the rest of the ports. I also reset the PRAM/NVRAM.

Thanks for your help!

Before:
Before.png



After:
After.png
 
Last edited:
Comment

nambuccaheadsau

macrumors 68000
Oct 19, 2007
1,938
478
Nambucca Heads Australia
Check your Hub is actually a USB3 hub. If it is an older USB2 it will still run at lower speed.

Might be best to upgrade to a USB3 hub. I use a USB3 hub for an exzternal SSD an external Thunderbolt SSD. Whilst they perform at very similar speeds on SuperDuper doing backups, the USB3 SSD is considerably slower at booting than the Thunderbolt.
 
Comment

Fishrrman

macrumors Core
Feb 20, 2009
21,698
7,904
Do you (did you) have the t5 connected through a hub?
If so, DISCONNECT it from the hub.
Plug it DIRECTLY into a USB3 port on the back of the Mac.
Reboot and try BlackMagic again.
Does anything change?

In other words... DON'T "boot through a hub"...
 
Comment

deehappy

macrumors newbie
Original poster
Jan 24, 2020
3
0
I had it plugged directly into one of the ports on the iMac in all scenarios (I don't have an external hub or anything)...but seems like the steps I took above have now resolved the issue.
 
Comment

ondert

macrumors 6502a
Aug 11, 2017
567
860
Italy
I had the same issue last night and saw your post suggests doing PRAM reset and it worked! Thanks

The problem happened again after a reboot. PRAM didn't solve it this time.


Well, after another SMC and PRAM reset it turned to 5Gb/s again.
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.