iPhone 3.0 BETA 2 - MMS officially works!

Discussion in 'iPhone' started by OriginalMasta, Mar 31, 2009.

  1. OriginalMasta macrumors member

    Joined:
    Mar 18, 2009
    #1
    What a suprise. Decided to try it <again> - this time MMS works! I come from 2.2.1 -> 3.0b2.

    I can send MMS/Receive MMS without any errors nor did I have to modify any carrier .plists!

    Update:

    In USA, AT&T 3G , with iPhone 3G, firmware 3.0b2 - 2.2.1 upgrade to 3.0b2 with complete backup restored.

    No settings changed, nothing on my end I did to make it work. I just sent a message (MMS) and it worked! I can receive and send to multiple AT&T people AND TMobile accts as well!


    UPDATE: VIDEO MMS WORKS!!

    At least I can RECEIVE IT - this was shot via SonyEricsson W800i video mode and sent from TMobile to my 3G iPhone.

    iPhone is now the ultimate phone! =)


    [​IMG]

    I've already tested text/mms/audio/and now video works 100% as it should with mms. If only the iPhone can send videos...
     
  2. Drumjim85 macrumors 68030

    Drumjim85

    Joined:
    Oct 7, 2007
    Location:
    DFW, TX
    #2
    on what carrier in what country?
     
  3. =MuLti-CeLL= macrumors 6502a

    =MuLti-CeLL=

    Joined:
    Jan 14, 2009
    Location:
    m0biLe
    #3
    Awesome! Now take a video and try and send...oh wait...
     
  4. OriginalMasta thread starter macrumors member

    Joined:
    Mar 18, 2009
    #4
    SEnt from USA/AT&T 3G to other AT&T 3G and regular non-iphone users - all work! Sent from AT&T 3G to Tmobile and works as well!
     
  5. =MuLti-CeLL= macrumors 6502a

    =MuLti-CeLL=

    Joined:
    Jan 14, 2009
    Location:
    m0biLe
    #5
    That's so cool! I mean we all know it's coming and all and it's probably gonna work just fine, but, ya know, still cool. ;)
     
  6. OriginalMasta thread starter macrumors member

    Joined:
    Mar 18, 2009
    #6
    I know you meant to come across as a real prick - but you should also note the media quality/size is also governed by the network not the phone. So what if you have a video when the network such as AT&T sucks and cannot provide anything larger than QCIF video sizes.
     
  7. llj1137075 macrumors member

    Joined:
    Mar 20, 2009
    #7
    Anybody else get theirs working?
    Still red! here.
     
  8. lisheran macrumors member

    Joined:
    Nov 4, 2007
    #8
    mine worked in the first beta and now it doesn't
     
  9. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
  10. tiguk macrumors 6502

    Joined:
    Jun 12, 2008
    Location:
    UK
    #10
    You can keep hoping I think.

    Didn't they say it wasn't going to be available for first gen?
     
  11. zapbryann macrumors newbie

    zapbryann

    Joined:
    Mar 26, 2009
  12. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #12
    Yes they did, but they also didn't give iPod touch users Mail, Notes, Stocks, Weather and Maps at first. They also didn't provide an "add" button in Calendar at first (in the iPod touch). I think it's subject to change. Since when do you *need* 3G to send and receive MMS messages?
     
  13. Digipimp macrumors regular

    Joined:
    Jun 17, 2003
    Location:
    Texas
    #13
    yeah mine didnt work in the first beta and doesnt work in this one either. does it maybe only work on 3g and not edge?
     
  14. The General macrumors 601

    Joined:
    Jul 7, 2006
    #14
    No worky for me. But, on my other IPCC that enables tethering, visual voice mail is now working.

    Could someone post their "working on ATT" IPCC so I can try it?
     
  15. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #15
    I can confirm that MMS is not enabled for SoftBank users in Japan. Naturally.
     
  16. lisheran macrumors member

    Joined:
    Nov 4, 2007
    #16
    i got it on 3g but not on edge. I put my sister on my dev account so i have her phone to test things on too and hers works via edge.
     
  17. OriginalMasta thread starter macrumors member

    Joined:
    Mar 18, 2009
    #17
    The MMS features are enabled ONLY FOR iPhone 3G only. If you have a 1G iPhone, it won't work for you.
     
  18. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #18
    I don't understand why you can send and receive MMS messages over EDGE on a 3G iPhone but, you can't on an original iPhone over EDGE... something's weird about their claim.
     
  19. OriginalMasta thread starter macrumors member

    Joined:
    Mar 18, 2009
    #19
    There's no reason NOT to be able to send via EDGE. It's just faster GPRS anyway - but I don't make the software and I know this is capped off specifically so that there will be an incentive to go iPhone 3G.

    They are ridding all 1st gen iPhone's in favor of the 3G and upcoming hardware revisions.
     
  20. LinMac macrumors 65816

    Joined:
    Oct 28, 2007
    #20
    What had you done prior to updating to 3.0b2 to try to enable MMS?
     
  21. RxMac macrumors 6502

    Joined:
    Sep 11, 2008
    #21
    No picture, so it didn't happen....
     
  22. hazelgreene macrumors newbie

    hazelgreene

    Joined:
    Mar 31, 2009
    #22
    my mms was working but now its not. i did not do anything other than update to beta 2. I didnt do anything to the beta 1 either. I got photos and videos for a bit but now cant send photos and I assume that I cant get videos currently either. I am on a 3G.
     
  23. OriginalMasta thread starter macrumors member

    Joined:
    Mar 18, 2009
    #23
    The first 3.0Beta 1, I could not send any mms. Everything had a red !. So I decided it was just too buggy to use since I really wanted mms and couldn't use it, I forgo the new sdk api's in favor of 2.2.1. I downgraded and left it at that.

    When 3.0b2 was released today, I decided to give it another shot. When I option clicked the "restore" button, and selected the new fw, it installed and after restoring my 2.2.1 backup data, I tried to send an mms.

    It worked. I can send to TMobile users and vice versa. AT&T 3G numbers I had worked as well.

    As of 6.44pm PST, I can still send AND RECEIVE MMS.

    PS - you can always try to send to yourself....it works because I tried to send an audio recording and I can receive it. Love it so far!
     
  24. solidus430 macrumors newbie

    Joined:
    Mar 31, 2009
    Location:
    PDX
    #24
    Here's the important question nobody is asking yet. Did you have to make any changes to your messaging plan with AT&T to enable MMS, or did it start working all on its own? Also it'd be good to know what messaging package you have (e.g. is it the iPhone Text plan or is it a Family Messaging plan?)

    If you were just working with the standard iPhone Text plan, about how long after the software update would you say it took for MMS to cooperate?
     
  25. phoenixdude24 macrumors member

    Joined:
    Mar 19, 2009
    #25
    alright lets see, first off i'm on AT&T in the US running beta 2 of OS 3.0
    -sent message to LG Shine, received it in under 15 seconds and got back another equally as fast.
    -sent message to iphone 3g running beta 1 of os 3.0, got the old website login link with username and password.
    -sent message to iphone 3g (different one) running beta 2 of os 3.0, received nothing yet
    -sent message to BB Curve on T-Mobile, working perfectly like the Shine.

    nothing worked with the first beta for me and i made no account changes, but i have the $30 unlimited family texting plan
     

Share This Page