iPhone 4S... update to 5.01?

Discussion in 'Jailbreaks and iOS Hacks' started by jarrodtb, Dec 27, 2011.

  1. jarrodtb macrumors member

    Joined:
    Oct 29, 2007
    #1
    I have a 4S ive been holding out on updating from 5.0 to 5.01. I will be interested in unlocking the phone once the JB is out.

    Since a JB has been released for A4 devices on 5.01, does it make sense to stay on 5.0 on a 4S still? Im woried about 5.02 being released and losing the signing window for 5.01, but also about potentially losing an unlock by updating past 5.0 before the JB.

    Thanks for any advice...
     
  2. Baggy Spandex macrumors 6502

    Baggy Spandex

    Joined:
    May 23, 2009
    #2
    I asked MN, pod2G and DevTeam on twitter but (understandably) didn't get a response. My guess would be that it's okay, but I get worried about committing to anything in the JB world as far as firmware.
     
  3. la79 macrumors regular

    la79

    Joined:
    Dec 27, 2011
    #3
    I would not. Be patient. You may end up updating and Pod2g and Musclenerd may end up coming out with a jailbreak which works only on 5.0.

    There is no harm in waiting. Unless you really need to for instance if you are one of the people who are really having battery problems.

    Patience.

    I have a feeling the jailbreak may be out before the end of the year. I don't think Pod2g and Musclenerd would have released without already having a jailbreak for the Iphone 4s/Ipad 2. Why? Well because Apple will more than likely close the jailbreak with iOS 5.0.2 and 5.1. All the work they would have accomplished would go be going down the drain.

    I think they are putting the finishing touches.
     
  4. jarrodtb thread starter macrumors member

    Joined:
    Oct 29, 2007
    #4
    thanks for the replies.

    i have no problem waiting to update, and get why waiting is important... but i got nervous that a release of 5.02 or even 5.1 would close the signing window for 5.01. If a JB were to be released only for 5.01, I'd be out of luck at that point.

    I would suppose that a JB that worked for 5.01 should work for 5.0, too?
     
  5. Baggy Spandex macrumors 6502

    Baggy Spandex

    Joined:
    May 23, 2009
    #5
    Precisely my concern as well.
     
  6. ACardAttack macrumors 6502

    ACardAttack

    Joined:
    Mar 18, 2010
    #6
    Well the A4 jailbreak doesnt work on 5.0 if I've read correctly, also pod2g said this earlier on his twitter
    "BTW: A4/A5 users, don't update to 5.0.2 when it's out, that would cut your jailbreak possibilities."
     
  7. rick snagwell macrumors 68040

    rick snagwell

    Joined:
    Feb 12, 2011
    Location:
    oceanside, ca
    #7
    pod2g and MN have said its ok to update to 5.0.1

    matter of fact, they urge you to do it asap before a new ios release.
     
  8. jarrodtb thread starter macrumors member

    Joined:
    Oct 29, 2007
    #8
    I must have missed this... I had only seen MN warn unlockers not to update to 5.01... but that was immediately after the 5.01 release.
     
  9. la79 macrumors regular

    la79

    Joined:
    Dec 27, 2011
    #9
    Yeah, I didn't know about this either. Going to update today!
     
  10. rick snagwell macrumors 68040

    rick snagwell

    Joined:
    Feb 12, 2011
    Location:
    oceanside, ca
    #10
    pod2g has been testing all his stuff on 5.0.1, as well as MN now.
     
  11. Baggy Spandex macrumors 6502

    Baggy Spandex

    Joined:
    May 23, 2009
    #11
    Not to doubt you, but do you have links to them stating this? I've been trying to find some solid info.
     
  12. Stormy05 macrumors member

    Joined:
    Oct 23, 2011
    #12
    Is there a way to preserve my baseband while updating my 4s to 5.01
     
  13. nfl46 macrumors 603

    Joined:
    Oct 5, 2008
    #13
    BTW: A4/A5 users, don't update to 5.0.2 when it's out, that would cut your jailbreak possibilities -- pod2g

    That means that it is okay to upgrade to 5.0.1. :)
     
  14. Baggy Spandex macrumors 6502

    Baggy Spandex

    Joined:
    May 23, 2009
    #14
    Honestly, it hints that's what he means, but then when it doesn't mean that I have nobody to be mad at. hehe
     
  15. nfl46 macrumors 603

    Joined:
    Oct 5, 2008
    #15
    Lol! 5.0.1 should be fine. I'm going to upgrade to it later on today. I hope it improves my battery life, lol.

    If they didn't want us on 5.0.1, then I believe he would have said, "A5 users, don't update to 5.0.1, that would cut your jailbreak possibilities."

    He's probably laughing at people for asking him over and over on Twitter, when most people just need to put 2 and 2 together.
     
  16. solo118 macrumors 65816

    Joined:
    May 16, 2011
    #16
    Is it possible to download & install 5.0.1 at a later date even if a 5.0.2 is released? I have done this with previous jailbroken devices (for example I jumped from an early 4.0 to 4.3.3 on my ip4) but never tried this on a non-jailbroken device.

    Just curious because I am also with a 4S on 5.0, I would hate to update and then pod2g says here ya go guys an untether for 5.0 only!!
     
  17. kmvguy83 macrumors member

    Joined:
    Oct 25, 2010
    #17
    impossible, once 5.0.2 is released, officially apple will stop signing 5.0.1
    I'm on the same boat, still on 5.0 dont know if i should update to 5.0.1 or not
     
  18. solo118 macrumors 65816

    Joined:
    May 16, 2011
    #18
    You know what I will just update to 5.0.1 when I get home. I know Apple will be hot to release a "fix" and nobody has mentioned in the past week or so that 5.0.1 can not be JBed on A5 devices.

    I guess I have been procastinating for no reason!
     
  19. lostboyz macrumors member

    lostboyz

    Joined:
    Aug 9, 2010
    Location:
    Singapore
    #19
    i guess it should be ok to update. Since the untethered jb for a4 is 5.01.. the dev like MN and pod2g, they knew majority is on the latest patch 5.01, and i think most of the 4S guys are on 5.01... so it make no sense for them to used an exploit for the 5.0 which is the minority..

    BUT this is just the jb.. MN did mentioned about 5.0 unlock..
     
  20. CTBC macrumors member

    Joined:
    Apr 3, 2011
    #20
    I would stay on 5.0.

    1). When 5.0.2/5.1 is released, the signing window for 5.0.1 will be open for several hours at least (it has been for every other release). Meaning you can upgrade to 5.0.1 if you have got the firmware downloaded. So download the firmware now so you can save time. Also, apple usually release updates in the afternoon/evening, so it should be easy to update.

    2). When the jailbreak is released, a program will likely be released allowing A5 devices to downgrade/upgrade to firmwares with SHSH and APTickets saved. This is because the process required a public exploit for the A5. So save your SHSHs with Tiny Umbrella or equivalent.
     
  21. solo118 macrumors 65816

    Joined:
    May 16, 2011
    #21
    Yes UNLOCK is a different story, but I rather have a JB than an unlock.

    edit: plus I have at&t so maybe this still works as an unlock trick
    http://gizmodo.com/5860647/unconfir...method-found-no-software-or-hardware-required
     
  22. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
    #22
    There was a small BB update on 5.0.1 to fix a "no sim installed" error, so I'm guessing (hoping) that the small change on the original BB had no effect on MN unlock. I mean apple can't patch up a hole that they don't know exist yet.
     
  23. Stormy05 macrumors member

    Joined:
    Oct 23, 2011
    #23
    just did an OTA update to 5.0.1 and it gave me build 9A405. I did notice that apple has build 9A406 out. What is the differance between the two? I have downloaded 9A406 on my pc should I force itunes to install it?
     
  24. Quazimojo macrumors regular

    Quazimojo

    Joined:
    Apr 4, 2010
    Location:
    Auburn Hills,Mi
    #24
    I believe that 9A406 was to address the no sim card issue on the 4s, so i guess if you are not having that issue then don't worry about it.
     
  25. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #25
    You're talking about saving SHSH's AFTER the jailbreak is released? I was under the impression that those of us with the 4S couldn't save SHSH's yet. Have I missed something? Is there something those of us with a 4S need to do NOW so we can revert later, or will those tools (hopefully) be coming with the jailbreak?
     

Share This Page