iPhone 7 Signal Problems with Three UK Home Signal Box

Discussion in 'iPhone Tips, Help and Troubleshooting' started by RobTuck, Sep 19, 2016.

  1. RobTuck macrumors regular

    Joined:
    Sep 19, 2006
    Location:
    UK
    #1
    We have a Home Signal Box/Femtocell in our house provided by Three/3 UK, which we've been using due to poor coverage since we moved house. It has worked perfectly with two iPhone 6's, a 5S and a 5C. My partners iPhone 7 is constantly suffering signal dropouts, however. My 6 is working fine, so it doesn't seem to be an iOS 10 issue.

    I asked Three on Twitter, and they weren't aware of any known issues, but another twitter user jumped on my conversation having the same problem, so I'm wondering if it is more widespread. Anyone else experiencing issues, and if so, have you managed to resolve it?
     
  2. PineappleSorbet macrumors member

    Joined:
    Sep 9, 2016
    Location:
    Worcestershire, U.K.
    #2
    If you've a new SIM card in the iPhone 7, you need to call the dedicated Home Signal team and get the new SIM ID added to the box.
     
  3. RobTuck thread starter macrumors regular

    Joined:
    Sep 19, 2006
    Location:
    UK
    #3
    Thanks, but its the same SIM that worked before. The only difference is the iPhone. It does connect to the Home Signal Box, but it just drops off randomly.
     
  4. jkozlow3 macrumors 6502a

    Joined:
    Jul 16, 2008
    #5
    I have Verizon here in the US and our (2) iPhone 7 phones won't reliably connect to the LTE Network Extender. I assume that's what you mean by "home signal box"?

    I also never had any issue with our iPhone 6S phones connecting to the extender. Always 5 bars. However, the iPhone 7 phones seem to prefer the Verizon cell/macro tower instead and rarely connect to the extender now.
     

Share This Page