goddamnitjesuschrist

macrumors newbie
Original poster
Nov 16, 2017
2
0
Recently purchased iPhone 10 and it isn’t reading my text messages while I have headphones on unless I take it out of my pocket and look at it to unlock. Is anyone else having this issue? Is it an easy fix? I’d like for Siri to read my messages while my phone is in my pocket and not having to look at it.
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
51,388
19,448
How are you trying to have the messages read to you? And what exactly happens when you do that?
 

goddamnitjesuschrist

macrumors newbie
Original poster
Nov 16, 2017
2
0
How are you trying to have the messages read to you? And what exactly happens when you do that?
On my previous iPhone 6, I would have my headphones in whilst listening to music. And if there’s an incoming message, all I’ll do is hold down the control button on the headphones and Siri will read the text message without me having to take the phone out from my pocket. Now with the new iPhone 10, Siri won’t read my text messages unless I take it out of my pocket and unlock it with facial recognition. Is there any way around this?
 

DeepIn2U

macrumors G3
May 30, 2002
9,308
3,742
Toronto, Ontario, Canada
On my previous iPhone 6, I would have my headphones in whilst listening to music. And if there’s an incoming message, all I’ll do is hold down the control button on the headphones and Siri will read the text message without me having to take the phone out from my pocket. Now with the new iPhone 10, Siri won’t read my text messages unless I take it out of my pocket and unlock it with facial recognition. Is there any way around this?

I think is is due to having a passcode on your iPhone. Siri , for me at least, never executed any command on iPhone 4-6S and now currently on iPhone 7 unless my phone was unlocked.

In iOS 11 :
Settings, Siri & Search:
Allow when locked,
Scroll down and look for Messages. Enable this and try.
 

symmetric

macrumors newbie
Nov 5, 2011
2
0
Recently purchased iPhone 10 and it isn’t reading my text messages while I have headphones on unless I take it out of my pocket and look at it to unlock. Is anyone else having this issue? Is it an easy fix? I’d like for Siri to read my messages while my phone is in my pocket and not having to look at it.
This worked for me (from another forum): Settings / Notifications / Messages / Show Previews /Always
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.