iPhone XS iPhone Xs- Can't find add esim option

Discussion in 'iPhone' started by ZaidButt, Jun 5, 2019.

  1. ZaidButt macrumors newbie

    Joined:
    Jun 5, 2019
    #1
    Hello,

    I bought a iPhone Xs from Turkey, Which means I should get dual sim (one nano and one esim). When I am trying to add esim I cant find "add cellular plan" option in mobile data, In about there are two IMEI, one is primary and second is back sim IMEI. Also I got single sim tray with my phone which means it cant be two nano sim phone. Can someone help me in this issue? is there anyone who faced the same issue?
     
  2. akash.nu macrumors 604

    akash.nu

    Joined:
    May 26, 2016
    #2
    If you have the 2 IMEIs then it’s able to support dual sim. The 2 physical sim tray is only available in China.

    I suggest you reset the phone and setup as new. Then give it a go again.
     
  3. ZaidButt thread starter macrumors newbie

    Joined:
    Jun 5, 2019
    #3

    I tried that, nothing happened. Still not getting “Add cellular plan” option.
     
  4. Lyn2012 macrumors 6502

    Joined:
    Dec 26, 2007
    #4
    On my UK purchased XS Max I only get the option to Add Data Plan so I’m assuming that it’s just a UK/US language thing - Cellular in US and Data rest of world. I am using using 2 Sims, one physical the other eSim, and both work correctly.
     
  5. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #5
    The carrier needs to support esim too.

    I'm in Canada and only two of the big three carriers support esim.
     

Share This Page

4 June 5, 2019