iTunes 11.4 not working properly

Discussion in 'macOS' started by sfphoto, Jan 14, 2017.

  1. sfphoto macrumors regular

    Joined:
    Jun 10, 2010
    #1
    One of our older MacBooks running Snow Leopard we upgraded from iTunes 10.5 to 11.4

    Devices sync fine and backup / transfer etc. - we can sign in to the store but get nothing but a blank screen. Trying the different tabs - all blank screen.

    Checked firewall (tried turning off too)
    Checked authorization (says authorized) plus off then on
    Ran Disk Utility & Disk Warrior
    Tried re-installing 11.4

    Tried deleting 11.4 and re-installing 10.5, would not install (says failed). Read in another thread someone else had the same problem of not being able to go back to an older version after 11.4 install.

    Any thoughts from those here would be appreciated!

    (Devices can access the store fine as did iTunes 10.5)
     
  2. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #2
    Apple tied iTunes to Safari with cookies, clearing the Safari cookie cache often solves the issue; it's been a while since I've used SL and you didn't allude to whether you restored from a backup or not during your install process. A second solution is execute the iTunes Preferences > Advanced tab > "Reset iTunes Store cache" > and click the Reset cache button. A third solution is to reset your internet router - the router may just need a port or two unblocked.
     
  3. sfphoto thread starter macrumors regular

    Joined:
    Jun 10, 2010
    #3
    Thanks for the cache suggestion(s) & router re-set. Sadly none worked.
    Installation of 11.4 was done from an image file I downloaded from Apple.

    Oddly from the Store menu at the top of iTunes I can view my account info but as mentioned in OP clicking on any of the tabs like 'Books' brings up a blank page.

    iTunes.app show as 'allowed' in firewall settings.
     
  4. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #4
    I run a company. I keep notes. I loved SL, still my favorite OS but need newer support for some of the apps I need…

    From my old notes, 11.4 and 10.6.8 had issues. 11.3.1 was stable as a rock embedded in a steel-reinforced concrete slab, 11.4 had issues and IMHO was a setup for what was to come in Lion.

    A System Extension (/System/Library/Extensions/AppleUSBEthernetHost.kext) did not get updated when iTunes is updated to 11.4 from 11.3.1. The "Modified Date" of that Extension was "May 28 2009"; this issue was discussed at length on the Apple Discussions forums portal. Moved this file to your Desktop and then re-install iTunes 11.4. The modified date on that Extension in question should now read "Jul 28 2014", or a newer date if Apple's updated it or addressed the installation bug. I never figured out why the older Extension did not get updated, only surmising at the time that it was a permissions issue…

    I'll credit others on the Apple Discussions forums, but was able to confirm it at the time on my personal iMac.
     
  5. sfphoto, Jan 18, 2017
    Last edited: Jan 19, 2017

    sfphoto thread starter macrumors regular

    Joined:
    Jun 10, 2010
    #5
    Thanks for the system extension tip. However 11.4 did load a new version (July 2014).

    I deleted 11.4 and installed 11.3 (which installed the same extension but from Jan 2014).

    Still no store access. Oddly I can select 'View Account' from the pull down store menu and it brings up my info - after waiting for the download.

    Wondering if I have some iTunes preference turned off that is needed?

    Just tried 11.1 - same issue. I can access my account, view 'Purchased' but when I select any of the tabs like 'Apps' there is a blank screen. Can sync devices fine.

    v11.4 must have installed something in the system or re-set some needed preference?
     
  6. sfphoto thread starter macrumors regular

    Joined:
    Jun 10, 2010
    #6
    That was it. SL installs Safari 5.05 - I downloaded 5.1 and iTunes now works (11.3). Thanks!
     

Share This Page