Linux on Mac Pro 4,1 -> 5,1 12 cores

Discussion in 'Mac Pro' started by thomasthegps, Jun 16, 2018.

  1. thomasthegps macrumors regular

    Joined:
    Sep 23, 2015
    Location:
    France
    #1
    When I boot linux on my Mac Pro 12 core 4.1 -> 5.1 FW update, I get an MCE error. It doesn't prevent the mac from booting but can someone boot linux on an upgraded 4.1 and tell me if they get a similar issue ?
    Thanks
     
  2. AidenShaw, Jun 16, 2018
    Last edited: Jun 16, 2018

    AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #2
    Which of the dozens of distributions of Linux, and which version?
     
  3. thomasthegps, Jun 16, 2018
    Last edited: Jun 16, 2018

    thomasthegps thread starter macrumors regular

    Joined:
    Sep 23, 2015
    Location:
    France
    #3
    Hi, try archlinux if you can. Just download the latest version, I've tried many different distribution and they all give me the same error. Archlinux boots by default in verbose mode, so seeing the error is a lot easier.
     
  4. theone29 macrumors member

    theone29

    Joined:
    May 6, 2013
  5. stayupforever909 macrumors newbie

    stayupforever909

    Joined:
    Apr 21, 2019
    Location:
    Stockholm
    #5
    What boot ROM are you running? What PCI cards do you have installed? Have you tried disconnecting all non essential USB devices?
     
  6. crjackson2134, May 6, 2019
    Last edited: May 6, 2019

    crjackson2134 macrumors 601

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #6
    X86 CPUs report errors detected by the CPU as machine check events (MCEs). These can be data corruption detected in the CPU caches, in main memory by an integrated memory controller, data transfer errors on the front side bus or CPU interconnect or other internal errors. Possible causes can be cosmic radiation (solar flair), unstable power supplies, cooling problems, broken hardware, running systems out of specification, or bad luck.

    Most errors can be corrected by the CPU by internal error correction mechanisms. Uncorrected errors cause machine check exceptions which may kill processes or panic the machine. A small number of corrected errors is usually not a cause for worry, but a large number can indicate future failure.

    When a corrected or recovered error happens the x86 kernel writes a record describing the MCE into a internal ring buffer available through the /dev/mcelog device. mcelog retrieves errors from /dev/mcelog, decodes them into a human readable format and prints them on the standard output or optionally into the system log.

    I’m not sure what distro you have installed at the present time. You may need to open your package manager and install mcelog. Taking a wild guess here, but if we presume you have Debian derivative, open a terminal session, and type
    Code:
    sudo apt-get install mcelog
    to start the install.

    Use the man page and get familiar with using the installed package to assist in your investigation.

    It might be more helpful to post your problem in a Linux help Forum for your distro, rather than here. This thread should have probably been started in the Linux subform at the very least.
     

Share This Page

5 June 16, 2018