Lockscreen Privacy

Wowereit

macrumors 6502a
Original poster
Feb 1, 2016
893
1,339
Germany
Hello,

I'm experiencing a weird problem.
My iPhone 7 on iOS 10.3.1 refuses to accept my settings for lockscreen privacy.
All sliders in the Touch ID & code menu for accessing things like direct reply, home kit etc. from locked phone are disabled, but I'm still able to see every message including text, call back and even direct reply to messages.

Some apps allow to control this behavior inside of their own settings, but some don't and I'm wondering why the universal kill switch isn't working.

I would appreciate any ideas on fixing this issue.
 
Last edited:

willmtaylor

macrumors G4
Oct 31, 2009
10,190
7,721
Here(-ish)
Hello,

I'm experiencing a weird problem.
My iPhone 7 on iOS 10.3.1 refuses to accept my settings for lockscreen privacy.
All sliders in the Touch ID & code menu for accessing things like direct reply, home kit etc. from locked phone are disabled, but I'm still able to see every message including text, call back and even direct reply to messages.

Some apps allow to control this behavior inside of their own settings, but some don't and I'm wondering why the universal kill switch isn't working.

I would appreciate any ideas on fixing this issue.
Settings>Notifications
  • Make sure apps DO NOT have the "Show On Lock Screen" toggled on.
 

Wowereit

macrumors 6502a
Original poster
Feb 1, 2016
893
1,339
Germany
Settings>Notifications
  • Make sure apps DO NOT have the "Show On Lock Screen" toggled on.
Thanks, but I want to see notifications, I just don't want people to be able to reply directly or view the actual text.
The text problem can be addressed by most app's internal settings.
iOS still provides reply features even when text is blocked, so just some generic *NAME* sent you a message notification shows up. Reply is unchecked in Touch ID & Passcode menu, why isn't this killing reply functionality?
 

willmtaylor

macrumors G4
Oct 31, 2009
10,190
7,721
Here(-ish)
Thanks, but I want to see notifications, I just don't want people to be able to reply directly or view the actual text.
The text problem can be addressed by most app's internal settings.
iOS still provides reply features even when text is blocked, so just some generic *NAME* sent you a message notification shows up. Reply is unchecked in Touch ID & Passcode menu, why isn't this killing reply functionality?
Have you tried restarting your phone after making this change?
 
  • Like
Reactions: Wowereit

EM2013

macrumors 68000
Sep 2, 2013
1,740
1,365
Do you have 'rest finger to open' unchecked in general -> accessibility -> home button
That's how I have mine. It says name sent you a message but as soon as I put my finger it'll show the message and allows me to reply because the phone is 'unlocked.'
If someone else were to use your phone they can't see or reply to the message as it requires your fingerprint.
 

Chazzle

macrumors 68000
Jul 17, 2015
1,910
1,838
Hello,

I'm experiencing a weird problem.
My iPhone 7 on iOS 10.3.1 refuses to accept my settings for lockscreen privacy.
All sliders in the Touch ID & code menu for accessing things like direct reply, home kit etc. from locked phone are disabled, but I'm still able to see every message including text, call back and even direct reply to messages.

Some apps allow to control this behavior inside of their own settings, but some don't and I'm wondering why the universal kill switch isn't working.

I would appreciate any ideas on fixing this issue.
You're just in the wrong part of Settings. You'll have to navigate to Notifications and then for each app that you don't want the full text to show (Messages, Mail, etc) choose "When Unlocked" for the "Show Previews" setting. See screenshot. That should do it :D
 

Attachments

Wowereit

macrumors 6502a
Original poster
Feb 1, 2016
893
1,339
Germany
Have you tried restarting your phone after making this change?
Yes, I did.

Do you have 'rest finger to open' unchecked in general -> accessibility -> home button
That's how I have mine. It says name sent you a message but as soon as I put my finger it'll show the message and allows me to reply because the phone is 'unlocked.'
If someone else were to use your phone they can't see or reply to the message as it requires your fingerprint.
I've unchecked this box as well, doesn't seem to be the solution.

You're just in the wrong part of Settings. You'll have to navigate to Notifications and then for each app that you don't want the full text to show (Messages, Mail, etc) choose "When Unlocked" for the "Show Previews" setting. See screenshot. That should do it :D
That's EXACTLY what I'm looking for. Sadly these options aren't available for 3rd party apps and only for some of Apple's own apps.