Resolved Mac Pro 1,1 Firmware upgrade issues

Discussion in 'Mac Pro' started by ColEpsi, Mar 25, 2019.

  1. ColEpsi macrumors newbie

    Joined:
    Feb 16, 2019
    #1
    Hello,

    I recently acquired an old Mac Pro 1,1 and have been trying to update it to version 2,1 in order to facilitate better processors, but after trying nearly everything I can think of I am still unable to perform the update.

    As I have done so much it will be neater if I post it in bullets:
    • Firstly I tried performing the update using the Firmware Upgrade Tool provided on Netkas. The Mac Pro was running 10.6.8 with the supplied hard drive in bay 1, ATI Radeon 2600xt and 2GB of stock RAM. The tool made the RAMDisk successfully and prompted a shutdown and firmware upgrade procedure. The initial steps of the upgrade went well, but upon getting to the update screen with the progress bar for a split second the machine just restarts and boots into the OS.
    • Next I tried with 10.7.5, performed SMC an PRAM reset but now I got stuck at the RAMDisk creation with Error 5530 while downloading the needed content. I also tried downloading the EFI 2,1 from the Apple website and mounting it alongside, but the outcome was the same.
    • With both operating systems I also tried switching the RAM configuration, even changing both RAM trays with the ones from a different Mac that has successfully performed the update. I also tried switching the optical drive and graphics card for a HD4870 that were also used in the other system and worked well.
    • I tried inserting a different Apple HD with 10.9.5 and got past the Error 5530 but got stuck in the same spot as with 10.6.8.
    • Finally I tried doing an ASD test that came up with no issues. I also tried restoring the firmware with the Firmware restoration CD 1,4 but could not get the machine to start reading from the CD (it just booted into the OS).
    At this point I am running out of components to switch out and configurations to try, and so am asking if someone has encountered this issue or would know what the next logical step in my troubleshooting would be.
     
  2. ColEpsi thread starter macrumors newbie

    Joined:
    Feb 16, 2019
    #2
    Nevermind...

    Turns out I havent read the whole thread on Netkas that had a patched version of the updater for my specific ROM version, which is MP1.1-005D-B00. The update went by normally when using that updater.
     
  3. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #3
    Glad to see things went well for you.
    Now you should consider marking your thread as "RESOLVED" found under "Edit Title"

    Screen Shot 2019-03-25 at 7.56.13 AM.png
     
  4. HaRoMR macrumors newbie

    Joined:
    Mar 25, 2019
    #4
    Hi @ColEpsi,
    unfortunately the link to the upgrade tool does not work for me. Do you know any other source where I can get it?

    Thanks in advance and cheers,
    Robert
     
  5. ColEpsi thread starter macrumors newbie

    Joined:
    Feb 16, 2019
    #5
    Seems like the whole of Netkas is down, so I uploaded the tool to Dropbox (hope it works...). This is the "vanilla" version, so if it won't go through don't make the same mistake as me and check the firmware version first. :D

    P.S. found out you can upload a file directly *derp*, so it is attached to the post as well...
     

    Attached Files:

  6. HaRoMR macrumors newbie

    Joined:
    Mar 25, 2019
    #6
    Thanks @ColEpsi! Unfortunately the tool shows an error while downloading stuff to the RAM disk:

    My Boot ROM Version is MP11.005C.B08 and my SMC Version is 1.7f10. I did also try to remove some RAM sticks but still no luck. Do I need a different version of the tool?

    Thanks again and cheers,
    Robert
     
  7. ColEpsi thread starter macrumors newbie

    Joined:
    Feb 16, 2019
    #7
    Which version of the OS are you running? I only got the error running 10.7.5. The error did not occur on 10.6.8 and 10.9.5. Hope it helps!
     
  8. HaRoMR macrumors newbie

    Joined:
    Mar 25, 2019
    #8
    I am running 10.7.5. But I did manage to upgrade my 1,1 to a 2,1 some minutes ago. I will describe it here in case somebody else faces the same issues:

    1. Get the Upgrade tool vom netkas.org via Wayback Machine here as @jbarley suggested or get it from somebody directly like @ColEpsi - thanks!
    2. Download the Apple firmware update
    3. Mount the .dmg file
    4. Use the upgrade tool to create the RAM Disk which in my case directly failed after creating the RAM Disk with the error code 5530
    5. Have a look at the content of the upgrade tool and copy the following scripts from /Contents/Resources to the RAM Disk:
      1. ExtractAndPatchEFIFiles.sh
      2. UpgradeEFI2006-2007.sh
      3. DowngradeEFI2007-2006.sh
      4. MacProEFIUpdater2006.patch
      5. MacProEFIUpdater2007.patch
    6. Open ExtractAndPatchEFIFiles.sh with the editor of your choice
    7. Remove the following lines:
      1. Code:
        hdiutil attach -nobrowse MacProEFI2006and2007.dmg
      2. Code:
        rm -R Expanded
      3. Code:
        rm -R System
      4. Code:
        rm Payload
    8. Save the script
    9. Run it with
      Code:
      ./ExtractAndPatchEFIFiles.sh
    10. Run the actual upgrade script with sudo rights via
      Code:
      sudo ./UpgradeEFI2006-2007.sh
    11. If everything runs trough without error proceed with the firmware upgrade:
      1. Shut down the Mac
      2. Press and hold the power button until it blinks
      3. Wait for the upgrade to finish
      4. Check the firmware version
      5. Reboot in case it does not detect your CPUs correctly until it does.
    That did the trick for me.

    Thanks again and cheers,
    Robert
     
  9. MikeInman macrumors newbie

    MikeInman

    Joined:
    Mar 29, 2019
    #9
    I got thru to item #8, but what to run with???
     
  10. HaRoMR macrumors newbie

    Joined:
    Mar 25, 2019
    #10
    You need to run this shell script in your terminal by using the exact same command as mentioned above.
     
  11. MikeInman macrumors newbie

    MikeInman

    Joined:
    Mar 29, 2019
    #11
    I still must be dense and stupid...
    Here is what the modified file: ExtractAndPatchEFIFiles.sh with the above mentioned parts removed....


    cd /Volumes/RamDisk



    cp '/Volumes/Mac Pro EFI Updater/MacProFirmwareUpdate.pkg/Contents/Archive.pax.gz' .
    gunzip Archive.pax.gz
    pax -r -f Archive.pax

    mkdir MacProEFI2007-2006
    mkdir MacProEFI2006-2007

    cp 'Applications/Utilities/Mac Pro EFI Firmware Update.app/Contents/Resources/EFIUpdaterApp2.efi' MacProEFI2007-2006
    cp 'Applications/Utilities/Mac Pro EFI Firmware Update.app/Contents/Resources/LOCKED_MP21_007F_06B.fd' MacProEFI2006-2007/LOCKED_MP11_005C_08B.fd
    cp 'Applications/Utilities/Mac Pro EFI Firmware Update.app/Contents/Resources/EfiUpdaterApp2.efi' MacProEFI2006-2007
    cp 'Applications/Utilities/Mac Pro EFI Firmware Update.app/Contents/Resources/LOCKED_MP11_005C_08B.fd' MacProEFI2007-2006/LOCKED_MP21_007F_06B.fd

    rm -R Applications
    hdiutil detach '/Volumes/Mac Pro EFI Update/'

    patch MacProEFI2006-2007/EfiUpdaterApp2.efi MacProEFIUpdater2006.patch
    patch MacProEFI2007-2006/EfiUpdaterApp2.efi MacProEFIUpdater2007.patch


    I then used the Terminal app to run (please bear with me I am NOT a programmer or hacker)
    I drop the file into terminal it looks like this:

    Last login: Sat Mar 30 21:00:41 on ttys000
    mac-pro-2006:~ michaelinman$ ./ExtractAndPatchEFIFiles.sh
    -bash: ./ExtractAndPatchEFIFiles.sh: No such file or directory
    mac-pro-2006:~ michaelinman$
    So I must still be doing something wrong...All help is appreciated


     
  12. livemixman macrumors newbie

    Joined:
    Mar 31, 2019
    #12
    --- Post Merged, Mar 31, 2019 ---
    I'm in the same boat...

    "New"er Dual 5365 3.0ghz quad cores, 32GB RAM,

    With Snow Leopard, I at least got the RAM disk to be created before I got the error code...

    Upped to Lion hoping it would resolve the issues with the updater...no dice.

    Now the updater doesn't even create the RAM disk before I get the error.

    Ultimately, I want to get up to El Capitan (w/ updated GPU) going on this FREE to me machine. Do I REALLY need to get to 2,1 to run the EL Cap with the boot loader hack? If I can run El Cap, I can make this machine usufull (min. Req for some SW ineed to run)
     
  13. MikeInman macrumors newbie

    MikeInman

    Joined:
    Mar 29, 2019
    #13

    I can't go any higher as several applications software won't run on anything newer than OS X 10.7 But need to flash to 2,1 so the "Unknown Processor" issue can be resolved... Benchmark sees the correct Processors! but not the MacPro! Go figure.
     
  14. livemixman macrumors newbie

    Joined:
    Mar 31, 2019
    #14
    I just ordered a nVidia GTS8800 512 that has been flashed for 32-bit EFI. Going to install El Capitan w/ the Pikify method. Fingers crossed. Ultimate goal is to be able to successfully run Wirecast v7 and QLab V4 on this 13 year old machine. Nuts!


    I can live with the "unknown" processor situation as long as it doesn't cause any issues (although I would really like to correct this) I'm getting no where with the Netkas firmware flash . Error 5530 still.
     
  15. erroruser macrumors newbie

    Joined:
    Apr 3, 2019
    #15
    tried an fails to work
     
  16. erroruser, Apr 3, 2019
    Last edited: Apr 4, 2019

    erroruser macrumors newbie

    Joined:
    Apr 3, 2019
    #16
    MacPro2006-2007FirmwareTool left it open an also MacProfirmwareUpdate then did till number 8 Run it with
    Code:
    /ExtractAndPatchEFIFiles.sh but this was wrong needs to be as so
    . /ExtractAndPatchEFIFiles.sh need space between the "." an "/" then drop file in then for 9
    sudo ./UpgradeEFI2006-2007.sh is also wrong needs to be
    sudo /UpgradeEFI2006-2007.sh no need for "."
    then i hit the power button to force shut down an hit the power again an waited for blinking light an BOOM is now completed
     
  17. livemixman, Apr 4, 2019
    Last edited: Apr 4, 2019

    livemixman macrumors newbie

    Joined:
    Mar 31, 2019
    #17
    Which os are you running?
     
  18. erroruser macrumors newbie

    Joined:
    Apr 3, 2019
    #18
    i was using lion 10.6.8 also i made a lil error in the code should have been "/ExtractAndPatchEFIFiles.sh"
     
  19. livemixman macrumors newbie

    Joined:
    Mar 31, 2019
    #19
    Thanks SO much for the corrected code...

    I made several OS moves on this free-to-me machine...

    Tiger (originally shipped OS), then Snow Leopard, and now Lion...

    I used the updater as-is in Snow Leopard...the RAM disk was created and then the 5530 error...in Lion the RAM disk wasn't even created before the 5530 crash...

    I'm going to give this a shot in Tiger...If I can get the RAM disk created, I will try the corrected code...just to confirm IT IS the "MacPro1.2EFI" file that will update 1,1 to 2,1 (along with Netkas updater)?

    This machine will end up with Pikify El Captian/Upgraded GPU.

    Thx again for corrected code. This has been driving me nuts.
     
  20. livemixman, Apr 5, 2019
    Last edited: Apr 5, 2019

    livemixman macrumors newbie

    Joined:
    Mar 31, 2019
    #20
    WELL...

    I updated the GPU and installed Pikify El Capitan...AND

    Firmware updater (finally) runs successfully, sort of...

    Creates RAM disk, downloads everything it needs to download, and runs all the way through until the restart prompt...I never even got close to this before. No errors, all SEEMS well...it connects to Apple Server and downloads the files without any issues.

    When I restart holding power button, I get nothing...I tried letting off power button after it flashes and gave it a shot holding it in until the tone...no dice either way. Still 1,1 w/ unknown CPU.

    BUT, progress. I'm going to try and edit the code now that I HAVE a RAM disk to edit and see what I get.
     
  21. Rassama macrumors newbie

    Joined:
    Apr 2, 2019
    #21
    Thanks Robert, this worked for me!
     
  22. Jamin1966 macrumors newbie

    Jamin1966

    Joined:
    Apr 13, 2019
    Location:
    Los Angeles
    #22
    after a few failures by 5530, I got it right now.

    This firmware tool have a few mistakes (extractandpatchefifiles.sh) on macOS 10.6 and 10.7, but works well on macOS 10.11 El Capitan, it is easy to upgrade your macpro1.1 to new system of 10.11, only the 12gb memory needed for the installation, then you can update the firmware to 2.1. I do the steps below:

    1. Partition the HD to 2, one for 10.6.3, one for El Capitan.
    2. Install 10.6.3 first, then Install El Capitan by pikify 3.1.14(no usb).
    3. Install boot64.v3.mpkg.
    4. Restart by cmd+R, terminal, run “csrutil disable”. (Disable the SIP)
    5. Restart and open “Macprofirmwareupdate1.2.dmg” (download from apple), then run “Mac pro 2006-2007 firmware tool”.
    6. Shut down, hold power and release after long beep and sound.
     
  23. ronbon macrumors newbie

    ronbon

    Joined:
    May 23, 2019
    #23
    For some one not up to speed on coding, would you mind explaining steps 9 and 10? Thankyou, Ronbon
     
  24. Fylylylybymy, May 29, 2019
    Last edited: May 29, 2019

    Fylylylybymy macrumors newbie

    Joined:
    May 29, 2019
    Location:
    UK
    #24

    Thank you HaRoMR!

    It worked for me :)

    same Boot ROM as yours, running 10.6.8

    I have downloaded Firmware update files from apple for 1.1 and 1.2

    Mounted both dmg

    Run app from Netkas forum to update firmaware

    It failed (error 5530) but created RAM disk

    I opened app again, without pressing "upgrade"

    Right click app icon, go to 'show package content'

    Opened folder 'contents'

    Opened folder 'resources'

    Grabbed all without icon and 2 blue folders and dropped in RAM disk

    Amended 'ExtractAndPatchEFIFiles.sh' as per your instructions

    The only difference is when I opened terminal, I didn't type, just drag 'ExtractAndPatchEFIFile.sh' and drop into terminal window, that way mac will fill out any required info about path
    press enter/return

    Then type in "sudo" press 'space' drag 'UpgradeEFI2006-2007.sh' drop into terminal, press enter/return
    Type in your password
    press enter/return

    Shut down

    Hold power button till mac light starts to flash

    That's it! :)

    Hope it helps anyone :)

    Simon
     
  25. spinaspina88 macrumors newbie

    Joined:
    Jun 8, 2019
    #25
    Hello and sorry but i really don't understand the point 8 and 9.
    I've the Lion 10.7.5 and i have the ramdisk ready with the modified script....now the only way to execute them is to open a terminal and drag every SH files inside....but doesn't work.
    Second question is: Why downloading the original EFI 2.1 patch from apple if you need only the netkas patcher and you are only modifing the scrips inside it?
    Thanks for your help because I really want to give a boost to my old mac pro 1,1.
    Sorry for my baaaaad english of course!!!
     

Share This Page

24 March 25, 2019