Macbook Air Sound Muted

Daniel2424

macrumors newbie
Original poster
Aug 26, 2016
2
0
Hi,
My sound is muted on my new Macbook Air. I have tried to turn it up using buttons and also using headphones. In the top column the sound icon is grey and when I go into system preferences the "muted" button is checked and grey and I am also unable to un-check the box. I have included pictures. HELP!!!
Screen Shot 2016-08-26 at 1.31.52 PM.png
Screen Shot 2016-08-26 at 1.32.32 PM.png

[doublepost=1472264377][/doublepost]I have added another picture of what happens when I try to turn up the volume from the keyboard controls. Please Help. Thanks.
Screen Shot 2016-08-26 at 10.16.56 PM.png
 

macrumorsforumuser

macrumors newbie
Mar 20, 2017
2
0
A restart solves this issue. Sometimes pressing the mute button on the keyboard a few times also fixes it.
Hey,

my MBA happens to have the same issue, though restarting or hitting the mute key several times doesn't help. Would be great if someone had another hint how to resolve the issue. Thanks.
 

ApfelKuchen

macrumors 68040
Aug 28, 2012
3,664
2,266
Between the coasts
Hey,

my MBA happens to have the same issue, though restarting or hitting the mute key several times doesn't help. Would be great if someone had another hint how to resolve the issue. Thanks.
In System Preferences > Sound > Output > Select a device for sound output - what device is selected? It ought to be "Internal Speakers Built-in"
 

cruisin

macrumors 6502a
Apr 1, 2014
962
223
Canada
I found something that occasionally works for me: https://discussions.apple.com/thread/4202694?start=0
Open a console and type in: sudo chown -R _coreaudiod:admin /Library/Preferences/Audio
This will fix permissions.

Then type in: sudo update_dyld_shared_cache -force
This will clear and rebuild dyld (dynamic linker)

And finish with: sudo killall coreaudiod
To restart the audio daemon. The sound should come back instantly and keep working on reboot.
Or as a one line command:
Code:
sudo chown -R _coreaudiod:admin /Library/Preferences/Audio && sudo update_dyld_shared_cache -force && sudo killall coreaudiod
This will take a bit to run (about 30 seconds) and then the audio will come back but the keyboard buttons will not work for the first few minutes.

Or you can try to reset the NVRAM and SMC. Some people say it helps, but it did nothing for me.
Resetting NVRAM
  • Shut down your Mac.
  • Locate the following keys on the keyboard: Command (⌘), Option, P, and R.
  • Turn on your Mac.
  • Press and hold the Command-Option-P-R keys immediately after you hear the startup sound.
  • Hold these keys until the computer restarts and you hear the startup sound for a second time.
  • Release the keys.
Reset the SMC on Mac notebook computers
  • Shut down the Mac.
  • Plug in the MagSafe or USB-C power adapter to a power source and to your Mac.
  • Using the built-in keyboard, press Shift-Control-Option on the left side of the keyboard, then press the power button at the same time.
  • Release all keys, then press the power button again to turn on your Mac
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.