Macbook Pro Internal Keyboard Trackpad not working.

Discussion in 'MacBook Pro' started by antron81, Feb 6, 2016.

  1. antron81 macrumors newbie

    antron81

    Joined:
    Feb 6, 2016
    #1
    Hi there,

    I have been scouring the net for a solution to my issue, and none of the responses have worked so I hoped I might be able to get some new advice.

    I opened the lid of my A1398 (2012 Macbook Pro 15" Retina, 256gb SSD) this morning and the trackpad and keyboard had stopped working. I have tried the following to get it working again:

    - SMC Reset using Option-Control-Shift
    - NVRAM Reset using Command-Option-P-R
    - Reinstalling El Capitan 10.11.3 over the old install
    - Using Disk Utility to wipe the Mac HDD and then install a fresh El Capitan 10.11.3
    - Disabling the Internal keyboard and then re-enabling it.

    I have attached a video which shows a strange flickering in the Keyboard System Preferences,. Not included in the video is when you go to change the modifiers, and you drop the menu down while the F-Key options that is flashing is displayed, you can get the Keyboard/Trackpad to show up.



    I know other people have had these issues in El Capitan but it's very frustrating. Any ideas?
     
  2. dastinger macrumors 6502a

    dastinger

    Joined:
    Mar 18, 2012
    #2
    I had this happening to me twice since installing 10.11.3. Exact same machine as yours. I didn't check System Prefs when it happened so I don't know if that flickering is present on mine.

    First time it happened, keyboard stopped working but the trackpad kept on working fine. I waited some seconds and the keyboard suddenly worked again. Second time was some minutes ago. Both the keyboard and trackpad stopped working and I had to force a reboot by keeping the power button pressed.
     
  3. antron81 thread starter macrumors newbie

    antron81

    Joined:
    Feb 6, 2016
    #3
    Only problem for me is that it wasn't during install. Also, forcing shutdown with the power button does nothing. Very frustrating.
     
  4. dastinger macrumors 6502a

    dastinger

    Joined:
    Mar 18, 2012
    #4
    You read it wrong. I had this happening twice since installing (updating). Not during install.
     
  5. antron81 thread starter macrumors newbie

    antron81

    Joined:
    Feb 6, 2016

Share This Page