Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

MacintoshUser101

macrumors member
Original poster
Aug 26, 2015
33
3
Hello. My rMBP Seems to be very slow and lag when i play certain videos from youtube in Safari 9.1.3 and the computer heats up. I am currently running 10.11.6. Can someone please assist?
My MBP Spec is a Mid 2014 15 inch with NVIDIA GT 750m 16GB Ram.
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,539
25,302
Hello. My rMBP Seems to be very slow and lag when i play certain videos from youtube in Safari 9.1.3 and the computer heats up. I am currently running 10.11.6. Can someone please assist?
My MBP Spec is a Mid 2014 15 inch with NVIDIA GT 750m 16GB Ram.

If you restart your Mac with 'reopen windows when logging back in' disabled/unticked, does the issue persist when you try the same videos?
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,539
25,302
Tried and that doesn't help unfortunately.

Any videos in particular?

Try download gfxCardStatus: http://gfx.io/downloads/gfxCardStatus-2.3.zip

You won't have to install it -- just run it from the downloads folder. A new icon will appear on the top menu bar. Click that. Try to change the graphics from auto switch to dedicated, and similarly with integrated. Try both iGPU/dGPU, closing & reopening Safari each time. Is there a positive difference when running from either?
 

MacintoshUser101

macrumors member
Original poster
Aug 26, 2015
33
3
Any videos in particular?

Try download gfxCardStatus: http://gfx.io/downloads/gfxCardStatus-2.3.zip

You won't have to install it -- just run it from the downloads folder. A new icon will appear on the top menu bar. Click that. Try to change the graphics from auto switch to dedicated, and similarly with integrated. Try both iGPU/dGPU, closing & reopening Safari each time. Is there a positive difference when running from either?
Here's an example:
When i open the video then go fullscreen and then back to the normal size view it lags and then i get the beach ball.
 

Fishrrman

macrumors Penryn
Feb 20, 2009
28,596
12,713
Re the YouTube video in post 7 above:

I'm on a late-2012 Mac Mini, still running 10.8.5 as I type this.
I played the video, went to full screen "and back" three times, without problems.

Something else is interfering on your setup, I believe.
 

Hieveryone

macrumors 603
Apr 11, 2014
5,625
2,338
USA
Hello. My rMBP Seems to be very slow and lag when i play certain videos from youtube in Safari 9.1.3 and the computer heats up. I am currently running 10.11.6. Can someone please assist?
My MBP Spec is a Mid 2014 15 inch with NVIDIA GT 750m 16GB Ram.

Maybe you have something using up a lot of RAM? Whenever I have problems, I just turn it off and on and it seems to work again. But I rarely have problems. I might have had problems only once or twice.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.