Macbook Pro Retina 2012 Screen Flickering

Discussion in 'MacBook Pro' started by anixon604, Sep 29, 2017.

  1. anixon604, Sep 29, 2017
    Last edited: Oct 17, 2017

    anixon604 macrumors newbie

    anixon604

    Joined:
    Sep 29, 2017
    #1
    My screen is flickering in a predictable cycle. During the flicker, there is horizontal and vertical grey lines and the display seems to freeze. However, the computer does not freeze during this time... if you keep typing you will see it all when the flickering dissipates.

    Tried replacing the LVDS connector and the cable.

    Has anyone seen this or have any ideas what could be causing it or how to fix it?

    Here is a video of what's going on.

    https://www.youtube.com/watch?v=KbCx08Vn...

    Please let me know if you guys have seen anything like this before and what you think it is. Thanks.


    UPDATE: Oct 17, 2017

    So there are some key things to this issue. Firstly, I tried to turn off automatic graphics switching and it did nothing.

    I AM able to get video over HDMI and its perfect no issues at all. However, my screen will keep flickering during this time.

    After being on for a while... either using through HDMI or trying to use the flickering LCD the screen seems to go to normal and then as long as I leave the computer on it stays normal!

    It's almost as if it's "warming" up or something.

    I've also noticed a tingling on the casing when I have the laptop plugged... I may have a short... I will investigate.

    1 - Right now I'm wondering if there is a short somewhere that cold be causing this
    Don't think this is it.... after researching the tingling seems more related to the fact I moved to Europe and they dump the excess of the 240V to the case.

    2 - Anyone also know if this could be an SMC related issue as I didn't have a working battery when this originally presented (now there is a new battery in) and I heard that the SMC draws off the main battery instead of having a regular coin style battery.
     
  2. TofSanity macrumors 6502a

    TofSanity

    Joined:
    Oct 29, 2010
    #2
    have you turned off the automatic graphics to see if that helps? it looks like your graphics card
     
  3. MacInTO macrumors 65816

    MacInTO

    Joined:
    Apr 25, 2005
    Location:
    Canada, eh!
  4. anixon604 thread starter macrumors newbie

    anixon604

    Joined:
    Sep 29, 2017
    #4
    My laptop has been tinkered with a TON so i definitely wouldn't qualify for this. The problem seems related to after I had the LVDS connector repaired.
    --- Post Merged, Oct 17, 2017 ---
    I tried tried switching off the automatic graphics and it didn't help. I have an update on the issue though. Which I've appended to the original post.
     
  5. kokomoko macrumors newbie

    Joined:
    Oct 17, 2017
    #5
    I got the same problem. At least in my case is related somehow to heating. It occurs when I compile + watch video mostly
     
  6. anixon604 thread starter macrumors newbie

    anixon604

    Joined:
    Sep 29, 2017
    #6
    I'd heard about your problem before. I think that may be a recall issue with Apple. My problem is almost the opposite, where it works more so when it IS hot.
     

Share This Page