MacBookPro 11.3 doesn't start unless power is pushed for ~8 secs,kernel_task high CPU, fresh install

Discussion in 'MacBook Pro' started by Camicia, Oct 24, 2018.

  1. Camicia, Oct 24, 2018
    Last edited: Oct 26, 2018

    Camicia macrumors newbie

    Camicia

    Joined:
    Feb 4, 2013
    #1
    Hi,

    I am pretty sure this is not a new problem. I hope that somebody has seen it before and hopefully they have some recommendations. What can I try next?

    The problem:

    In order to start my MacBookPro Retina( 11,3 - Late 2013 ) I need to keep the power button until the chime sound is completely finished. The release needs to be timely. If I release it before the computer shut down. If I keep it pressed too long it shut down like if you do a "hard reset" when the computer is running. It is also not able to recover from sleeping.

    When it boots it is very slow. The CPU on kernel_task is 400% - 1200%. At boot time it is also very slow and the animations on the drive icons if you start with CMD+R are also super slow.

    The fans are quite but I am sure they are working because I can turn them up with the temperature gadget. Other temperature sensors also seems Ok.

    The problem started on High Sierra that I had been running for a little less than a year.

    Mitigation:

    Interestingly enough, if I open it, physically unplug the battery and I start with only the power adaptor, it works well.

    I can push the power button for only 2 seconds, the kernel_task is less than 5% and the laptop is running fast as normal. If I wanted to transform it in a desktop that might work... but I obviously want it to move around.


    What I tried so far:
    • Reset SMC and clear NVRAM (multiple times).
    • Start the Diagnostic with CMD+D. It returned "No issues found. ADP000".
    • I wiped the HD (including EFI partition) and run an Internet restore that installed Maverick. The problem persisted. Interesting facts: it went from "About 1,056,366,442 hours and 38 minutes remaining" to "0" in a few seconds... Eventually it went back to 20 minutes but it took probably 4 hours to get slowly down to 0 and finish the installation. No improvement.
    • I wiped again and installed Mojave. This time I did it with the battery unplugged. It took about 30 minutes. The trackpad was working but not recognized in "Settings - Trackpad" It was looking for bluetooth trackpads. When I plugged back the battery and rebooted, the trackpad started showing up but I started having again the 400% CPU on kernel_task and needing to press on power for longer than usual. And again it was not resuming from sleeping.
    • I went to the Genius bar. They run tests and tried the "manual" SMC reset disconnecting the battery that I did already and it fixed nothing. They gave me the standard answer: it is probably a problem with the logic board, it is going to be $575+TAX (ouch!), it will took about 10 days and it has a 30 or 90 days warranty after the repair. I am not sure if it is completely guaranteed. They says that I will get back a working computer. Their tool did not report any "common" problems. The person there did not want me to take pictures. They run 3 tests (general, sensor and another one that I do not remeber). None of the temperatures in the report seemed off but there were:
      • a generic MLB F:050000 code - I think it was relative to the battery but I could not find anything on Google.
      • A failed test: TIM Test 75 percent Gardband. - Check that CPU heatsink is properly attached, using product spec theta dh + 75 percent guardband - on Google I did not see anything very actionable. It is a stress test and considering that the temperatures were normal, I would not expect any improvement changing the thermal paste or the heatsink. Am I wrong?
    • The BIOS and SMC were supposedly updated to the latest version but I forced flashed the BIOS first and of all 3 parts of the SMC firmware (one by one) later. I though that some internal state may had been out of wack and reflashing them could reset it. I tried before with rEFInd but I was not able to run the SMCFlasher.efi so I used the OS commands: /usr/libexec/efiupdater --force-update and /usr/libexec/smcupdater
      I saw only the output of the commands in the OS setting up the flashing and the final bless command. On restart I could not see the EFI execution's output. By the way do you know how you can see the output?
      The only significant difference was that when I restarted Mojave, the CPU was 400% but it dropped to 100% after a few minutes on the first reboot after SMC flash. I think it eventually went up again... for sure, it was back to ~400% after a reboot. I did not have the courage to try to downgrade the SMC and risk to brick the SMC that I am not sure how to flash if the computer stop booting.
    • On Mojave, I tried to eliminate all .plist in ACPI_SMC_PlatformPlugin.kext as described in https://forums.macrumors.com/threads/how-to-solve-kernel_task-high-cpu-usage.1706948/ since my model was not there... no improvement.
    • I read the BIOS from the MX25L6406E chip with a Raspberry Pi, replacing the ME region copying the whole ME Region from the SCAP BIOS file (the current version MBP112.0146.B00 ), and flash it back. After some googling that it is how I understood ME cleaning should be done. I am not completely positive that it is correct. But anyway... no changes.
    • I run EtreCheckPro free version when Maverick was installed. It said that the test was running slow and some think else that did not help a lot. I can re run it or provide the output if necessary.

    Did you see this problem before? How was it fixed?


    Description of the system:

    It has an NVIDIA GeForce GT 750M. In the "secret" NRAM variables

    Some general info:
    Code:
                    
                    SMC_version_system: 2.19f12
                    boot_rom_version: MBP112.0146.B00
                    cpu_type: Intel Core i7
                    current_processor_speed: 2.3 GHz
                    l2_cache_core: 256 KB
                    l3_cache: 6 MB
                    machine_model: MacBookPro11,3
                    machine_name: MacBook Pro
                    number_processors: 4
                    physical_memory: 16 GB
                    BoardID: Mac-2BD1B31983FE1663
    
    
    The logic board is a 820-3787-A that is the version of the 820-3662 with the extra NVIDIA GPU.

    Battery details (since it works without the battery I wonder if this may help):
    Code:
        
            AdapterInfo: 0
            Amperage: -904
            AppleRawCurrentCapacity: 5032
            AppleRawMaxCapacity: 7279
            AvgTimeToEmpty: 334
            AvgTimeToFull: 65535
            BatteryData:
                CycleCount: 741
                DesignCapacity: 8440
                QmaxCell0: 20767
                QmaxCell1: 18975
                QmaxCell2: 29471
                ResScale: 0
                StateOfCharge: 17920
                Voltage: 11562
            
            BatteryFCCData:
                DOD0: 0
                DOD1: 0
                DOD2: 0
                PassedCharge: 0
                ResScale: 0
            
            BatteryInstalled:
            BatteryInvalidWakeSeconds: 30
            BootPathUpdated: 1514809090
            CellVoltage:
                3854
                3866
                3842
                0
            
            ChargerData:
                ChargingCurrent: 0
                ChargingVoltage: 0
                NotChargingReason: 1
            
            CurrentCapacity: 5032
            CycleCount: 741
            DesignCapacity: 8440
            DesignCycleCount70: 65535
            DesignCycleCount9C: 1000
            DeviceName: bq20z451
            ExternalChargeCapable:
            ExternalConnected:
            FirmwareSerialNumber: 1
            FullyCharged:
            IOGeneralInterest: IOCommand is not serializable
            IOObjectClass: AppleSmartBattery
            IOObjectRetainCount: 6
            IORegistryEntryName: AppleSmartBattery
            IOReportLegend:
                
                    IOReportChannelInfo:
                        IOReportChannelUnit: 0
                    
                    IOReportGroupName: Battery
                
            
            IOReportLegendPublic:
            IOServiceBusyState: 0
            IOServiceBusyTime: 239684
            IOServiceState: 30
            InstantAmperage: -1043
            InstantTimeToEmpty: 233
            IsCharging:
            LegacyBatteryInfo:
                Amperage: -904
                Capacity: 7279
                Current: 5032
                Cycle Count: 741
                Flags: 4
                Voltage: 11562
            
            Location: 0
            ManufactureDate: 17253
            Manufacturer: SMP
            MaxCapacity: 7279
            MaxErr: 1
            OperationStatus: 58435
            PackReserve: 200
            PermanentFailureStatus: 0
            PostChargeWaitSeconds: 120
            PostDischargeWaitSeconds: 120
            Temperature: 3020
            TimeRemaining: 334
            Voltage: 11562
        
    
    IORegistryEntryName: AppleSmartBatteryManager
    IOServiceBusyState: 0
    IOServiceBusyTime: 401772
    IOServiceState: 30
    IOUserClientClass: AppleSmartBatteryManagerUserClient
     
  2. Camicia, Oct 26, 2018
    Last edited: Oct 26, 2018

    Camicia thread starter macrumors newbie

    Camicia

    Joined:
    Feb 4, 2013
    #2
    Did I understood correctly how the SMC works? If something is slightly off it throttle down the computer. If one of the components is not found, it stops doing diagnostic and chill... that does not make a lot of sense.

    I just edited the main post to make the data more readable.

    For a moment I though I found the problem: one of the cell battery is 0V!

    Unfortunately this battery package has 3 cells, so 0V on the fourth cell is expected.

    However at https://www.ifixit.com/Store/Mac/MacBook-Pro-15-Inch-Retina-Late-2013-Mid-2014-Battery/IF117-046-5 it says that the battery should be 11,26V and I have 11,562V. Can the 0.3V difference be what upset the SMC?
     
  3. Camicia thread starter macrumors newbie

    Camicia

    Joined:
    Feb 4, 2013
    #3
    Update:The Charger BMON sensor (ampere drawn from the battery) is always reporting 18A ... If the SMC thinks that the battery is constantly sending 18A it thinks that something is wrong.

    How can I fix it? I was looking at the schematic 820-3787-A and the SMC is driven by the ISL6359 chip. I checked the resistors between SMC and the ISL6359, so the problem must be around the ISL6359. Did anybody fixed this problem before?
     
  4. _Kiki_ macrumors 6502a

    Joined:
    Aug 13, 2017
    #4
    You should replace the battery after that you'll see if problem still occur
     
  5. Camicia thread starter macrumors newbie

    Camicia

    Joined:
    Feb 4, 2013
    #5
    A battery is $100... My gut tells me that the probability that it may work are low... nevertheless if I had one battery handy I would give it a try.
     
  6. Camicia thread starter macrumors newbie

    Camicia

    Joined:
    Feb 4, 2013

Share This Page

5 October 24, 2018