macOS 10.12 Sierra Unsupported Macs Thread

Discussion in 'macOS Sierra (10.12)' started by redheeler, Jun 13, 2016.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. Branskins macrumors 65816

    Dec 8, 2008
  2. Machist macrumors member


    Mar 9, 2016
    Night Sift is enabled but it is not work?
    It is scheduled to sunset to sunrise.

    I need to always turn that off and on -> then it works.

    Mac Pro 2008
  3. Branskins macrumors 65816

    Dec 8, 2008
    Finally got it installed and everything looks great on my mid 2009 MBP!

    AirPods seem to work only when going to Bluetooth -> AirPods -> Connect. Then they show up in the volume controls.

    But when I connect them to my iPhone and try to switch back, there is no AirPods option in the volume controls. It only works through the Bluetooth settings.

    Any idea why this would work this way?
  4. fischersd macrumors 601


    Oct 23, 2014
    Kitchener, Ontario, Canada
    It could be that your Bluetooth card needs to support BLE. From one of the articles published on using them:
    "On Apple TV, older Macs and non-Apple devices like Windows PCs and Android smartphones and tablets, you will need to manually connect AirPods in Bluetooth settings menu before you can use them."

    On my 2012 Mini as well as my 2008 MBP (which has an upgraded card that support BLE 4.x) the AirPods are always listed under bluetooth devices, but only show under the volume control when they're active (out of their case).
  5. kaanmijo, Apr 14, 2017
    Last edited: Apr 14, 2017

    kaanmijo macrumors newbie

    Apr 14, 2017
    Did you manage to fix this? I'm having the same issue on my mid-2009 MBP.

    I've got it up and running! The version of macOS I downloaded wasn't compatible with the tool. I used this tool: to download the correct version and it worked!
  6. exiva macrumors newbie

    Jan 16, 2009
    I'm trying to patch the recovery partition on a drive with filevault on it and the post install patcher always crashes when I have that option enabled. Did it on the same machine, same usb stick just a different HD and it worked fine. Here's the crashlog for it.

    Also this is the partition map from diskutil list

    /dev/disk0 (internal, physical):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *1.0 TB     disk0
       1:                        EFI EFI                     209.7 MB   disk0s1
       2:          Apple_CoreStorage Macintosh HD            999.3 GB   disk0s2
       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
    /dev/disk1 (internal, virtual):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:                  Apple_HFS Macintosh HD           +999.0 GB   disk1
                                     Logical Volume on disk0s2
                                     Unlocked Encrypted
  7. toyosup88 macrumors newbie

    Feb 10, 2017
  8. Ferferu2 macrumors newbie


    Apr 17, 2017
    Is the link down? the page doesn't load. I have the same issue as you, Macbook Pro 4,1 (Early 2008). I disable SIP, patch Sierra with the latest version of the tool and then boot and press the Option key. I select the USB and.. it never finishes loading.. it gets stuck at aproximately half of the progress bar, cursor appears and transform into the beach ball of the death ... fans start making noise and nothing happens

    I have tried two different usbs and I switched the language to English before creating the USB (my MB is in Spanish)
  9. Damodici macrumors member

    Nov 10, 2014
    Hi All,

    Ive tried reading through as many of the early pages i could on this and then from the most recent backwards a little.

    Unless I'm mistaken, i should still use the brilliant walkthrough from here -

    The only problem I'm having to start with is that the link for actually downloading Sierra itself doesn't seem to work.

    The Mega website loads up but theres no apparent file or link to download anything? Ive even registered an account thinking that might be the reason and still the link doesn't go to anything unfortunately.

    is that correct or am i using an older way of doing the update?

    Having checked my system (although I'm no techy by any stretch) it seems I'm lucky enough to not expect any of the wifi issues due to my card model being - 0x14E4, 0x8D (see below screenshots)

    i also believe i shouldn't expect the trackpad issues either?

    Heres my system details with some elements redacted

    Screen Shot 2017-04-17 at 18.20.46.png Screen Shot 2017-04-17 at 18.19.59.png Screen Shot 2017-04-17 at 18.19.08.png Screen Shot 2017-04-17 at 18.19.29.png

    Can anybody advise the best route to take doing this upgrade? Whatever the most recent version is i guess.

    If its still simply to follow the dosdude1 walkthrough thats fine, but is there another way i can get the Sierra download for it to work in conjunction with this method?

    Thank you all.
  10. dosdude1 macrumors 65816


    Feb 16, 2012
    I'm not exactly sure why, but Mega seems to be screwed up right now... For some reason, you have to copy and paste the link from the webpage into the address bar of your browser, then it works... Not exactly sure why that is, but it does.
  11. Damodici macrumors member

    Nov 10, 2014
    Thanks for replying dosdude1, much appreciated.

    I take it you mean right hand click and 'copy link' on this part where it says 'here' ?

    -A copy of the macOS Sierra Installer App. This can be obtained from the Mac App Store using a machine that supports Sierra, or if you don't have one, you can download a copy here

    Just given that a go and unfortunately it just loads up the same as clicking on it for me.

    I tried using a different browser (usually safari) so opened Chrome and pasted it in there and get the same results.

    is there a direct link you could possibly pm me which shares it from your folder maybe?

    Again appreciate the effort you've done on this
  12. dosdude1 macrumors 65816


    Feb 16, 2012
    The link somehow got screwed up... It should work just by clicking on it now.
  13. Ferferu2 macrumors newbie


    Apr 17, 2017
    yep, the link is working now:!e0sAwarD!olRixx47PbvlqlcWNpAjfJKcbhzpvggxFXP4qafCKj4

    I'm going to try with that version, I have tried with the 10.12.4 version from the Spanish Mac App store and with a 10.12.0 I found, and the usb drive always hangs up while loading the installer

    (macbook pro 4,1 early 2008, English language, SIP disabled)
  14. Kosti, Apr 18, 2017
    Last edited: Apr 18, 2017

    Kosti macrumors newbie

    Mar 19, 2017
    I keep getting errors when checking for updates

    The operation couldn’t be completed. (NSURLErrorDomain error -1100.)
    I switched productions on AUS to seed I can see Beta files, but when I switch it back I get the above error

    Assuming its not a big deal as there are no updates
  15. rambon macrumors newbie

    Apr 20, 2017
    hi, after updating to sierra 10.12.4 and enabled nightshift I'm not able to use airplay to stream video from safari or quicktime to my apple tv but I'm still able to use airplay with itunes to stream music. I try different solution to fix the problem with no results. I check firewall's options, turned on and off the option in system preference->monitor to show in the menubar, try to delete keychains folder from user-library as suggested by someone, did different reboot of my late 2008 macbook pro and apple tv too but I'm not able to use airplay. After opening a video when I push on the airplay logo like on the menubar blink quickly with a new icon (or just a space) that I'm not able to see (i think airplay) and after a while I receive the message that was not possibile to connect to my apple tv. If i try to send audio to apple tv from system pref->sound or from sound menubar I get the same error message. From system preference->monitor when enabling the option to show in menubar mirroring options I just saw in the menubar a quickly invisible icon/space appearing between wifi icon and bluetooth icon. I know my macbook pro is not supporting screen mirroring but in the past I was able to send to my apple tv the video from safari or send all the sound from the mac to the apple tv, now only iTunes is working with apple tv. Anyone with this issue? any solutions?
    I'm able to use airplay or mirroring from my iPhone iPhone
  16. Sedulous macrumors 68020


    Dec 10, 2002
    AirPlay can be buggy. I do not think it is caused because of running Sierra on unsupported hardware. It might be bandwidth limitation. Sierra does seem to have more network chatter.
  17. rambon macrumors newbie

    Apr 20, 2017
    Thanks for reply.
    What do you mean with badwith limitation?
    The Apple TV is connected by Lan cable, I have a brand new router xiaomi r1d and a 100 mbit fiber
  18. Sedulous macrumors 68020


    Dec 10, 2002
    The AppleTV might be connected by cable but I presume the stream for airplay is coming from wifi connected source. I'm just suggesting the possibility that this might be the source of airplay issues. Yeah, it is possible something got messed up during Sierra update and is causing issues. Airplay is still glitchy too. But I have not experienced airplay issues caused by unsupported install of OS 10.12. Mine seem to be caused by my router.
  19. Surgeon One macrumors newbie

    Surgeon One

    Apr 2, 2017
    United States of America
    You are correct...I uninstalled Norton internet security and all is well in Zion...
  20. danyMRF macrumors newbie

    Apr 24, 2017
    Hello everyone,

    I wanted to know if using the dosdude1 tool can be install macOS Sierra (on an unsupported Mac mini Late 2009) on an external USB hard drive, leaving the internal hard drive unchanged with OS X El Capitan.

    Thank you all.
  21. dosdude1 macrumors 65816


    Feb 16, 2012
    Yes, it can be. Just select that drive when installing, and of course run the post-install patch on it as well.
  22. chris_de macrumors newbie

    Apr 24, 2017
    I've been trying to get 10.12 installed on my Mac Pro early 2008 but no luck. I have followed the instructions that dosdude has on his site but I'm not sure why it fails. I get 2 errors when trying to install the software to the USB (which is a brand new SanDisk 16GB Cruzer Glide)the first is that the macOS Sierra Patcher app has unexpectedly quit and this is right at the end of the install. So I have tried reformatting the USB as GUID Partition and on another try as a Boot record and reinstalling. But no luck. The second error I get is screen capped below. All failures are at the very end of the install.
    In both cases the USB has what looks like a proper set of files and directories on it for an install. So each time I try and reboot from USB and when I select it I get the "NO" symbol( circle /). Any ideas as to what I'm doing wrong? btw SIP is disabled and I downloaded the install from dosdudes's link ( only Opera worked). My Mac Pro is running 10.11.6.

    Appreciate any help, tried slogging through this thread but its a bit long.



    Attached Files:

    • Err1.png
      File size:
      181.5 KB
  23. dosdude1 macrumors 65816


    Feb 16, 2012
    It looks like there's some sort of issue with your USB drive, seeing as it has disconnected unexpectedly. Try a different USB port or different drive.
  24. chris_de macrumors newbie

    Apr 24, 2017
    Appreciate the quick reply! Thanks. Yeah I have tried every port on the machine and the keyboard so maybe its the USB which I just bought earlier today. I will try another one tomorrow and see what happens. Thanks!
  25. pdcardec macrumors newbie

    Apr 26, 2017
    I made USB disk but it does not boot on my imac 9,1. while pressing option key (alt) boots straight from mainSDD
    If i try other Mac it can boot from this USB
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page