macOS 10.13 High Sierra - Bugs and bug fixes

Discussion in 'macOS High Sierra (10.13)' started by xflashx, Jun 7, 2017.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. brokeniño macrumors newbie

    Joined:
    Nov 2, 2017
    #501
    10.13.2 Beta 4 (so I think 10.13.2 public release is coming soon) and bugs that bother me the most are still present:

    • You need to reboot/re-log when you install a new AU plug-in in order to Logic Pro X to detect it.
    • "Mouse Keys" is unusable.
    • "Order by" > "Name" scrolls to top of a Finder window instead of retain the scroll position of the window.
    • You get clicks/pops if you minimize Safari while playing audio using an external audio interface.

    I think I will downgrade to Sierra, I will not upgrade my Mac anymore and I will not buy another Apple product anymore.
     
  2. nameste macrumors regular

    Joined:
    Mar 8, 2016
    #502
    my mbp came with high Sierra .When I try to downgrade to Sierra it says this program is too old.Is there a way to downgrade for me?
     
  3. 011 macrumors member

    Joined:
    Oct 16, 2017
    #503
    If You use the same Apple ID and had downloaded Sierra on previous MacBook Pro.

    If you had Sierra, download it, make bootable USB drive, get in the Recovery mode and install it from USB.

    Backup all your important things.
     
  4. nameste, Nov 18, 2017
    Last edited: Nov 18, 2017

    nameste macrumors regular

    Joined:
    Mar 8, 2016
    #504
    I managed to create a sierra bootable USB drive but when I select to install sierra system drive I can't select my ssd drive
     

    Attached Files:

  5. whg, Nov 18, 2017
    Last edited: Nov 18, 2017

    whg macrumors regular

    whg

    Joined:
    Aug 2, 2012
    Location:
    Switzerland
    #505
    Select Disk Manager from the Tools menu and erase your SDD to get rid of the APFS file system on it. Format as Journaled (HFS+) then you can install Sierra again. High Sierra has converted your SSD from the old HFS+ to the new APFS file system that the Sierra installer doesn't know how to handle.
     
  6. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #506
    Must be a very new one. You cannot downgrade to a lower version than what came installed on the machine from Apple.
     
  7. nameste macrumors regular

    Joined:
    Mar 8, 2016
    #507
    well actually you can thanks @whg I am now using Sierra
     
  8. JingleOtoko007 macrumors newbie

    Joined:
    Nov 24, 2017
    #508
    Been a Mac user for more than 25 years. Regularly use the resources at Mac Rumors and thought this might be a good place to post a High Sierra bug I just discovered...

    Been running High Sierra on several systems for about a month now. I've seen a few minor issues crop up, but nothing too scary. Until now, the only really inconvenient bug I've encountered is that I can't easily scroll all the way down some text files created with textedit. (Rtf format) The cursor stops at about 1/3 the way down. The only solution I've found is to Cnd+DWN(arrow) to the bottom and scroll upwards.

    But today, (using a brand new 21.5" iMac) I downloaded a couple of JPGs from my own website because I had lost the original files and noticed that they had been date-stamped as modified "Tomorrow." First time I've seen that one. So far not a problem for me, but a little scary. All other dates and times on my system seem ok. (See screenshot below)

    Just wanted to document this and wondered if anyone else had encountered similar (or worse) issues with the time stamp.
     

    Attached Files:

  9. broattimes macrumors newbie

    Joined:
    Nov 24, 2017
    Location:
    Australia
    #509
    I've noticed that this version of High Sierra (10.13.1) does seem to have a few bugs in the Finder - I've found particularly with Quick Look. I use it quite a bit and noticed when I updated that it was lagging when viewing images (jpgs, pngs, etc) and it stopped quick viewing Illustrator files altogether (ai & eps). I only bought my iMac only a few months ago and Quick Look was very fast, now I'm finding that I have to relaunch my Finder every 15-20 mins to refresh Quick Look.

    I also tried to download the EPSQLPlugIn.qlgenerator, however, I think this is outdated. Maybe there's a new qlgenerator that might fix the issue?

    Anyone else having this issue or recommend a fix?
     
  10. mhrob macrumors newbie

    Joined:
    May 17, 2004
    #510
    Make sure that the display menu matches whatever column sorting order you have selected, as the sort order can vary greatly between these two modes (see attachment) and they combine.

    Capture d’écran 2017-11-25 à 20.10.37.jpg
     
  11. friednoodles macrumors 6502

    Joined:
    Feb 4, 2014
    #511
    Interesting to see that beta 5 displays the favicon of the current site in the address bar in Safari. This may not make it in 10.13.2 because it's pretty buggy right now (the buttons for Reader view and Add to Reading List end up sitting over the top of it), but it's a start! Maybe they'll finally introduce an option to display favicons in tabs as well... (this is a feature of Chrome and Firefox that I really miss in Safari).

    Edit: And now they've disappeared! Very strange.
     
  12. Copyjoh macrumors newbie

    Joined:
    Nov 29, 2017
    #512
    I upgraded to os high Sierra last week but there was an error during the installation, and now my computer always starts on the MacOS Utilities screen... Have tried to reinstall the os multiple times unsuccessfully, have tried to format and erase Macintosh HD unsuccessfully (error)... I've read you can download the OS X and create a boatable drive from a USB., but in order to do that I need a Mac to download the DMG file! I'm a bit frustrated as I'm trapped in an endless cycle here... Please help!!
     
  13. JReinn macrumors member

    Joined:
    May 22, 2010
    Location:
    Denmark
    #513
    Lately my trash has only worked for iCloud Drive files. I cannot drag and drop normal files to the trash. Whenever I try to delete a normal file (from my main storage) it gives me a warning saying that the file can only be deleted forever.

    Is this a bug or a setting I've turned on by mistake? Or maybe a setting that turns on when you have limited space? I still have 29,84GB of storage left, so I don't see why it should be that way... I'm running the latest High Sierra 10.13.1

    My Mac is in Danish. The message roughly says:
     

    Attached Files:

  14. hipnetic macrumors 6502a

    Joined:
    Oct 5, 2010
    #514
    I'm encountering this same issue editing a fairly large plain text file. Another workaround seems to be to open the text file in TextEdit in the smaller window, scroll to the bottom (you won't really be at the bottom of the text file because of this bug), then maximize the TextEdit window, which will now display the true bottom. Then you can resize the window back to the size you want and the entire text file should still be available to scroll around to. Your workaround is a lot simpler!
     
  15. sahyun macrumors newbie

    Joined:
    Dec 3, 2017
    #515
    I have unsupported Mac Pro with ATI GPU. But is there same problem also supported Macs also?[/QUOTE]
    Yes, I have the same issue, except it is a random pdf page, scrolling up or down sometimes changes which page (or part of page) goes red. Also had the login background image go to a flat red and had to replace the default (red) image in the library. Haven't figured out what to do about the red pdf page other than scrolling and hope it goes to a different page. 10.13.1 on 2008 (unsupported) MacPro with ATI 5770.
     
  16. AphoticD macrumors 6502a

    AphoticD

    Joined:
    Feb 17, 2017
    Location:
    Queensland, Australia
    #516
    I came across a performance bug in High Sierra 10.13.1 (clean install) on my iMac 21.5" late 2009 (C2D 3.33Ghz [E8600], 10GB RAM, 256GB mSATA SSD).

    I run all of my Macs as Synergy clients with a MacPro '08 as the Synergy server (v1.6.3 for compatibility), so all mouse and keyboard movements are over the Gigabit network. After taking some photos, I popped an SD card into the side of the iMac, the Photos app launched and instantly I was getting major mouse lag, window movement lag, etc.

    I checked Activity Monitor and there was nothing causing excessive CPU usage (which rarely causes mouse lag on synergy unless i'm pushing it on a G3 or something). Even though the Photo syncing service was pushing only 15-20% CPU usage, it turned out that as soon as I switched off the Photos iCloud sync options, the issue went away. I turned it back on again and the iMac felt like it was experiencing a DMA collision like an old Pentium. (i.e needing to wait for a network activity to finish before being able to move the mouse).

    I've disabled the Photos iCloud syncing now, but I think it's strange for a service like this to absolutely crush a low-bandwidth and low-resource service like Synergy. Has anyone experienced similar lag/collisions between Photo syncing and other network services? File sharing, apache, etc?

    I tried to replicate this issue on my MacBook Unibody '08 running El Capitan and Synergy was fine with or without the Photos sync service running.
     
  17. israces macrumors newbie

    Joined:
    Feb 15, 2017
    #517
    I have the same thing going on. Rebuilt the Trash thinking it was a permissions issue. Worked until reboot and then same issue again. I don't think it's a Trash issue itself, but that this is the manifestation of a different problem. Noticed it after the security updates.

    Anyone have any ideas?

     
  18. majid23 macrumors member

    majid23

    Joined:
    Sep 22, 2008
    #518
    So far it seems all of my issues have been resolved with 10.13.2.

    My MacBook immediately wakes up from sleep now. I also haven't had any brief lockups.

    The media key issue is a "feature" but there are fixes out there.
     
  19. decafjava macrumors 68020

    decafjava

    Joined:
    Feb 7, 2011
    Location:
    Geneva
    #519
    A minor issue but annoying. The calculator on the side notification bar still has a number on it (780.25 on my Mac) that always appears even when I clear it. I mean the calculator on iPhone was fixed ffs.
     
  20. ghostface147 macrumors 68020

    ghostface147

    Joined:
    May 28, 2008
    #520
    HS seems to get stuck when working with Windows File Shares. I can connect to one, browse around, but that's it. Once I try to do something, like delete or copy/paste files, it just locks up and I have to force shutdown and restart to get the Finder to work again. I don't know 100% for sure if this is because of the KRACK update, but even using the supplied terminal commands in a different thread doesn't fix the issue. Odd. I also never dealt with windows file shares after the KRACK update to 10.13.1, so who knows. It wasn't an issue in plain ol' 10.13.1.
     
  21. big610 macrumors newbie

    Joined:
    Sep 26, 2016
    #521
    Update to 10.13.2

    Network File Sharing,
    just looking at Windows,
    Beachball Freezes Finder, must unplug power, can't even restart.


    Was perfect in 10.13.1.
    Wish Apple would check their work first before implemented untested changes.

    Quite an inconvenience. Will end up costing me hours of extra time ever day, till fixed.
    Should not have to wait two months till 10.13.3.

    The good news 10.13.2 fixes MP3 Album Art to finally appear.
    I rather have a working Network, that I constantly do not have to keep unplugging.
     
  22. cmChimera macrumors 68040

    cmChimera

    Joined:
    Feb 12, 2010
    #522
    Go to folder"~/Library/Containers/com.apple.ncplugin.calculator/Data/Library/Preferences" and remove the file "com.apple.ncplugin.calculator.plist"
     
  23. tmoney468 macrumors 6502a

    Joined:
    Mar 13, 2007
    #523
    Anyone else have issues with Finder not updating the free space after deleting files? I've ran across this multiple times now, and this past time I deleted over 15GB of files and it still hasn't updated yet
     
  24. cool11 macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #524

    Wow, at least one more forum member here with the same problem!
    My hard disk had occupied about 165gb before 10.13.2 update.
    Now it shows as occupied about 200gb!!!
    What is this? A bug?
    I am trying to find out what is going on with applications like 'daisydisk' for disk usage, but I can't discover anything strange or anything made by me during the last days.

    Please, somebody post a solution here...unbelievable problem....
    :(
     
  25. bopajuice macrumors 6502a

    bopajuice

    Joined:
    Mar 22, 2016
    #525
    I am so tired of the bugs. Lately when I try to cut and paste some text from a pdf using Preview into a word document it copies some of the text, or sometimes all of the formatting disappears... or it pastes to a word document with a different font and font size. Or it highlights a bunch of text I don’t want to copy. I have had to revert to opening a pdf in Chrome and then cut and paste into Word in order to get the format to match up and to be able to highlight only what I select. Only happened when I upgraded to high sierra.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page