macOS High Sierra (10.13) Unsupported Macs Thread

Discussion in 'macOS High Sierra (10.13)' started by foxlet, Jun 5, 2017.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. fheusel, Dec 6, 2017
    Last edited: Dec 6, 2017

    fheusel macrumors newbie

    Joined:
    Jul 10, 2012
    #2576
    I installed the 10.13.2 update on my iMac9,1 (GT120) and now Safari does not render any webpage and the AppStore stays blank and shows no content..

    Same issue as described in this post, but NVRAM Reset didn't fix it for me.. :-(
     
  2. shaocaholica macrumors member

    shaocaholica

    Joined:
    May 26, 2010
  3. dosdude1 macrumors 6502a

    dosdude1

    Joined:
    Feb 16, 2012
    #2578
    Download Onyx, open it, and run the Automation script. This fixes the Safari and App Store issues.
     
  4. nekton1 macrumors 6502

    Joined:
    Apr 15, 2010
    Location:
    Asia
    #2579
    No problems here. Downloaded and installed over 10.13.1 (17B1003) in minutes and all working without needing dosdude1's repatching or Onyx fix. MacPro 3,1.

     
  5. fheusel macrumors newbie

    Joined:
    Jul 10, 2012
    #2580
    Indeed it fixed the issues - thanks for your quick reply.
     
  6. craigtheguru macrumors newbie

    Joined:
    Oct 1, 2017
    #2581
    Aside from the root user Security patch which rolled out for 10.13.0, I am super not eager to disrupt my working High Sierra 3,1 Mac Pro. Sleep, HandOff, Apple Watch3 unlock, iCloud, iPhone X support... all the great features™! So for now I will patiently wait until I need to upgrade and the jump to the latest point release.
     
  7. ATC, Dec 6, 2017
    Last edited: Dec 6, 2017

    ATC macrumors 6502a

    Joined:
    Apr 25, 2008
    Location:
    Canada
    #2582
    Sorry for the noob question but I have the same iMac (9,1 with GT120) and about to install the update to 10.13.2 from 10.13.1 but I don't know anything about Onyx. Is this a program that we can download from somewhere? And is the Automation script referred to something extra or built in?

    Finally found out what Onyx is and installed it. I also lost Safari and App Store functionality after update, running Onyx Automation fixed all. Interestingly in the App Store after updating, it doesn't show the updates completed from today, the last thing it shows is the 2017-001 Security update.
     
  8. sumer macrumors regular

    Joined:
    Mar 2, 2015
    Location:
    Toronto
    #2583
    After I updated to macos 10.13.2 on my mac pro 3.1 it rebooted to a grey screen. I'm assuming i have to repatch
     
  9. evertjr macrumors newbie

    evertjr

    Joined:
    Oct 24, 2016
    #2584
    Updated macbook pro 5,5 to 10.3.2 via app store and everything is fine.
     
  10. EugW, Dec 6, 2017
    Last edited: Dec 6, 2017

    EugW macrumors 68020

    EugW

    Joined:
    Jun 18, 2017
    #2585
    Both of my two patched Macs got the Safari & the App Store issue. I had to run OnyX on both my MacBookPro5,5 and my MacBook5,1 to get internet access back for Safari & the App Store. Chrome always worked fine for both machines, so is this some sort of weird DNS issue? In contrast, all three of my fully supported Macs updated fine.

    BTW, after running OnyX, the 10.13.2 and iTunes update are not listed in Updates Installed, even though they're installed.

    Also, before I ran OnyX, one of my user accounts stopped working. Trying to log in just gave me a forever spinning wheel. I'm not sure if I let it spin long enough, but many minutes ought to be enough to log in, so I hard restarted and ran OnyX.

    Then after running OnyX, upon my first reboot, my MacBookPro5,5 took a long time to reboot, and when it finally finished, it couldn't find a keyboard. I then rebooted yet again, and then all was fine, including that other non-functional login account.

    Given this experience, I don't think I could give (or sell) a Mac like this. I'd want to wait until 10.14 is released, meaning 10.13 has received its last point update. That would minimize issues like this. If someone were to update such a patched machine and weren't tech savvy, this would freak them right out.

    The Automation script is part of OnyX, which can be downloaded here:

    https://www.titanium-software.fr/en/onyx.html

    It asks for extra security access to control the Mac, but I denied that. I just ran the script.
     
  11. macdos macrumors newbie

    Joined:
    Oct 15, 2017
    #2586
    10.13.2 will not work with AMD cards. Repatching doesn't help, it just freezes with graphical garbage at bootup.

    There also seems to be a new AMD kext that is not patched. It doesn't help removing it.

    Had to reinstall 13.0, now I need to figure out how to get 13.1 back.

    Mac Pro 3,1 AMD Radeon HD 7950
     
  12. KernkraftX360 macrumors member

    KernkraftX360

    Joined:
    Sep 23, 2016
    #2587
    I'm still stuck with a mute 10.13.2 Mac Pro 3,1. How do I reinstall audio drivers?
     
  13. Blackriton macrumors newbie

    Blackriton

    Joined:
    Sep 21, 2016
    Location:
    Paris
    #2588
    Same problem here on a Mac Pro 3,1. After running the Only automation script, everything back to normal..............Thanks for the advice..........
     
  14. Schnegg macrumors newbie

    Schnegg

    Joined:
    Oct 9, 2017
    #2589
    Mac Pro 3,1 here. This was a tough one.

    1. I downloaded the update normalley through the App Store.
    2. On reboot I got stuck at the end of the update (same as the 10.13.1 update).
    3. I booted from my dosdude1 USB stick and reapplied the post-install.
    4. Could boot, but had to update the AMD patch to gain GPU acceleration again. Also had the Safari/App Store problem.
    5. Got a warning (from the Patch Updater?) that SIP was on.
    6. Tried the Onyx Automation Script and rebooted, which fixed the Safari/App Store problem.
    7. Still got to disable SIP.

    TL/DR: Make sure the latest post-install is active, zip all the caches and disable SIP.
    --- Post Merged, Dec 7, 2017 at 1:17 AM ---
    Weird, my HD 5770 booted with software acceleration only, which was slow but worked. Have you checked if SIP is active? You can deactivate it from the recovery partition (boot with cmd-R, start Terminal and enter csrutil disable).
     
  15. doobydoooby macrumors newbie

    Joined:
    Oct 17, 2011
    Location:
    Genève, Switzerland
    #2590
    Mac Pro 3,1 with Nividia GTX 680 'flashed native' graphics card:

    Update to 10.13.2 worked with the following steps:
    Installed update from App store, upon reboot I could log in as normal but App store said the update had failed to install. App store then failed to connect.

    I ran the Onyx automation scripts and continuity activation tool, then rebooted. Everything works and the update was applied to 10.13.2
     
  16. Yoshua macrumors newbie

    Yoshua

    Joined:
    Dec 15, 2016
    #2591
    Hello,

    After the update 10.13.2, after restarting the screen goes black.
     
  17. mumux macrumors newbie

    Joined:
    May 4, 2015
    #2592
    I was not able to boot from USB thumb drive (forbidden grey screen).
    A firewire drive did the trick!

    BTW, I'm having some issues with a Radeon R9 280X: red artefacts (mainly in pdf rendering, but also in Safari and sometimes in login screen) but the biggest one is that screen does not wake up from sleep.
    I did patch the AMD drivers, is there (or there will be) a fix or should I'd better move to nvidia cards?

    Thank you
     
  18. Yoshua macrumors newbie

    Yoshua

    Joined:
    Dec 15, 2016
    #2593
    Fixed up.

    But everything is very slow.
    Any solution?
     
  19. W1SS macrumors member

    Joined:
    Aug 20, 2013
    #2594
    Same here... wait for 10.13.3, a supplemental update or rollback to Sierra.
     
  20. Yoshua macrumors newbie

    Yoshua

    Joined:
    Dec 15, 2016
    #2595
    Thanks!!!! But after run Onyx .... It's fine!!!
     
  21. Calixtod macrumors newbie

    Joined:
    Thursday
    #2596
    I tired to upgrade my MacBook Pro Late 2008 (5,1) using dosdude's tool. I somehow must have done something wrong as my computer is COMPLETELY borked. Is there a way to try to repair the installation?
    My mac no longer display the apple nor makes the bong sound.The only thing that is displayed is the prohibited sign.

    I cannot to a restore nor an internet restore. I cannot boot into single-user mode.

    The only thing that works is a verbose boot which tells me:
    This version is not supported on this platform Reason:Mac-F42D86B8

    I am completely at a loss. My mistake is to have installed the modified installer on another partition of the same disk and tried to do the install that way.

    Can someone help this poor soul to either revert to El Cap or repair this mess ?

    Thanks !
    Please note: My secondary computer is runnning Mint MATE.
     
  22. EugW macrumors 68020

    EugW

    Joined:
    Jun 18, 2017
    #2597
    Did you run the post install patch?
     
  23. MacGuyRookie macrumors newbie

    Joined:
    Dec 8, 2016
    #2598
    I am NOT tech savvy and this DID freak me out!!! Thanks for posting an easy solution.
     
  24. Calixtod macrumors newbie

    Joined:
    Thursday
    #2599
    No because I can't boot to a usable system. I proceeded with the install and went downstairs. When I came up I had my mac displaying the prohibited sign.
     
  25. EugW macrumors 68020

    EugW

    Joined:
    Jun 18, 2017
    #2600
    It’s in the installer. Boot the installer USB drive.

    ie. It sounds like you need to reread the instructions.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page